mbox series

[V2,net-next,00/10] ENA: capabilities field and cosmetic changes

Message ID 20220107202346.3522-1-akiyano@amazon.com (mailing list archive)
Headers show
Series ENA: capabilities field and cosmetic changes | expand

Message

Kiyanovski, Arthur Jan. 7, 2022, 8:23 p.m. UTC
V2 Changes
----------
Fixed "mixing different enum types" warning in patch
10/10 "net: ena: Extract recurring driver reset code into a function"


Original Cover Letter
---------------------
Add a new capabilities bitmask field to get indication of
capabilities supported by the device. Use the capabilities
field to query the device for ENI stats support.

Other patches are cosmetic changes like fixing readme
mistakes, removing unused variables etc...

Arthur Kiyanovski (10):
  net: ena: Change return value of ena_calc_io_queue_size() to void
  net: ena: Add capabilities field with support for ENI stats capability
  net: ena: Change ENI stats support check to use capabilities field
  net: ena: Update LLQ header length in ena documentation
  net: ena: Remove redundant return code check
  net: ena: Move reset completion print to the reset function
  net: ena: Remove ena_calc_queue_size_ctx struct
  net: ena: Add debug prints for invalid req_id resets
  net: ena: Change the name of bad_csum variable
  net: ena: Extract recurring driver reset code into a function

 .../device_drivers/ethernet/amazon/ena.rst    |   2 +-
 .../net/ethernet/amazon/ena/ena_admin_defs.h  |  10 +-
 drivers/net/ethernet/amazon/ena/ena_com.c     |   8 ++
 drivers/net/ethernet/amazon/ena/ena_com.h     |  13 ++
 drivers/net/ethernet/amazon/ena/ena_ethtool.c |  15 ++-
 drivers/net/ethernet/amazon/ena/ena_netdev.c  | 125 +++++++-----------
 drivers/net/ethernet/amazon/ena/ena_netdev.h  |  24 ++--
 7 files changed, 95 insertions(+), 102 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Jan. 8, 2022, 3:30 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by Jakub Kicinski <kuba@kernel.org>:

On Fri, 7 Jan 2022 20:23:36 +0000 you wrote:
> V2 Changes
> ----------
> Fixed "mixing different enum types" warning in patch
> 10/10 "net: ena: Extract recurring driver reset code into a function"
> 
> 
> Original Cover Letter
> 
> [...]

Here is the summary with links:
  - [V2,net-next,01/10] net: ena: Change return value of ena_calc_io_queue_size() to void
    https://git.kernel.org/netdev/net-next/c/7dcf92215227
  - [V2,net-next,02/10] net: ena: Add capabilities field with support for ENI stats capability
    https://git.kernel.org/netdev/net-next/c/a2d5d6a70fa5
  - [V2,net-next,03/10] net: ena: Change ENI stats support check to use capabilities field
    https://git.kernel.org/netdev/net-next/c/394c48e08bbc
  - [V2,net-next,04/10] net: ena: Update LLQ header length in ena documentation
    https://git.kernel.org/netdev/net-next/c/273a2397fc91
  - [V2,net-next,05/10] net: ena: Remove redundant return code check
    https://git.kernel.org/netdev/net-next/c/09f8676eae1d
  - [V2,net-next,06/10] net: ena: Move reset completion print to the reset function
    https://git.kernel.org/netdev/net-next/c/e34454698033
  - [V2,net-next,07/10] net: ena: Remove ena_calc_queue_size_ctx struct
    https://git.kernel.org/netdev/net-next/c/c215941abacf
  - [V2,net-next,08/10] net: ena: Add debug prints for invalid req_id resets
    https://git.kernel.org/netdev/net-next/c/9b648bb1d89e
  - [V2,net-next,09/10] net: ena: Change the name of bad_csum variable
    https://git.kernel.org/netdev/net-next/c/d0e8831d6c93
  - [V2,net-next,10/10] net: ena: Extract recurring driver reset code into a function
    https://git.kernel.org/netdev/net-next/c/9fe890cc5bb8

You are awesome, thank you!