mbox series

[net-next,00/12] mlxsw: Various updates

Message ID 20220222171703.499645-1-idosch@nvidia.com (mailing list archive)
Headers show
Series mlxsw: Various updates | expand

Message

Ido Schimmel Feb. 22, 2022, 5:16 p.m. UTC
This patchset contains miscellaneous updates to mlxsw gathered over
time.

Patches #1-#2 fix recent regressions present in net-next.

Patches #3-#11 are small cleanups performed while adding line card
support in mlxsw.

Patch #12 adds the SFF-8024 Identifier Value of OSFP transceiver in
order to be able to dump their EEPROM contents over the ethtool IOCTL
interface.

Danielle Ratson (1):
  mlxsw: core: Add support for OSFP transceiver modules

Ido Schimmel (2):
  mlxsw: spectrum_span: Ignore VLAN entries not used by the bridge in
    mirroring
  mlxsw: Remove resource query check

Jiri Pirko (1):
  mlxsw: spectrum: Remove SP{1,2,3} defines for FW minor and subminor

Vadim Pasternak (8):
  mlxsw: core: Prevent trap group setting if driver does not support
    EMAD
  mlxsw: core_thermal: Avoid creation of virtual hwmon objects by
    thermal module
  mlxsw: core_hwmon: Fix variable names for hwmon attributes
  mlxsw: core_thermal: Rename labels according to naming convention
  mlxsw: core_thermal: Remove obsolete API for query resource
  mlxsw: reg: Add "mgpir_" prefix to MGPIR fields comments
  mlxsw: core: Remove unnecessary asserts
  mlxsw: core: Unify method of trap support validation

 drivers/net/ethernet/mellanox/mlxsw/core.c    | 32 +++-----
 drivers/net/ethernet/mellanox/mlxsw/core.h    |  7 --
 .../net/ethernet/mellanox/mlxsw/core_env.c    | 38 +--------
 .../net/ethernet/mellanox/mlxsw/core_hwmon.c  | 79 +++++++++----------
 .../ethernet/mellanox/mlxsw/core_thermal.c    | 66 ++++++++--------
 drivers/net/ethernet/mellanox/mlxsw/minimal.c |  1 -
 drivers/net/ethernet/mellanox/mlxsw/reg.h     |  9 ++-
 .../net/ethernet/mellanox/mlxsw/spectrum.c    | 45 ++++-------
 .../ethernet/mellanox/mlxsw/spectrum_span.c   |  3 +-
 9 files changed, 106 insertions(+), 174 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Feb. 23, 2022, 12:50 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:

On Tue, 22 Feb 2022 19:16:51 +0200 you wrote:
> This patchset contains miscellaneous updates to mlxsw gathered over
> time.
> 
> Patches #1-#2 fix recent regressions present in net-next.
> 
> Patches #3-#11 are small cleanups performed while adding line card
> support in mlxsw.
> 
> [...]

Here is the summary with links:
  - [net-next,01/12] mlxsw: core: Prevent trap group setting if driver does not support EMAD
    https://git.kernel.org/netdev/net-next/c/c035ea76c4e7
  - [net-next,02/12] mlxsw: spectrum_span: Ignore VLAN entries not used by the bridge in mirroring
    https://git.kernel.org/netdev/net-next/c/42c9135fef9b
  - [net-next,03/12] mlxsw: core_thermal: Avoid creation of virtual hwmon objects by thermal module
    https://git.kernel.org/netdev/net-next/c/f8a36880f474
  - [net-next,04/12] mlxsw: core_hwmon: Fix variable names for hwmon attributes
    https://git.kernel.org/netdev/net-next/c/bed8f4197cb2
  - [net-next,05/12] mlxsw: core_thermal: Rename labels according to naming convention
    https://git.kernel.org/netdev/net-next/c/009da9fad567
  - [net-next,06/12] mlxsw: core_thermal: Remove obsolete API for query resource
    https://git.kernel.org/netdev/net-next/c/bfb82c9cceac
  - [net-next,07/12] mlxsw: reg: Add "mgpir_" prefix to MGPIR fields comments
    https://git.kernel.org/netdev/net-next/c/719fc0662cdc
  - [net-next,08/12] mlxsw: core: Remove unnecessary asserts
    https://git.kernel.org/netdev/net-next/c/af9911c569d5
  - [net-next,09/12] mlxsw: spectrum: Remove SP{1,2,3} defines for FW minor and subminor
    https://git.kernel.org/netdev/net-next/c/8b5f555be8f2
  - [net-next,10/12] mlxsw: core: Unify method of trap support validation
    https://git.kernel.org/netdev/net-next/c/902992d18f5a
  - [net-next,11/12] mlxsw: Remove resource query check
    https://git.kernel.org/netdev/net-next/c/cc4d3de99052
  - [net-next,12/12] mlxsw: core: Add support for OSFP transceiver modules
    https://git.kernel.org/netdev/net-next/c/f881c4ab37db

You are awesome, thank you!