mbox series

[net-next,00/15] mlxsw: Spectrum-2 PTP preparations

Message ID 20220724080329.2613617-1-idosch@nvidia.com (mailing list archive)
Headers show
Series mlxsw: Spectrum-2 PTP preparations | expand

Message

Ido Schimmel July 24, 2022, 8:03 a.m. UTC
This patchset includes various preparations required for Spectrum-2 PTP
support.

Most of the changes are non-functional (e.g., renaming, adding
registers). The only intentional user visible change is in patch #10
where the PHC time is initialized to zero in accordance with the
recommendation of the PTP maintainer.

Amit Cohen (7):
  mlxsw: resources: Add resource identifier for maximum number of FIDs
  mlxsw: spectrum_ptp: Initialize the clock to zero as part of
    initialization
  mlxsw: pci: Simplify FRC clock reading
  mlxsw: spectrum_ptp: Use 'struct mlxsw_sp_ptp_state' per ASIC
  mlxsw: spectrum_ptp: Use 'struct mlxsw_sp_ptp_clock' per ASIC
  mlxsw: spectrum_ptp: Rename mlxsw_sp_ptp_get_message_types()
  mlxsw: spectrum_ptp: Rename mlxsw_sp1_ptp_phc_adjfreq()

Danielle Ratson (8):
  mlxsw: Rename mlxsw_reg_mtptptp_pack() to mlxsw_reg_mtptpt_pack()
  mlxsw: reg: Add MTUTC register's fields for supporting PTP in
    Spectrum-2
  mlxsw: reg: Add Monitoring Time Precision Correction Port
    Configuration Register
  mlxsw: pci_hw: Add 'time_stamp' and 'time_stamp_type' fields to CQEv2
  mlxsw: cmd: Add UTC related fields to query firmware command
  mlxsw: Set time stamp type as part of config profile
  mlxsw: spectrum: Fix the shift of FID field in TX header
  mlxsw: Rename 'read_frc_capable' bit to 'read_clock_capable'

 drivers/net/ethernet/mellanox/mlxsw/cmd.h     |  52 ++++++
 drivers/net/ethernet/mellanox/mlxsw/core.h    |   6 +-
 drivers/net/ethernet/mellanox/mlxsw/pci.c     |  27 +++-
 drivers/net/ethernet/mellanox/mlxsw/pci_hw.h  |  81 +++++++++-
 drivers/net/ethernet/mellanox/mlxsw/reg.h     |  99 +++++++++++-
 .../net/ethernet/mellanox/mlxsw/resources.h   |   2 +
 .../net/ethernet/mellanox/mlxsw/spectrum.c    |   6 +-
 .../ethernet/mellanox/mlxsw/spectrum_ptp.c    | 148 +++++++++++-------
 8 files changed, 344 insertions(+), 77 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org July 25, 2022, 1:10 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:

On Sun, 24 Jul 2022 11:03:14 +0300 you wrote:
> This patchset includes various preparations required for Spectrum-2 PTP
> support.
> 
> Most of the changes are non-functional (e.g., renaming, adding
> registers). The only intentional user visible change is in patch #10
> where the PHC time is initialized to zero in accordance with the
> recommendation of the PTP maintainer.
> 
> [...]

Here is the summary with links:
  - [net-next,01/15] mlxsw: Rename mlxsw_reg_mtptptp_pack() to mlxsw_reg_mtptpt_pack()
    https://git.kernel.org/netdev/net-next/c/1c358fedecd1
  - [net-next,02/15] mlxsw: reg: Add MTUTC register's fields for supporting PTP in Spectrum-2
    https://git.kernel.org/netdev/net-next/c/97b05cfb68ae
  - [net-next,03/15] mlxsw: reg: Add Monitoring Time Precision Correction Port Configuration Register
    https://git.kernel.org/netdev/net-next/c/731416e9ae5d
  - [net-next,04/15] mlxsw: pci_hw: Add 'time_stamp' and 'time_stamp_type' fields to CQEv2
    https://git.kernel.org/netdev/net-next/c/aa98487cc96b
  - [net-next,05/15] mlxsw: cmd: Add UTC related fields to query firmware command
    https://git.kernel.org/netdev/net-next/c/577d80238ff7
  - [net-next,06/15] mlxsw: Set time stamp type as part of config profile
    https://git.kernel.org/netdev/net-next/c/291fcb937e95
  - [net-next,07/15] mlxsw: spectrum: Fix the shift of FID field in TX header
    https://git.kernel.org/netdev/net-next/c/81016180e3f4
  - [net-next,08/15] mlxsw: resources: Add resource identifier for maximum number of FIDs
    https://git.kernel.org/netdev/net-next/c/448e9cb3631e
  - [net-next,09/15] mlxsw: Rename 'read_frc_capable' bit to 'read_clock_capable'
    https://git.kernel.org/netdev/net-next/c/33a9583f9a02
  - [net-next,10/15] mlxsw: spectrum_ptp: Initialize the clock to zero as part of initialization
    https://git.kernel.org/netdev/net-next/c/22d950b79ea7
  - [net-next,11/15] mlxsw: pci: Simplify FRC clock reading
    https://git.kernel.org/netdev/net-next/c/946832296389
  - [net-next,12/15] mlxsw: spectrum_ptp: Use 'struct mlxsw_sp_ptp_state' per ASIC
    https://git.kernel.org/netdev/net-next/c/e8fea346b556
  - [net-next,13/15] mlxsw: spectrum_ptp: Use 'struct mlxsw_sp_ptp_clock' per ASIC
    https://git.kernel.org/netdev/net-next/c/9bfe3c16fc23
  - [net-next,14/15] mlxsw: spectrum_ptp: Rename mlxsw_sp_ptp_get_message_types()
    https://git.kernel.org/netdev/net-next/c/4017d9296492
  - [net-next,15/15] mlxsw: spectrum_ptp: Rename mlxsw_sp1_ptp_phc_adjfreq()
    https://git.kernel.org/netdev/net-next/c/a168e13f8448

You are awesome, thank you!