mbox series

[v3,0/9] ptp .adjphase cleanups

Message ID 20230612211500.309075-1-rrameshbabu@nvidia.com (mailing list archive)
Headers show
Series ptp .adjphase cleanups | expand

Message

Rahul Rameshbabu June 12, 2023, 9:14 p.m. UTC
The goal of this patch series is to improve documentation of .adjphase, add
a new callback .getmaxphase to enable advertising the max phase offset a
device PHC can support, and support invoking .adjphase from the testptp
kselftest.

Changes:
  v3->v2:
    * Add information about returning -ERANGE instead of clamping
      out-of-range offsets for driver implementations of .adjphase that
      previously clamped out-of-range offsets.

      Link: https://lore.kernel.org/netdev/13b7315446390d3a78d8f508937354f12778b68e.camel@redhat.com/
  v2->v1:
    * Removes arbitrary rule that the PHC servo must restore the frequency
      to the value used in the last .adjfine call if any other PHC
      operation is used after a .adjphase operation.
    * Removes a macro introduced in v1 for adding PTP sysfs device
      attribute nodes using a callback for populating the data.

Link: https://lore.kernel.org/netdev/20230523205440.326934-1-rrameshbabu@nvidia.com/ 
Link: https://lore.kernel.org/netdev/20230510205306.136766-1-rrameshbabu@nvidia.com/
Link: https://lore.kernel.org/netdev/20230120160609.19160723@kernel.org/

Cc: Jakub Kicinski <kuba@kernel.org>
Cc: Richard Cochran <richardcochran@gmail.com>

Rahul Rameshbabu (9):
  ptp: Clarify ptp_clock_info .adjphase expects an internal servo to be
    used
  docs: ptp.rst: Add information about NVIDIA Mellanox devices
  testptp: Remove magic numbers related to nanosecond to second
    conversion
  testptp: Add support for testing ptp_clock_info .adjphase callback
  ptp: Add .getmaxphase callback to ptp_clock_info
  net/mlx5: Add .getmaxphase ptp_clock_info callback
  ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback
  ptp: idt82p33: Add .getmaxphase ptp_clock_info callback
  ptp: ocp: Add .getmaxphase ptp_clock_info callback

 Documentation/driver-api/ptp.rst              | 29 +++++++++++++++
 .../ethernet/mellanox/mlx5/core/lib/clock.c   | 31 ++++++++--------
 drivers/ptp/ptp_chardev.c                     |  5 ++-
 drivers/ptp/ptp_clock.c                       |  4 +++
 drivers/ptp/ptp_clockmatrix.c                 | 36 +++++++++----------
 drivers/ptp/ptp_clockmatrix.h                 |  2 +-
 drivers/ptp/ptp_idt82p33.c                    | 18 +++++-----
 drivers/ptp/ptp_idt82p33.h                    |  4 +--
 drivers/ptp/ptp_ocp.c                         |  7 ++++
 drivers/ptp/ptp_sysfs.c                       | 12 +++++++
 include/linux/ptp_clock_kernel.h              | 11 ++++--
 include/uapi/linux/ptp_clock.h                |  3 +-
 tools/testing/selftests/ptp/testptp.c         | 29 ++++++++++++---
 13 files changed, 135 insertions(+), 56 deletions(-)

Comments

Rahul Rameshbabu June 12, 2023, 9:25 p.m. UTC | #1
On Mon, 12 Jun, 2023 14:14:51 -0700 Rahul Rameshbabu <rrameshbabu@nvidia.com> wrote:
> The goal of this patch series is to improve documentation of .adjphase, add
> a new callback .getmaxphase to enable advertising the max phase offset a
> device PHC can support, and support invoking .adjphase from the testptp
> kselftest.
>
> Changes:
>   v3->v2:
>     * Add information about returning -ERANGE instead of clamping
>       out-of-range offsets for driver implementations of .adjphase that
>       previously clamped out-of-range offsets.
>
>       Link: https://lore.kernel.org/netdev/13b7315446390d3a78d8f508937354f12778b68e.camel@redhat.com/
>   v2->v1:
>     * Removes arbitrary rule that the PHC servo must restore the frequency
>       to the value used in the last .adjfine call if any other PHC
>       operation is used after a .adjphase operation.
>     * Removes a macro introduced in v1 for adding PTP sysfs device
>       attribute nodes using a callback for populating the data.
>
> Link: https://lore.kernel.org/netdev/20230523205440.326934-1-rrameshbabu@nvidia.com/ 
> Link: https://lore.kernel.org/netdev/20230510205306.136766-1-rrameshbabu@nvidia.com/
> Link: https://lore.kernel.org/netdev/20230120160609.19160723@kernel.org/
>
> Cc: Jakub Kicinski <kuba@kernel.org>
> Cc: Richard Cochran <richardcochran@gmail.com>

Sorry that this submission did not correctly target the net-next tree in
the subject. I have been submitting to other subsystems and forgot to
target the correct tree in the subject of this patch series.

-- Rahul Rameshbabu
patchwork-bot+netdevbpf@kernel.org June 20, 2023, 8:10 a.m. UTC | #2
Hello:

This series was applied to netdev/net-next.git (main)
by David S. Miller <davem@davemloft.net>:

On Mon, 12 Jun 2023 14:14:51 -0700 you wrote:
> The goal of this patch series is to improve documentation of .adjphase, add
> a new callback .getmaxphase to enable advertising the max phase offset a
> device PHC can support, and support invoking .adjphase from the testptp
> kselftest.
> 
> Changes:
>   v3->v2:
>     * Add information about returning -ERANGE instead of clamping
>       out-of-range offsets for driver implementations of .adjphase that
>       previously clamped out-of-range offsets.
> 
> [...]

Here is the summary with links:
  - [v3,1/9] ptp: Clarify ptp_clock_info .adjphase expects an internal servo to be used
    https://git.kernel.org/netdev/net-next/c/a05d070a6164
  - [v3,2/9] docs: ptp.rst: Add information about NVIDIA Mellanox devices
    https://git.kernel.org/netdev/net-next/c/fe3834cd0cf7
  - [v3,3/9] testptp: Remove magic numbers related to nanosecond to second conversion
    https://git.kernel.org/netdev/net-next/c/048f6d998eac
  - [v3,4/9] testptp: Add support for testing ptp_clock_info .adjphase callback
    https://git.kernel.org/netdev/net-next/c/3a9a9a613928
  - [v3,5/9] ptp: Add .getmaxphase callback to ptp_clock_info
    https://git.kernel.org/netdev/net-next/c/c3b60ab7a4df
  - [v3,6/9] net/mlx5: Add .getmaxphase ptp_clock_info callback
    https://git.kernel.org/netdev/net-next/c/67ac72a599d8
  - [v3,7/9] ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback
    https://git.kernel.org/netdev/net-next/c/c066e74f34bc
  - [v3,8/9] ptp: idt82p33: Add .getmaxphase ptp_clock_info callback
    https://git.kernel.org/netdev/net-next/c/e156e4d2e43f
  - [v3,9/9] ptp: ocp: Add .getmaxphase ptp_clock_info callback
    https://git.kernel.org/netdev/net-next/c/d8ee5ca845b4

You are awesome, thank you!