mbox series

[net-next,00/15] mlxsw: Preparations for improving performance

Message ID cover.1712062203.git.petrm@nvidia.com (mailing list archive)
Headers show
Series mlxsw: Preparations for improving performance | expand

Message

Petr Machata April 2, 2024, 1:54 p.m. UTC
Amit Cohen writes:

mlxsw driver will use NAPI for event processing in a next patch set.
Some additional improvements will be added later. This patch set
prepares the code for NAPI usage and refactor some relevant areas. See
more details in commit messages.

Patch Set overview:
Patches #1-#2 are preparations for patch #3
Patch #3 setups tasklets as part of queue initializtion
Patch #4 removes handling of unlikely scenario
Patch #5 removes unused counters
Patch #6 makes style change in mlxsw_pci_eq_tasklet()
Patch #7-#10 poll command interface instead of EQ0 usage
Patches #11-#12 make style change and break the function
mlxsw_pci_cq_tasklet()
Patches #13-#14 remove functions which can be replaced by a stored value
Patch #15 improves accessing to descriptor queue instance

Amit Cohen (15):
  mlxsw: pci: Move mlxsw_pci_eq_{init, fini}()
  mlxsw: pci: Move mlxsw_pci_cq_{init, fini}()
  mlxsw: pci: Do not setup tasklet from operation
  mlxsw: pci: Arm CQ doorbell regardless of number of completions
  mlxsw: pci: Remove unused counters
  mlxsw: pci: Make style changes in mlxsw_pci_eq_tasklet()
  mlxsw: pci: Poll command interface for each cmd_exec()
  mlxsw: pci: Rename MLXSW_PCI_EQS_COUNT
  mlxsw: pci: Use only one event queue
  mlxsw: pci: Remove unused wait queue
  mlxsw: pci: Make style change in mlxsw_pci_cq_tasklet()
  mlxsw: pci: Break mlxsw_pci_cq_tasklet() into tasklets per queue type
  mlxsw: pci: Remove mlxsw_pci_sdq_count()
  mlxsw: pci: Remove mlxsw_pci_cq_count()
  mlxsw: pci: Store DQ pointer as part of CQ structure

 drivers/net/ethernet/mellanox/mlxsw/pci.c    | 492 ++++++++++---------
 drivers/net/ethernet/mellanox/mlxsw/pci_hw.h |   4 +-
 2 files changed, 250 insertions(+), 246 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org April 4, 2024, 3:50 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Tue, 2 Apr 2024 15:54:13 +0200 you wrote:
> Amit Cohen writes:
> 
> mlxsw driver will use NAPI for event processing in a next patch set.
> Some additional improvements will be added later. This patch set
> prepares the code for NAPI usage and refactor some relevant areas. See
> more details in commit messages.
> 
> [...]

Here is the summary with links:
  - [net-next,01/15] mlxsw: pci: Move mlxsw_pci_eq_{init, fini}()
    https://git.kernel.org/netdev/net-next/c/d38718a525a3
  - [net-next,02/15] mlxsw: pci: Move mlxsw_pci_cq_{init, fini}()
    https://git.kernel.org/netdev/net-next/c/f46de9f0e70c
  - [net-next,03/15] mlxsw: pci: Do not setup tasklet from operation
    https://git.kernel.org/netdev/net-next/c/fb29028ae718
  - [net-next,04/15] mlxsw: pci: Arm CQ doorbell regardless of number of completions
    https://git.kernel.org/netdev/net-next/c/38b124cb4ee5
  - [net-next,05/15] mlxsw: pci: Remove unused counters
    https://git.kernel.org/netdev/net-next/c/57beea8e5667
  - [net-next,06/15] mlxsw: pci: Make style changes in mlxsw_pci_eq_tasklet()
    https://git.kernel.org/netdev/net-next/c/29ad2a990648
  - [net-next,07/15] mlxsw: pci: Poll command interface for each cmd_exec()
    https://git.kernel.org/netdev/net-next/c/d4b3930b19f7
  - [net-next,08/15] mlxsw: pci: Rename MLXSW_PCI_EQS_COUNT
    https://git.kernel.org/netdev/net-next/c/7bc6a3098c38
  - [net-next,09/15] mlxsw: pci: Use only one event queue
    https://git.kernel.org/netdev/net-next/c/6fc280a36515
  - [net-next,10/15] mlxsw: pci: Remove unused wait queue
    https://git.kernel.org/netdev/net-next/c/2c200863fcc7
  - [net-next,11/15] mlxsw: pci: Make style change in mlxsw_pci_cq_tasklet()
    https://git.kernel.org/netdev/net-next/c/a0639236d420
  - [net-next,12/15] mlxsw: pci: Break mlxsw_pci_cq_tasklet() into tasklets per queue type
    https://git.kernel.org/netdev/net-next/c/1df7d871e349
  - [net-next,13/15] mlxsw: pci: Remove mlxsw_pci_sdq_count()
    https://git.kernel.org/netdev/net-next/c/0cd1453b7e55
  - [net-next,14/15] mlxsw: pci: Remove mlxsw_pci_cq_count()
    https://git.kernel.org/netdev/net-next/c/82238f0ddb46
  - [net-next,15/15] mlxsw: pci: Store DQ pointer as part of CQ structure
    https://git.kernel.org/netdev/net-next/c/77c6e27df9e5

You are awesome, thank you!