Message ID | 20210519025639.12108-1-yuehaibing@huawei.com (mailing list archive) |
---|---|
State | Not Applicable |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | [net-next] net/9p: use DEVICE_ATTR_RO macro | expand |
Context | Check | Description |
---|---|---|
netdev/cover_letter | success | Link |
netdev/fixes_present | success | Link |
netdev/patch_count | success | Link |
netdev/tree_selection | success | Clearly marked for net-next |
netdev/subject_prefix | success | Link |
netdev/cc_maintainers | success | CCed 7 of 7 maintainers |
netdev/source_inline | success | Was 0 now: 0 |
netdev/verify_signedoff | success | Link |
netdev/module_param | success | Was 0 now: 0 |
netdev/build_32bit | success | Errors and warnings before: 0 this patch: 0 |
netdev/kdoc | success | Errors and warnings before: 0 this patch: 0 |
netdev/verify_fixes | success | Link |
netdev/checkpatch | success | total: 0 errors, 0 warnings, 0 checks, 18 lines checked |
netdev/build_allmodconfig_warn | success | Errors and warnings before: 0 this patch: 0 |
netdev/header_inline | success | Link |
YueHaibing wrote on Wed, May 19, 2021 at 10:56:39AM +0800: > Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR, > which makes the code a bit shorter and easier to read. > > Signed-off-by: YueHaibing <yuehaibing@huawei.com> Sure, why not. Will queue to -next tomorrow-ish
diff --git a/net/9p/trans_virtio.c b/net/9p/trans_virtio.c index 93f2f8654882..43339f314a86 100644 --- a/net/9p/trans_virtio.c +++ b/net/9p/trans_virtio.c @@ -528,8 +528,8 @@ p9_virtio_zc_request(struct p9_client *client, struct p9_req_t *req, return err; } -static ssize_t p9_mount_tag_show(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t mount_tag_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct virtio_chan *chan; struct virtio_device *vdev; @@ -544,7 +544,7 @@ static ssize_t p9_mount_tag_show(struct device *dev, return tag_len + 1; } -static DEVICE_ATTR(mount_tag, 0444, p9_mount_tag_show, NULL); +static DEVICE_ATTR_RO(mount_tag); /** * p9_virtio_probe - probe for existence of 9P virtio channels
Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: YueHaibing <yuehaibing@huawei.com> --- net/9p/trans_virtio.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)