diff mbox series

af_unix: Rename UNIX-DGRAM to UNIX to maintain backwards compatability

Message ID 20211008215946.3961353-1-swboyd@chromium.org (mailing list archive)
State Accepted
Commit 0edf0824e0dc359ed76bf96af986e6570ca2c0b9
Delegated to: Netdev Maintainers
Headers show
Series af_unix: Rename UNIX-DGRAM to UNIX to maintain backwards compatability | expand

Checks

Context Check Description
netdev/cover_letter success Single patches do not need cover letters
netdev/fixes_present success Fixes tag not required for -next series
netdev/patch_count success Link
netdev/tree_selection success Guessed tree name to be net-next
netdev/subject_prefix warning Target tree name not specified in the subject
netdev/cc_maintainers warning 6 maintainers not CCed: Rao.Shoaib@oracle.com christian.brauner@ubuntu.com viro@zeniv.linux.org.uk edumazet@google.com kuniyu@amazon.co.jp ast@kernel.org
netdev/source_inline success Was 0 now: 0
netdev/verify_signedoff success Signed-off-by tag matches author and committer
netdev/module_param success Was 0 now: 0
netdev/build_32bit success Errors and warnings before: 4 this patch: 4
netdev/kdoc success Errors and warnings before: 0 this patch: 0
netdev/verify_fixes success Fixes tag looks correct
netdev/checkpatch success total: 0 errors, 0 warnings, 0 checks, 8 lines checked
netdev/build_allmodconfig_warn success Errors and warnings before: 4 this patch: 4
netdev/header_inline success No static functions without inline keyword in header files

Commit Message

Stephen Boyd Oct. 8, 2021, 9:59 p.m. UTC
Then name of this protocol changed in commit 94531cfcbe79 ("af_unix: Add
unix_stream_proto for sockmap") because that commit added stream support
to the af_unix protocol. Renaming the existing protocol makes a ChromeOS
protocol test[1] fail now that the name has changed in
/proc/net/protocols from "UNIX" to "UNIX-DGRAM".

Let's put the name back to how it was while keeping the stream protocol
as "UNIX-STREAM" so that the procfs interface doesn't change. This fixes
the test and maintains backwards compatibility in proc.

Cc: Jiang Wang <jiang.wang@bytedance.com>
Cc: Andrii Nakryiko <andrii@kernel.org>
Cc: Cong Wang <cong.wang@bytedance.com>
Cc: Jakub Sitnicki <jakub@cloudflare.com>
Cc: John Fastabend <john.fastabend@gmail.com>
Cc: Dmitry Osipenko <digetx@gmail.com>
Link: https://source.chromium.org/chromiumos/chromiumos/codesearch/+/main:src/platform/tast-tests/src/chromiumos/tast/local/bundles/cros/network/supported_protocols.go;l=50;drc=e8b1c3f94cb40a054f4aa1ef1aff61e75dc38f18 [1]
Fixes: 94531cfcbe79 ("af_unix: Add unix_stream_proto for sockmap")
Signed-off-by: Stephen Boyd <swboyd@chromium.org>
---
 net/unix/af_unix.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 9e1ff307c779ce1f0f810c7ecce3d95bbae40896

Comments

patchwork-bot+netdevbpf@kernel.org Oct. 12, 2021, 10:20 a.m. UTC | #1
Hello:

This patch was applied to netdev/net.git (master)
by David S. Miller <davem@davemloft.net>:

On Fri,  8 Oct 2021 14:59:45 -0700 you wrote:
> Then name of this protocol changed in commit 94531cfcbe79 ("af_unix: Add
> unix_stream_proto for sockmap") because that commit added stream support
> to the af_unix protocol. Renaming the existing protocol makes a ChromeOS
> protocol test[1] fail now that the name has changed in
> /proc/net/protocols from "UNIX" to "UNIX-DGRAM".
> 
> Let's put the name back to how it was while keeping the stream protocol
> as "UNIX-STREAM" so that the procfs interface doesn't change. This fixes
> the test and maintains backwards compatibility in proc.
> 
> [...]

Here is the summary with links:
  - af_unix: Rename UNIX-DGRAM to UNIX to maintain backwards compatability
    https://git.kernel.org/netdev/net/c/0edf0824e0dc

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
diff mbox series

Patch

diff --git a/net/unix/af_unix.c b/net/unix/af_unix.c
index efac5989edb5..26f92325d94b 100644
--- a/net/unix/af_unix.c
+++ b/net/unix/af_unix.c
@@ -828,7 +828,7 @@  static void unix_unhash(struct sock *sk)
 }
 
 struct proto unix_dgram_proto = {
-	.name			= "UNIX-DGRAM",
+	.name			= "UNIX",
 	.owner			= THIS_MODULE,
 	.obj_size		= sizeof(struct unix_sock),
 	.close			= unix_close,