Message ID | 20220621113740.103317-1-jiangjian@cdjrlc.com (mailing list archive) |
---|---|
State | Changes Requested |
Headers | show |
Series | net: s390: drop unexpected word "the" in the comments | expand |
Context | Check | Description |
---|---|---|
netdev/tree_selection | success | Not a local patch |
On 21.06.22 13:37, Jiang Jian wrote: > there is an unexpected word "the" in the comments that need to be dropped > > file: ./drivers/s390/net/qeth_core_main.c > line: 3568 > > * have to request a PCI to be sure the the PCI > changed to > * have to request a PCI to be sure the PCI > > Signed-off-by: Jiang Jian <jiangjian@cdjrlc.com> > --- > drivers/s390/net/qeth_core_main.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/s390/net/qeth_core_main.c b/drivers/s390/net/qeth_core_main.c > index 9e54fe76a9b2..35d4b398c197 100644 > --- a/drivers/s390/net/qeth_core_main.c > +++ b/drivers/s390/net/qeth_core_main.c > @@ -3565,7 +3565,7 @@ static void qeth_flush_buffers(struct qeth_qdio_out_q *queue, int index, > if (!atomic_read(&queue->set_pci_flags_count)) { > /* > * there's no outstanding PCI any more, so we > - * have to request a PCI to be sure the the PCI > + * have to request a PCI to be sure the PCI > * will wake at some time in the future then we > * can flush packed buffers that might still be > * hanging around, which can happen if no Acked-by: Alexandra Winter <wintera@linux.ibm.com>
On Tue, 2022-06-21 at 13:58 +0200, Alexandra Winter wrote: > On 21.06.22 13:37, Jiang Jian wrote: > > there is an unexpected word "the" in the comments that need to be dropped [] > > * have to request a PCI to be sure the the PCI > > * have to request a PCI to be sure the PCI [] > > diff --git a/drivers/s390/net/qeth_core_main.c b/drivers/s390/net/qeth_core_main.c [] > > @@ -3565,7 +3565,7 @@ static void qeth_flush_buffers(struct qeth_qdio_out_q *queue, int index, > > if (!atomic_read(&queue->set_pci_flags_count)) { > > /* > > * there's no outstanding PCI any more, so we > > - * have to request a PCI to be sure the the PCI Might have intended "that the" and not "the the" > > + * have to request a PCI to be sure the PCI > > * will wake at some time in the future then we > > * can flush packed buffers that might still be > > * hanging around, which can happen if no And this is a relatively long sentence. Perhaps something like: if (!atomic_read(&queue->set_pci_flags_count)) { /* * there's no outstanding PCI any more so: * o request a PCI to be sure that the PCI * will wake at some time in the future * o flush packed buffers that might still be * hanging around (which can happen if no * further send was requested by the stack) */
On Tue, 2022-06-21 at 23:21 +0800, 蒋健 wrote:
> So,i need to resubmit a new patch ?
Not necesarily no. Up to you.
And this is a quite old driver that likely doesn't need much
change so if there is a patch at all, maybe simpler is better.
(though all the uses like ? in your reply could be a
reason to either update or perhaps reconfigure your
X-Mailer: QQMail 2.x email client)
cheers, Joe
On 21.06.22 17:01, Joe Perches wrote: > On Tue, 2022-06-21 at 13:58 +0200, Alexandra Winter wrote: >> On 21.06.22 13:37, Jiang Jian wrote: >>> there is an unexpected word "the" in the comments that need to be dropped > [] >>> * have to request a PCI to be sure the the PCI >>> * have to request a PCI to be sure the PCI > [] >>> diff --git a/drivers/s390/net/qeth_core_main.c b/drivers/s390/net/qeth_core_main.c > [] >>> @@ -3565,7 +3565,7 @@ static void qeth_flush_buffers(struct qeth_qdio_out_q *queue, int index, >>> if (!atomic_read(&queue->set_pci_flags_count)) { >>> /* >>> * there's no outstanding PCI any more, so we >>> - * have to request a PCI to be sure the the PCI > > Might have intended "that the" and not "the the" > >>> + * have to request a PCI to be sure the PCI >>> * will wake at some time in the future then we >>> * can flush packed buffers that might still be >>> * hanging around, which can happen if no > > And this is a relatively long sentence. > > Perhaps something like: > > if (!atomic_read(&queue->set_pci_flags_count)) { > /* > * there's no outstanding PCI any more so: > * o request a PCI to be sure that the PCI > * will wake at some time in the future > * o flush packed buffers that might still be > * hanging around (which can happen if no > * further send was requested by the stack) > */ > No, don't remove the word 'then' Not-Acked-by: Alexandra Winter <wintera@linux.ibm.com> Jiang, if you want to submit another patch, You could split the long sentence: if (!atomic_read(&queue->set_pci_flags_count)) { /* * there's no outstanding PCI any more, so we - * have to request a PCI to be sure the the PCI - * will wake at some time in the future then we + * have to request a PCI to be sure the PCI + * will wake at some time in the future. Then we * can flush packed buffers that might still be * hanging around, which can happen if no I don't think this is a significant improvement in readability, though.
diff --git a/drivers/s390/net/qeth_core_main.c b/drivers/s390/net/qeth_core_main.c index 9e54fe76a9b2..35d4b398c197 100644 --- a/drivers/s390/net/qeth_core_main.c +++ b/drivers/s390/net/qeth_core_main.c @@ -3565,7 +3565,7 @@ static void qeth_flush_buffers(struct qeth_qdio_out_q *queue, int index, if (!atomic_read(&queue->set_pci_flags_count)) { /* * there's no outstanding PCI any more, so we - * have to request a PCI to be sure the the PCI + * have to request a PCI to be sure the PCI * will wake at some time in the future then we * can flush packed buffers that might still be * hanging around, which can happen if no
there is an unexpected word "the" in the comments that need to be dropped file: ./drivers/s390/net/qeth_core_main.c line: 3568 * have to request a PCI to be sure the the PCI changed to * have to request a PCI to be sure the PCI Signed-off-by: Jiang Jian <jiangjian@cdjrlc.com> --- drivers/s390/net/qeth_core_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)