diff mbox series

page_pool: fix documentation typos

Message ID 20231001003846.29541-1-rdunlap@infradead.org (mailing list archive)
State Accepted
Commit 513dbc10cfc1da6754e004ea651d6bc480c23eb9
Delegated to: Netdev Maintainers
Headers show
Series page_pool: fix documentation typos | expand

Checks

Context Check Description
netdev/series_format warning Single patches do not need cover letters; Target tree name not specified in the subject
netdev/tree_selection success Guessed tree name to be net-next
netdev/fixes_present success Fixes tag not required for -next series
netdev/header_inline success No static functions without inline keyword in header files
netdev/build_32bit success Errors and warnings before: 1396 this patch: 1396
netdev/cc_maintainers success CCed 7 of 7 maintainers
netdev/build_clang success Errors and warnings before: 1370 this patch: 1370
netdev/verify_signedoff success Signed-off-by tag matches author and committer
netdev/deprecated_api success None detected
netdev/check_selftest success No net selftest shell script
netdev/verify_fixes success No Fixes tag
netdev/build_allmodconfig_warn success Errors and warnings before: 1430 this patch: 1430
netdev/checkpatch success total: 0 errors, 0 warnings, 0 checks, 16 lines checked
netdev/kdoc success Errors and warnings before: 0 this patch: 0
netdev/source_inline success Was 0 now: 0

Commit Message

Randy Dunlap Oct. 1, 2023, 12:38 a.m. UTC
Correct grammar for better readability.

Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
Cc: Jesper Dangaard Brouer <hawk@kernel.org>
Cc: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Cc: netdev@vger.kernel.org
Cc: "David S. Miller" <davem@davemloft.net>
Cc: Eric Dumazet <edumazet@google.com>
Cc: Jakub Kicinski <kuba@kernel.org>
Cc: Paolo Abeni <pabeni@redhat.com>
---
 include/net/page_pool/helpers.h |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Simon Horman Oct. 3, 2023, 10:45 a.m. UTC | #1
On Sat, Sep 30, 2023 at 05:38:45PM -0700, Randy Dunlap wrote:
> Correct grammar for better readability.
> 
> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>

Reviewed-by: Simon Horman <horms@kernel.org>
Ilias Apalodimas Oct. 3, 2023, 3:29 p.m. UTC | #2
Thanks Randy!

On Sun, 1 Oct 2023 at 03:38, Randy Dunlap <rdunlap@infradead.org> wrote:
>
> Correct grammar for better readability.
>
> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
> Cc: Jesper Dangaard Brouer <hawk@kernel.org>
> Cc: Ilias Apalodimas <ilias.apalodimas@linaro.org>
> Cc: netdev@vger.kernel.org
> Cc: "David S. Miller" <davem@davemloft.net>
> Cc: Eric Dumazet <edumazet@google.com>
> Cc: Jakub Kicinski <kuba@kernel.org>
> Cc: Paolo Abeni <pabeni@redhat.com>
> ---
>  include/net/page_pool/helpers.h |    6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff -- a/include/net/page_pool/helpers.h b/include/net/page_pool/helpers.h
> --- a/include/net/page_pool/helpers.h
> +++ b/include/net/page_pool/helpers.h
> @@ -16,13 +16,13 @@
>   * page_pool_alloc_pages() call.  Drivers should use
>   * page_pool_dev_alloc_pages() replacing dev_alloc_pages().
>   *
> - * API keeps track of in-flight pages, in order to let API user know
> + * The API keeps track of in-flight pages, in order to let API users know
>   * when it is safe to free a page_pool object.  Thus, API users
>   * must call page_pool_put_page() to free the page, or attach
> - * the page to a page_pool-aware objects like skbs marked with
> + * the page to a page_pool-aware object like skbs marked with
>   * skb_mark_for_recycle().
>   *
> - * API user must call page_pool_put_page() once on a page, as it
> + * API users must call page_pool_put_page() once on a page, as it
>   * will either recycle the page, or in case of refcnt > 1, it will
>   * release the DMA mapping and in-flight state accounting.
>   */

Acked-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
patchwork-bot+netdevbpf@kernel.org Oct. 4, 2023, 9:30 p.m. UTC | #3
Hello:

This patch was applied to netdev/net.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Sat, 30 Sep 2023 17:38:45 -0700 you wrote:
> Correct grammar for better readability.
> 
> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
> Cc: Jesper Dangaard Brouer <hawk@kernel.org>
> Cc: Ilias Apalodimas <ilias.apalodimas@linaro.org>
> Cc: netdev@vger.kernel.org
> Cc: "David S. Miller" <davem@davemloft.net>
> Cc: Eric Dumazet <edumazet@google.com>
> Cc: Jakub Kicinski <kuba@kernel.org>
> Cc: Paolo Abeni <pabeni@redhat.com>
> 
> [...]

Here is the summary with links:
  - page_pool: fix documentation typos
    https://git.kernel.org/netdev/net/c/513dbc10cfc1

You are awesome, thank you!
diff mbox series

Patch

diff -- a/include/net/page_pool/helpers.h b/include/net/page_pool/helpers.h
--- a/include/net/page_pool/helpers.h
+++ b/include/net/page_pool/helpers.h
@@ -16,13 +16,13 @@ 
  * page_pool_alloc_pages() call.  Drivers should use
  * page_pool_dev_alloc_pages() replacing dev_alloc_pages().
  *
- * API keeps track of in-flight pages, in order to let API user know
+ * The API keeps track of in-flight pages, in order to let API users know
  * when it is safe to free a page_pool object.  Thus, API users
  * must call page_pool_put_page() to free the page, or attach
- * the page to a page_pool-aware objects like skbs marked with
+ * the page to a page_pool-aware object like skbs marked with
  * skb_mark_for_recycle().
  *
- * API user must call page_pool_put_page() once on a page, as it
+ * API users must call page_pool_put_page() once on a page, as it
  * will either recycle the page, or in case of refcnt > 1, it will
  * release the DMA mapping and in-flight state accounting.
  */