diff mbox series

[1/1] idpf: Clean up the vmvf_type for ctlq_recv functions

Message ID 20240312061520.4112782-1-yanjun.zhu@intel.com (mailing list archive)
State Changes Requested
Delegated to: Netdev Maintainers
Headers show
Series [1/1] idpf: Clean up the vmvf_type for ctlq_recv functions | expand

Checks

Context Check Description
netdev/series_format warning Single patches do not need cover letters; Target tree name not specified in the subject
netdev/tree_selection success Guessed tree name to be net-next
netdev/ynl success Generated files up to date; no warnings/errors; no diff in generated;
netdev/fixes_present success Fixes tag not required for -next series
netdev/header_inline success No static functions without inline keyword in header files
netdev/build_32bit success Errors and warnings before: 940 this patch: 940
netdev/build_tools success No tools touched, skip
netdev/cc_maintainers success CCed 7 of 7 maintainers
netdev/build_clang success Errors and warnings before: 956 this patch: 956
netdev/verify_signedoff success Signed-off-by tag matches author and committer
netdev/deprecated_api success None detected
netdev/check_selftest success No net selftest shell script
netdev/verify_fixes success No Fixes tag
netdev/build_allmodconfig_warn success Errors and warnings before: 956 this patch: 956
netdev/checkpatch success total: 0 errors, 0 warnings, 0 checks, 9 lines checked
netdev/build_clang_rust success No Rust files in patch. Skipping build
netdev/kdoc success Errors and warnings before: 0 this patch: 0
netdev/source_inline success Was 0 now: 0
netdev/contest success net-next-2024-03-12--09-00 (tests: 887)

Commit Message

Zhu Yanjun March 12, 2024, 6:15 a.m. UTC
From: Zhu Yanjun <yanjun.zhu@linux.dev>

In the original source code, add vmvf_type to ctrl_msg for ctlq_recv
functions. These new types will be implemented and used. But currently
these types are not used. So remove them.

Signed-off-by: Zhu Yanjun <yanjun.zhu@linux.dev>
---
 drivers/net/ethernet/intel/idpf/idpf_controlq_api.h | 3 ---
 1 file changed, 3 deletions(-)

Comments

Przemek Kitszel March 12, 2024, 7:05 a.m. UTC | #1
On 3/12/24 07:15, Zhu Yanjun wrote:
> From: Zhu Yanjun <yanjun.zhu@linux.dev>
> 
> In the original source code, add vmvf_type to ctrl_msg for ctlq_recv
> functions. These new types will be implemented and used. But currently
> these types are not used. So remove them.

This commit message is hard to read.
Also please try to use imperative mood, and avoid phrases like "this 
commit", "in the code", as most likely those are implicit.

Please also wait with your contribution for next window opening.

For Intel Employees this internal wiki could be useful:
https://wiki.ith.intel.com/display/LADSW/Common+faults+when+sending+%28a+first%29+series+upstream

> 
> Signed-off-by: Zhu Yanjun <yanjun.zhu@linux.dev>
> ---
>   drivers/net/ethernet/intel/idpf/idpf_controlq_api.h | 3 ---
>   1 file changed, 3 deletions(-)
> 
> diff --git a/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h b/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h
> index 8dee098bbfb0..e1b6ee87ad95 100644
> --- a/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h
> +++ b/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h
> @@ -37,9 +37,6 @@ struct idpf_ctlq_reg {
>   /* Generic queue msg structure */
>   struct idpf_ctlq_msg {
>   	u8 vmvf_type; /* represents the source of the message on recv */
> -#define IDPF_VMVF_TYPE_VF 0
> -#define IDPF_VMVF_TYPE_VM 1
> -#define IDPF_VMVF_TYPE_PF 2
>   	u8 host_id;
>   	/* 3b field used only when sending a message to CP - to be used in
>   	 * combination with target func_id to route the message
diff mbox series

Patch

diff --git a/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h b/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h
index 8dee098bbfb0..e1b6ee87ad95 100644
--- a/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h
+++ b/drivers/net/ethernet/intel/idpf/idpf_controlq_api.h
@@ -37,9 +37,6 @@  struct idpf_ctlq_reg {
 /* Generic queue msg structure */
 struct idpf_ctlq_msg {
 	u8 vmvf_type; /* represents the source of the message on recv */
-#define IDPF_VMVF_TYPE_VF 0
-#define IDPF_VMVF_TYPE_VM 1
-#define IDPF_VMVF_TYPE_PF 2
 	u8 host_id;
 	/* 3b field used only when sending a message to CP - to be used in
 	 * combination with target func_id to route the message