diff mbox series

[net-next,01/24] can: mcp251x: Fix up includes

Message ID 20240621080201.305471-2-mkl@pengutronix.de (mailing list archive)
State Accepted
Commit b1dc3c68e977273397619d901b34f25634666c24
Delegated to: Netdev Maintainers
Headers show
Series [net-next,01/24] can: mcp251x: Fix up includes | expand

Checks

Context Check Description
netdev/series_format warning Pull request is its own cover letter; Series longer than 15 patches (PR)
netdev/tree_selection success Clearly marked for net-next, async
netdev/ynl success Generated files up to date; no warnings/errors; no diff in generated;
netdev/fixes_present success Fixes tag not required for -next series
netdev/header_inline success No static functions without inline keyword in header files
netdev/build_32bit success Errors and warnings before: 842 this patch: 842
netdev/build_tools success No tools touched, skip
netdev/cc_maintainers warning 2 maintainers not CCed: pabeni@redhat.com edumazet@google.com
netdev/build_clang success Errors and warnings before: 849 this patch: 849
netdev/verify_signedoff success Signed-off-by tag matches author and committer
netdev/deprecated_api success None detected
netdev/check_selftest success No net selftest shell script
netdev/verify_fixes success No Fixes tag
netdev/build_allmodconfig_warn success Errors and warnings before: 849 this patch: 849
netdev/checkpatch success total: 0 errors, 0 warnings, 0 checks, 18 lines checked
netdev/build_clang_rust success No Rust files in patch. Skipping build
netdev/kdoc success Errors and warnings before: 0 this patch: 0
netdev/source_inline success Was 0 now: 0
netdev/contest success net-next-2024-06-21--21-00 (tests: 659)

Commit Message

Marc Kleine-Budde June 21, 2024, 7:48 a.m. UTC
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>

This driver is including the legacy GPIO header <linux/gpio.h>
but the only thing it is using from that header is the wrong
define for GPIOF_DIR_OUT.

Fix it up by using GPIO_LINE_DIRECTION_* macros respectively.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Reviewed-by: Vincent Mailhol <mailhol.vincent@wanadoo.fr>
Link: https://lore.kernel.org/all/20240412173332.186685-1-andriy.shevchenko@linux.intel.com
Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
---
 drivers/net/can/spi/mcp251x.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)


base-commit: 7e8fcb815432e68897dbbc2c4213e546ac40f49c

Comments

patchwork-bot+netdevbpf@kernel.org June 22, 2024, 1:20 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (main)
by Marc Kleine-Budde <mkl@pengutronix.de>:

On Fri, 21 Jun 2024 09:48:21 +0200 you wrote:
> From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> 
> This driver is including the legacy GPIO header <linux/gpio.h>
> but the only thing it is using from that header is the wrong
> define for GPIOF_DIR_OUT.
> 
> Fix it up by using GPIO_LINE_DIRECTION_* macros respectively.
> 
> [...]

Here is the summary with links:
  - [net-next,01/24] can: mcp251x: Fix up includes
    https://git.kernel.org/netdev/net-next/c/b1dc3c68e977
  - [net-next,02/24] can: sja1000: plx_pci: Reuse predefined CTI subvendor ID
    https://git.kernel.org/netdev/net-next/c/5ca3801388f8
  - [net-next,03/24] can: Kconfig: remove obsolete help text for slcan
    https://git.kernel.org/netdev/net-next/c/58b34cd646b4
  - [net-next,04/24] dt-bindings: can: xilinx_can: Modify the title to indicate CAN and CANFD controllers are supported
    https://git.kernel.org/netdev/net-next/c/8416ac9c87bd
  - [net-next,05/24] can: isotp: remove ISO 15675-2 specification version where possible
    https://git.kernel.org/netdev/net-next/c/ba63a7e08523
  - [net-next,06/24] can: xilinx_can: Document driver description to list all supported IPs
    https://git.kernel.org/netdev/net-next/c/e562bad35fe3
  - [net-next,07/24] Documentation: networking: document ISO 15765-2
    https://git.kernel.org/netdev/net-next/c/67711e04254c
  - [net-next,08/24] can: mscan: remove unused struct 'mscan_state'
    https://git.kernel.org/netdev/net-next/c/f9f608e38b9c
  - [net-next,09/24] can: kvaser_usb: Add support for Vining 800
    https://git.kernel.org/netdev/net-next/c/2851d357a485
  - [net-next,10/24] can: kvaser_usb: Add support for Kvaser USBcan Pro 5xCAN
    https://git.kernel.org/netdev/net-next/c/96a669a1958f
  - [net-next,11/24] can: kvaser_usb: Add support for Kvaser Mini PCIe 1xCAN
    https://git.kernel.org/netdev/net-next/c/0135c4c6b84c
  - [net-next,12/24] can: kvaser_pciefd: Group #defines together
    https://git.kernel.org/netdev/net-next/c/cdbc9d055fc7
  - [net-next,13/24] can: kvaser_pciefd: Skip redundant NULL pointer check in ISR
    https://git.kernel.org/netdev/net-next/c/ac765219c2c4
  - [net-next,14/24] can: kvaser_pciefd: Remove unnecessary comment
    https://git.kernel.org/netdev/net-next/c/11d186697ceb
  - [net-next,15/24] can: kvaser_pciefd: Add inline
    https://git.kernel.org/netdev/net-next/c/0132a05df1e0
  - [net-next,16/24] can: kvaser_pciefd: Add unlikely
    https://git.kernel.org/netdev/net-next/c/cebfebefaa01
  - [net-next,17/24] can: kvaser_pciefd: Rename board_irq to pci_irq
    https://git.kernel.org/netdev/net-next/c/cbf88a6ba7bb
  - [net-next,18/24] can: kvaser_pciefd: Change name of return code variable
    https://git.kernel.org/netdev/net-next/c/26a1b0fe3f62
  - [net-next,19/24] can: kvaser_pciefd: Move reset of DMA RX buffers to the end of the ISR
    https://git.kernel.org/netdev/net-next/c/48f827d4f48f
  - [net-next,20/24] can: kvaser_pciefd: Add MSI interrupts
    https://git.kernel.org/netdev/net-next/c/dd1f05ba2a99
  - [net-next,21/24] can: hi311x: simplify with spi_get_device_match_data()
    https://git.kernel.org/netdev/net-next/c/1562a49d000c
  - [net-next,22/24] can: mcp251x: simplify with spi_get_device_match_data()
    https://git.kernel.org/netdev/net-next/c/d4383d67a25b
  - [net-next,23/24] can: mcp251xfd: simplify with spi_get_device_match_data()
    https://git.kernel.org/netdev/net-next/c/9cdae370c4ec
  - [net-next,24/24] can: m_can: don't enable transceiver when probing
    (no matching commit)

You are awesome, thank you!
diff mbox series

Patch

diff --git a/drivers/net/can/spi/mcp251x.c b/drivers/net/can/spi/mcp251x.c
index 79c4bab5f724..643974b3f329 100644
--- a/drivers/net/can/spi/mcp251x.c
+++ b/drivers/net/can/spi/mcp251x.c
@@ -28,7 +28,6 @@ 
 #include <linux/device.h>
 #include <linux/ethtool.h>
 #include <linux/freezer.h>
-#include <linux/gpio.h>
 #include <linux/gpio/driver.h>
 #include <linux/interrupt.h>
 #include <linux/io.h>
@@ -482,9 +481,9 @@  static int mcp251x_gpio_get_direction(struct gpio_chip *chip,
 				      unsigned int offset)
 {
 	if (mcp251x_gpio_is_input(offset))
-		return GPIOF_DIR_IN;
+		return GPIO_LINE_DIRECTION_IN;
 
-	return GPIOF_DIR_OUT;
+	return GPIO_LINE_DIRECTION_OUT;
 }
 
 static int mcp251x_gpio_get(struct gpio_chip *chip, unsigned int offset)