Message ID | 20240806074731.1905378-2-mkl@pengutronix.de (mailing list archive) |
---|---|
State | Accepted |
Commit | ef5e8d34bb9a2f6c13fa35a2209709d345ac1017 |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | [net-next,01/20] dt-bindings: can: fsl,flexcan: add common 'can-transceiver' for fsl,flexcan | expand |
Hello: This series was applied to netdev/net-next.git (main) by Marc Kleine-Budde <mkl@pengutronix.de>: On Tue, 6 Aug 2024 09:41:52 +0200 you wrote: > From: Frank Li <Frank.Li@nxp.com> > > Add common 'can-transceiver' children node for fsl,flexcan. > > Fix below warning: > arch/arm64/boot/dts/freescale/fsl-ls1028a-rdb.dtb: can@2180000: 'can-transceiver' does not match any of the regexes: 'pinctrl-[0-9]+' > from schema $id: http://devicetree.org/schemas/net/can/fsl,flexcan.yaml# > > [...] Here is the summary with links: - [net-next,01/20] dt-bindings: can: fsl,flexcan: add common 'can-transceiver' for fsl,flexcan https://git.kernel.org/netdev/net-next/c/ef5e8d34bb9a - [net-next,02/20] dt-bindings: can: fsl,flexcan: move fsl,imx95-flexcan standalone https://git.kernel.org/netdev/net-next/c/3eea16ba7c69 - [net-next,03/20] can: flexcan: add wakeup support for imx95 https://git.kernel.org/netdev/net-next/c/5b512f42e098 - [net-next,04/20] can: esd_402_pci: Rename esdACC CTRL register macros (no matching commit) - [net-next,05/20] can: esd_402_pci: Add support for one-shot mode https://git.kernel.org/netdev/net-next/c/c20ff3e0d9eb - [net-next,06/20] can: kvaser_usb: Add helper functions to convert device timestamp into ktime https://git.kernel.org/netdev/net-next/c/7d102d0e4c63 - [net-next,07/20] can: kvaser_usb: hydra: kvaser_usb_hydra_ktime_from_rx_cmd: Drop {rx_} in function name https://git.kernel.org/netdev/net-next/c/7cb0450c1da5 - [net-next,08/20] can: kvaser_usb: hydra: Add struct for Tx ACK commands https://git.kernel.org/netdev/net-next/c/0512cc691a3a - [net-next,09/20] can: kvaser_usb: hydra: Set hardware timestamp on transmitted packets https://git.kernel.org/netdev/net-next/c/d920dd289ee5 - [net-next,10/20] can: kvaser_usb: leaf: Add struct for Tx ACK commands https://git.kernel.org/netdev/net-next/c/8e7895942ea5 - [net-next,11/20] can: kvaser_usb: leaf: Assign correct timestamp_freq for kvaser_usb_leaf_imx_dev_cfg_{16,24,32}mhz https://git.kernel.org/netdev/net-next/c/dcc8c203318a - [net-next,12/20] can: kvaser_usb: leaf: Replace kvaser_usb_leaf_m32c_dev_cfg with kvaser_usb_leaf_m32c_dev_cfg_{16,24,32}mhz https://git.kernel.org/netdev/net-next/c/9e1cd0d27276 - [net-next,13/20] can: kvaser_usb: leaf: kvaser_usb_leaf_tx_acknowledge: Rename local variable https://git.kernel.org/netdev/net-next/c/7f3823759751 - [net-next,14/20] can: kvaser_usb: leaf: Add hardware timestamp support to leaf based devices https://git.kernel.org/netdev/net-next/c/8a52e5a0361f - [net-next,15/20] can: kvaser_usb: leaf: Add structs for Tx ACK and clock overflow commands https://git.kernel.org/netdev/net-next/c/a7cfb2200d85 - [net-next,16/20] can: kvaser_usb: leaf: Store MSB of timestamp https://git.kernel.org/netdev/net-next/c/c644c9698d8d - [net-next,17/20] can: kvaser_usb: leaf: Add hardware timestamp support to usbcan devices https://git.kernel.org/netdev/net-next/c/0aa639d3b3b9 - [net-next,18/20] can: kvaser_usb: Remove KVASER_USB_QUIRK_HAS_HARDWARE_TIMESTAMP https://git.kernel.org/netdev/net-next/c/51b56a25ed60 - [net-next,19/20] can: kvaser_usb: Remove struct variables kvaser_usb_{ethtool,netdev}_ops https://git.kernel.org/netdev/net-next/c/1a6b249e4b19 - [net-next,20/20] can: kvaser_usb: Rename kvaser_usb_{ethtool,netdev}_ops_hwts to kvaser_usb_{ethtool,netdev}_ops https://git.kernel.org/netdev/net-next/c/88371f85461a You are awesome, thank you!
diff --git a/Documentation/devicetree/bindings/net/can/fsl,flexcan.yaml b/Documentation/devicetree/bindings/net/can/fsl,flexcan.yaml index f197d9b516bb..a4261a201fdb 100644 --- a/Documentation/devicetree/bindings/net/can/fsl,flexcan.yaml +++ b/Documentation/devicetree/bindings/net/can/fsl,flexcan.yaml @@ -80,6 +80,10 @@ properties: node then controller is assumed to be little endian. If this property is present then controller is assumed to be big endian. + can-transceiver: + $ref: can-transceiver.yaml# + unevaluatedProperties: false + fsl,stop-mode: description: | Register bits of stop mode control.