Message ID | 20250218143717.3580605-1-nicolas.dichtel@6wind.com (mailing list archive) |
---|---|
State | Changes Requested |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | [net-next] skbuff: kill skb_flow_get_ports() | expand |
On Tue, Feb 18, 2025 at 03:37:17PM +0100, Nicolas Dichtel wrote: > This function is not used anymore. > > Fixes: a815bde56b15 ("net, bonding: Refactor bond_xmit_hash for use with xdp_buff") > Signed-off-by: Nicolas Dichtel <nicolas.dichtel@6wind.com> Reviewed-by: Simon Horman <horms@kernel.org> I guess the churn isn't worth it, but it seems to me that __skb_flow_get_ports could be renamed skb_flow_get_ports. ...
Le 20/02/2025 à 11:54, Simon Horman a écrit : > On Tue, Feb 18, 2025 at 03:37:17PM +0100, Nicolas Dichtel wrote: >> This function is not used anymore. >> >> Fixes: a815bde56b15 ("net, bonding: Refactor bond_xmit_hash for use with xdp_buff") >> Signed-off-by: Nicolas Dichtel <nicolas.dichtel@6wind.com> > > Reviewed-by: Simon Horman <horms@kernel.org> > > I guess the churn isn't worth it, but it seems to me that > __skb_flow_get_ports could be renamed skb_flow_get_ports. > Right. I can send a follow-up patch.
On Thu, Feb 20, 2025 at 02:02:05PM +0100, Nicolas Dichtel wrote: > Le 20/02/2025 à 11:54, Simon Horman a écrit : > > On Tue, Feb 18, 2025 at 03:37:17PM +0100, Nicolas Dichtel wrote: > >> This function is not used anymore. > >> > >> Fixes: a815bde56b15 ("net, bonding: Refactor bond_xmit_hash for use with xdp_buff") Hi, Fixes tag is redundant as this is -next material. > >> Signed-off-by: Nicolas Dichtel <nicolas.dichtel@6wind.com> > > > > Reviewed-by: Simon Horman <horms@kernel.org> > > > > I guess the churn isn't worth it, but it seems to me that > > __skb_flow_get_ports could be renamed skb_flow_get_ports. > > > Right. I can send a follow-up patch. > > >
diff --git a/include/linux/skbuff.h b/include/linux/skbuff.h index bb2b751d274a..f403d43064a5 100644 --- a/include/linux/skbuff.h +++ b/include/linux/skbuff.h @@ -1530,12 +1530,6 @@ u32 __skb_get_poff(const struct sk_buff *skb, const void *data, __be32 __skb_flow_get_ports(const struct sk_buff *skb, int thoff, u8 ip_proto, const void *data, int hlen_proto); -static inline __be32 skb_flow_get_ports(const struct sk_buff *skb, - int thoff, u8 ip_proto) -{ - return __skb_flow_get_ports(skb, thoff, ip_proto, NULL, 0); -} - void skb_flow_dissector_init(struct flow_dissector *flow_dissector, const struct flow_dissector_key *key, unsigned int key_count);
This function is not used anymore. Fixes: a815bde56b15 ("net, bonding: Refactor bond_xmit_hash for use with xdp_buff") Signed-off-by: Nicolas Dichtel <nicolas.dichtel@6wind.com> --- include/linux/skbuff.h | 6 ------ 1 file changed, 6 deletions(-)