Message ID | 3476b0ef04a0944f03e0b771ec8ed1a9c70db4dc.1739186253.git.ecree.xilinx@gmail.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 5ea73bf3c40d03f09d4cd19b8222ad6b585afbbb |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | sfc: support devlink flash | expand |
Mon, Feb 10, 2025 at 12:25:45PM +0100, edward.cree@amd.com wrote: >From: Edward Cree <ecree.xilinx@gmail.com> > >Update the information in sfc's devlink documentation including > support for firmware update with devlink flash. >Also update the help text for CONFIG_SFC_MTD, as it is no longer > strictly required for firmware updates. > >Signed-off-by: Edward Cree <ecree.xilinx@gmail.com> >--- > Documentation/networking/devlink/sfc.rst | 16 +++++++++++++++- > drivers/net/ethernet/sfc/Kconfig | 5 +++-- > 2 files changed, 18 insertions(+), 3 deletions(-) > >diff --git a/Documentation/networking/devlink/sfc.rst b/Documentation/networking/devlink/sfc.rst >index db64a1bd9733..0398d59ea184 100644 >--- a/Documentation/networking/devlink/sfc.rst >+++ b/Documentation/networking/devlink/sfc.rst >@@ -5,7 +5,7 @@ sfc devlink support > =================== > > This document describes the devlink features implemented by the ``sfc`` >-device driver for the ef100 device. >+device driver for the ef10 and ef100 devices. > > Info versions > ============= >@@ -18,6 +18,10 @@ The ``sfc`` driver reports the following versions > * - Name > - Type > - Description >+ * - ``fw.bundle_id`` Why "id"? It is the bundle version, isn't it. In that case just "bundle" would be fine I guess... >+ - stored >+ - Version of the firmware "bundle" image that was last used to update >+ multiple components. > * - ``fw.mgmt.suc`` > - running > - For boards where the management function is split between multiple >@@ -55,3 +59,13 @@ The ``sfc`` driver reports the following versions > * - ``fw.uefi`` > - running > - UEFI driver version (No UNDI support). >+ >+Flash Update >+============ >+ >+The ``sfc`` driver implements support for flash update using the >+``devlink-flash`` interface. It supports updating the device flash using a >+combined flash image ("bundle") that contains multiple components (on ef10, >+typically ``fw.mgmt``, ``fw.app``, ``fw.exprom`` and ``fw.uefi``). >+ >+The driver does not support any overwrite mask flags. >diff --git a/drivers/net/ethernet/sfc/Kconfig b/drivers/net/ethernet/sfc/Kconfig >index 3eb55dcfa8a6..c4c43434f314 100644 >--- a/drivers/net/ethernet/sfc/Kconfig >+++ b/drivers/net/ethernet/sfc/Kconfig >@@ -38,8 +38,9 @@ config SFC_MTD > default y > help > This exposes the on-board flash and/or EEPROM as MTD devices >- (e.g. /dev/mtd1). This is required to update the firmware or >- the boot configuration under Linux. >+ (e.g. /dev/mtd1). This is required to update the boot >+ configuration under Linux, or use some older userland tools to >+ update the firmware. > config SFC_MCDI_MON > bool "Solarflare SFC9100-family hwmon support" > depends on SFC && HWMON && !(SFC=y && HWMON=m)
On 10/02/2025 13:51, Jiri Pirko wrote: > Mon, Feb 10, 2025 at 12:25:45PM +0100, edward.cree@amd.com wrote: >> Info versions >> ============= >> @@ -18,6 +18,10 @@ The ``sfc`` driver reports the following versions >> * - Name >> - Type >> - Description >> + * - ``fw.bundle_id`` > > Why "id"? It is the bundle version, isn't it. In that case just "bundle" > would be fine I guess... bundle_id comes from DEVLINK_INFO_VERSION_GENERIC_FW_BUNDLE_ID in include/net/devlink.h, which git blame tells me was added by Jacob Keller in 2020 as a generalisation of a similar name in nfp.[1] Its use in sfc was added[2] by Alejandro Lucero in 2023 but seems to have been left out of the documentation at that time. The present patch series is merely documenting the name that already exists, not adding it. Changing it might break existing scripts, and in any case would affect more drivers than just sfc (it is used by i40e, ice, and nfp). CCing Jacob in case he has anything to add on why that name was chosen. [1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=c90977a3c227 [2]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=14743ddd2495
Mon, Feb 10, 2025 at 03:50:18PM +0100, ecree.xilinx@gmail.com wrote: >On 10/02/2025 13:51, Jiri Pirko wrote: >> Mon, Feb 10, 2025 at 12:25:45PM +0100, edward.cree@amd.com wrote: >>> Info versions >>> ============= >>> @@ -18,6 +18,10 @@ The ``sfc`` driver reports the following versions >>> * - Name >>> - Type >>> - Description >>> + * - ``fw.bundle_id`` >> >> Why "id"? It is the bundle version, isn't it. In that case just "bundle" >> would be fine I guess... > >bundle_id comes from DEVLINK_INFO_VERSION_GENERIC_FW_BUNDLE_ID in > include/net/devlink.h, which git blame tells me was added by Jacob > Keller in 2020 as a generalisation of a similar name in nfp.[1] >Its use in sfc was added[2] by Alejandro Lucero in 2023 but seems to > have been left out of the documentation at that time. >The present patch series is merely documenting the name that already > exists, not adding it. Changing it might break existing scripts, and > in any case would affect more drivers than just sfc (it is used by > i40e, ice, and nfp). Yeah, correct. I just found out myself by accident. Thanks! > >CCing Jacob in case he has anything to add on why that name was chosen. > >[1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=c90977a3c227 >[2]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=14743ddd2495
On 2/10/2025 6:50 AM, Edward Cree wrote: > On 10/02/2025 13:51, Jiri Pirko wrote: >> Mon, Feb 10, 2025 at 12:25:45PM +0100, edward.cree@amd.com wrote: >>> Info versions >>> ============= >>> @@ -18,6 +18,10 @@ The ``sfc`` driver reports the following versions >>> * - Name >>> - Type >>> - Description >>> + * - ``fw.bundle_id`` >> >> Why "id"? It is the bundle version, isn't it. In that case just "bundle" >> would be fine I guess... > > bundle_id comes from DEVLINK_INFO_VERSION_GENERIC_FW_BUNDLE_ID in > include/net/devlink.h, which git blame tells me was added by Jacob > Keller in 2020 as a generalisation of a similar name in nfp.[1] > Its use in sfc was added[2] by Alejandro Lucero in 2023 but seems to > have been left out of the documentation at that time. > The present patch series is merely documenting the name that already > exists, not adding it. Changing it might break existing scripts, and > in any case would affect more drivers than just sfc (it is used by > i40e, ice, and nfp). > > CCing Jacob in case he has anything to add on why that name was chosen. > > [1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=c90977a3c227 > [2]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=14743ddd2495 > Yep. The versions were discussed extensively at [1] and I ultimately settled on re-using fw.bundle_id as a generic name rather than having nfp use bundle_id but everyone else use bundle [2] [1] https://lore.kernel.org/netdev/83a7a25e-50f0-862d-f535-92d64d86fd4f@intel.com/ [2] https://lore.kernel.org/netdev/20200321081028.2763550-8-jeffrey.t.kirsher@intel.com/ I don't think we can really change this at this point given this is effectively part of uABI.
diff --git a/Documentation/networking/devlink/sfc.rst b/Documentation/networking/devlink/sfc.rst index db64a1bd9733..0398d59ea184 100644 --- a/Documentation/networking/devlink/sfc.rst +++ b/Documentation/networking/devlink/sfc.rst @@ -5,7 +5,7 @@ sfc devlink support =================== This document describes the devlink features implemented by the ``sfc`` -device driver for the ef100 device. +device driver for the ef10 and ef100 devices. Info versions ============= @@ -18,6 +18,10 @@ The ``sfc`` driver reports the following versions * - Name - Type - Description + * - ``fw.bundle_id`` + - stored + - Version of the firmware "bundle" image that was last used to update + multiple components. * - ``fw.mgmt.suc`` - running - For boards where the management function is split between multiple @@ -55,3 +59,13 @@ The ``sfc`` driver reports the following versions * - ``fw.uefi`` - running - UEFI driver version (No UNDI support). + +Flash Update +============ + +The ``sfc`` driver implements support for flash update using the +``devlink-flash`` interface. It supports updating the device flash using a +combined flash image ("bundle") that contains multiple components (on ef10, +typically ``fw.mgmt``, ``fw.app``, ``fw.exprom`` and ``fw.uefi``). + +The driver does not support any overwrite mask flags. diff --git a/drivers/net/ethernet/sfc/Kconfig b/drivers/net/ethernet/sfc/Kconfig index 3eb55dcfa8a6..c4c43434f314 100644 --- a/drivers/net/ethernet/sfc/Kconfig +++ b/drivers/net/ethernet/sfc/Kconfig @@ -38,8 +38,9 @@ config SFC_MTD default y help This exposes the on-board flash and/or EEPROM as MTD devices - (e.g. /dev/mtd1). This is required to update the firmware or - the boot configuration under Linux. + (e.g. /dev/mtd1). This is required to update the boot + configuration under Linux, or use some older userland tools to + update the firmware. config SFC_MCDI_MON bool "Solarflare SFC9100-family hwmon support" depends on SFC && HWMON && !(SFC=y && HWMON=m)