Message ID | 491e9d549dd6b5d1b50e4540536f4fa4ce4e968f.1645171288.git.christophe.leroy@csgroup.eu (mailing list archive) |
---|---|
State | Accepted |
Commit | 0f6938eb2ecc572896ef9ad11238eb2846dcaad3 |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | [net-next,v2] net: core: Use csum_replace_by_diff() and csum_sub() instead of opencoding | expand |
Hello: This patch was applied to netdev/net-next.git (master) by David S. Miller <davem@davemloft.net>: On Fri, 18 Feb 2022 09:03:48 +0100 you wrote: > Open coded calculation can be avoided and replaced by the > equivalent csum_replace_by_diff() and csum_sub(). > > Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu> > --- > v2: Dropped the change in nft_csum_replace() as it would > require nasty casts. > > [...] Here is the summary with links: - [net-next,v2] net: core: Use csum_replace_by_diff() and csum_sub() instead of opencoding https://git.kernel.org/netdev/net-next/c/0f6938eb2ecc You are awesome, thank you!
diff --git a/net/core/utils.c b/net/core/utils.c index 1f31a39236d5..938495bc1d34 100644 --- a/net/core/utils.c +++ b/net/core/utils.c @@ -476,9 +476,9 @@ void inet_proto_csum_replace_by_diff(__sum16 *sum, struct sk_buff *skb, __wsum diff, bool pseudohdr) { if (skb->ip_summed != CHECKSUM_PARTIAL) { - *sum = csum_fold(csum_add(diff, ~csum_unfold(*sum))); + csum_replace_by_diff(sum, diff); if (skb->ip_summed == CHECKSUM_COMPLETE && pseudohdr) - skb->csum = ~csum_add(diff, ~skb->csum); + skb->csum = ~csum_sub(diff, skb->csum); } else if (pseudohdr) { *sum = ~csum_fold(csum_add(diff, csum_unfold(*sum))); }
Open coded calculation can be avoided and replaced by the equivalent csum_replace_by_diff() and csum_sub(). Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu> --- v2: Dropped the change in nft_csum_replace() as it would require nasty casts. --- net/core/utils.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)