diff mbox series

[net-next] net: phy: simplify a check in phy_check_link_status

Message ID de37bf30-61dd-49f9-b645-2d8ea11ddb5d@gmail.com (mailing list archive)
State Accepted
Commit c786459fc827216447b34d716d0a9f8f6a79bf73
Delegated to: Netdev Maintainers
Headers show
Series [net-next] net: phy: simplify a check in phy_check_link_status | expand

Checks

Context Check Description
netdev/series_format success Single patches do not need cover letters
netdev/tree_selection success Clearly marked for net-next
netdev/ynl success Generated files up to date; no warnings/errors; no diff in generated;
netdev/fixes_present success Fixes tag not required for -next series
netdev/header_inline success No static functions without inline keyword in header files
netdev/build_32bit success Errors and warnings before: 940 this patch: 940
netdev/build_tools success No tools touched, skip
netdev/cc_maintainers success CCed 7 of 7 maintainers
netdev/build_clang success Errors and warnings before: 956 this patch: 956
netdev/verify_signedoff success Signed-off-by tag matches author and committer
netdev/deprecated_api success None detected
netdev/check_selftest success No net selftest shell script
netdev/verify_fixes success No Fixes tag
netdev/build_allmodconfig_warn success Errors and warnings before: 956 this patch: 956
netdev/checkpatch success total: 0 errors, 0 warnings, 0 checks, 12 lines checked
netdev/build_clang_rust success No Rust files in patch. Skipping build
netdev/kdoc success Errors and warnings before: 0 this patch: 0
netdev/source_inline success Was 0 now: 0
netdev/contest success net-next-2024-03-08--09-00 (tests: 890)

Commit Message

Heiner Kallweit March 7, 2024, 9:16 p.m. UTC
Handling case err == 0 in the other branch allows to simplify the
code. In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
it should have been a logical and operator. It works as expected also
with the bitwise and, but using a bitwise and with a bool value looks
ugly to me.

Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
---
 drivers/net/phy/phy.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ratheesh Kannoth March 8, 2024, 4:50 a.m. UTC | #1
On 2024-03-08 at 02:46:12, Heiner Kallweit (hkallweit1@gmail.com) wrote:
> Handling case err == 0 in the other branch allows to simplify the
> code. In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
> it should have been a logical and operator. It works as expected also
> with the bitwise and, but using a bitwise and with a bool value looks
> ugly to me.
>
> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
> ---
>  drivers/net/phy/phy.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
> index c3a0a5ee5..c4236564c 100644
> --- a/drivers/net/phy/phy.c
> +++ b/drivers/net/phy/phy.c
> @@ -985,10 +985,10 @@ static int phy_check_link_status(struct phy_device *phydev)
>  		phydev->state = PHY_RUNNING;
>  		err = genphy_c45_eee_is_active(phydev,
>  					       NULL, NULL, NULL);
IMO, better to rename "err" to "ret", and do if (ret == true). OR,
we should fix syntax of genphy_c45_eee_is_active() to return bool (true/false)
than doing this, because function name suggest so , xxx_is_active(). err == 0, norm is
for success case.

> -		if (err < 0)
> +		if (err <= 0)
>  			phydev->enable_tx_lpi = false;
>  		else
> -			phydev->enable_tx_lpi = (err & phydev->eee_cfg.tx_lpi_enabled);
> +			phydev->enable_tx_lpi = phydev->eee_cfg.tx_lpi_enabled;
>
>  		phy_link_up(phydev);
>  	} else if (!phydev->link && phydev->state != PHY_NOLINK) {
> --
> 2.44.0
Heiner Kallweit March 8, 2024, 7:09 a.m. UTC | #2
On 08.03.2024 05:50, Ratheesh Kannoth wrote:
> On 2024-03-08 at 02:46:12, Heiner Kallweit (hkallweit1@gmail.com) wrote:
>> Handling case err == 0 in the other branch allows to simplify the
>> code. In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
>> it should have been a logical and operator. It works as expected also
>> with the bitwise and, but using a bitwise and with a bool value looks
>> ugly to me.
>>
>> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
>> ---
>>  drivers/net/phy/phy.c | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
>> index c3a0a5ee5..c4236564c 100644
>> --- a/drivers/net/phy/phy.c
>> +++ b/drivers/net/phy/phy.c
>> @@ -985,10 +985,10 @@ static int phy_check_link_status(struct phy_device *phydev)
>>  		phydev->state = PHY_RUNNING;
>>  		err = genphy_c45_eee_is_active(phydev,
>>  					       NULL, NULL, NULL);
> IMO, better to rename "err" to "ret", and do if (ret == true). OR,
> we should fix syntax of genphy_c45_eee_is_active() to return bool (true/false)
> than doing this, because function name suggest so , xxx_is_active(). err == 0, norm is
> for success case.
> 
Return value of genphy_c45_eee_is_active() is tristate int:
<0: error
 0: eee not active
 1: eee active (implicit cast from bool to int)

This tristate behavior isn't unusual, you can find it with other phylib
functions too, another example are several of the rpm functions.
So both, 0 and 1, are success cases (from a technical perspective).

>> -		if (err < 0)
>> +		if (err <= 0)
>>  			phydev->enable_tx_lpi = false;
>>  		else
>> -			phydev->enable_tx_lpi = (err & phydev->eee_cfg.tx_lpi_enabled);
>> +			phydev->enable_tx_lpi = phydev->eee_cfg.tx_lpi_enabled;
>>
>>  		phy_link_up(phydev);
>>  	} else if (!phydev->link && phydev->state != PHY_NOLINK) {
>> --
>> 2.44.0
Suman Ghosh March 8, 2024, 7:39 a.m. UTC | #3
Hi Heiner,

To me it looks like both patches,
r8169: switch to new function phy_support_eee and net: phy: simplify a check in phy_check_link_status is related and can be pushed as a series. This will make change more harmonic. Because, you are moving setting of enable_tx_lpi in one patch and removing from the other one.

Regards,
Suman

>-----Original Message-----
>From: Heiner Kallweit <hkallweit1@gmail.com>
>Sent: Friday, March 8, 2024 2:46 AM
>To: Russell King - ARM Linux <linux@armlinux.org.uk>; Andrew Lunn
><andrew@lunn.ch>; Paolo Abeni <pabeni@redhat.com>; Eric Dumazet
><edumazet@google.com>; David Miller <davem@davemloft.net>; Jakub
>Kicinski <kuba@kernel.org>
>Cc: netdev@vger.kernel.org
>Subject: [EXTERNAL] [PATCH net-next] net: phy: simplify a check in
>phy_check_link_status
>
>Handling case err == 0 in the other branch allows to simplify the code.
>In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
>it should have been a logical and operator. It works as expected also
>with the bitwise and, but using a bitwise and with a bool value looks
>ugly to me.
>
>Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
>---
> drivers/net/phy/phy.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
>diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c index
>c3a0a5ee5..c4236564c 100644
>--- a/drivers/net/phy/phy.c
>+++ b/drivers/net/phy/phy.c
>@@ -985,10 +985,10 @@ static int phy_check_link_status(struct phy_device
>*phydev)
> 		phydev->state = PHY_RUNNING;
> 		err = genphy_c45_eee_is_active(phydev,
> 					       NULL, NULL, NULL);
>-		if (err < 0)
>+		if (err <= 0)
> 			phydev->enable_tx_lpi = false;
> 		else
>-			phydev->enable_tx_lpi = (err & phydev-
>>eee_cfg.tx_lpi_enabled);
>+			phydev->enable_tx_lpi = phydev->eee_cfg.tx_lpi_enabled;
>
> 		phy_link_up(phydev);
> 	} else if (!phydev->link && phydev->state != PHY_NOLINK) {
>--
>2.44.0
>
Heiner Kallweit March 11, 2024, 8:44 p.m. UTC | #4
On 07.03.2024 22:16, Heiner Kallweit wrote:
> Handling case err == 0 in the other branch allows to simplify the
> code. In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
> it should have been a logical and operator. It works as expected also
> with the bitwise and, but using a bitwise and with a bool value looks
> ugly to me.
> 
> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
> ---
>  drivers/net/phy/phy.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
> index c3a0a5ee5..c4236564c 100644
> --- a/drivers/net/phy/phy.c
> +++ b/drivers/net/phy/phy.c
> @@ -985,10 +985,10 @@ static int phy_check_link_status(struct phy_device *phydev)
>  		phydev->state = PHY_RUNNING;
>  		err = genphy_c45_eee_is_active(phydev,
>  					       NULL, NULL, NULL);
> -		if (err < 0)
> +		if (err <= 0)
>  			phydev->enable_tx_lpi = false;
>  		else
> -			phydev->enable_tx_lpi = (err & phydev->eee_cfg.tx_lpi_enabled);
> +			phydev->enable_tx_lpi = phydev->eee_cfg.tx_lpi_enabled;
>  
>  		phy_link_up(phydev);
>  	} else if (!phydev->link && phydev->state != PHY_NOLINK) {

This patch was set to "changes requested" in patchwork. The comment that this refers to
(make two patches a series) isn't applicable and I answered to it here:
https://lore.kernel.org/netdev/d6ee6353-5cb0-4751-9b69-255ab62e6b56@gmail.com/T/
Whatever is better for you: If it can still be applied, fine. Otherwise I'd resubmit
after the merge window.
patchwork-bot+netdevbpf@kernel.org March 11, 2024, 9:10 p.m. UTC | #5
Hello:

This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Thu, 7 Mar 2024 22:16:12 +0100 you wrote:
> Handling case err == 0 in the other branch allows to simplify the
> code. In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
> it should have been a logical and operator. It works as expected also
> with the bitwise and, but using a bitwise and with a bool value looks
> ugly to me.
> 
> Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
> 
> [...]

Here is the summary with links:
  - [net-next] net: phy: simplify a check in phy_check_link_status
    https://git.kernel.org/netdev/net-next/c/c786459fc827

You are awesome, thank you!
diff mbox series

Patch

diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
index c3a0a5ee5..c4236564c 100644
--- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c
@@ -985,10 +985,10 @@  static int phy_check_link_status(struct phy_device *phydev)
 		phydev->state = PHY_RUNNING;
 		err = genphy_c45_eee_is_active(phydev,
 					       NULL, NULL, NULL);
-		if (err < 0)
+		if (err <= 0)
 			phydev->enable_tx_lpi = false;
 		else
-			phydev->enable_tx_lpi = (err & phydev->eee_cfg.tx_lpi_enabled);
+			phydev->enable_tx_lpi = phydev->eee_cfg.tx_lpi_enabled;
 
 		phy_link_up(phydev);
 	} else if (!phydev->link && phydev->state != PHY_NOLINK) {