diff mbox series

[2/4] platform/x86: wmi: Add to_wmi_device() helper macro

Message ID 20231102042959.11816-2-W_Armin@gmx.de (mailing list archive)
State Superseded, archived
Headers show
Series [1/4] platform/x86: wmi: Add wmidev_block_set() | expand

Commit Message

Armin Wolf Nov. 2, 2023, 4:29 a.m. UTC
Add a helper macro for WMI drivers to cast a device to
the corresponding WMI device. This should replace some
boilerplate code.

Signed-off-by: Armin Wolf <W_Armin@gmx.de>
---
 include/linux/wmi.h | 8 ++++++++
 1 file changed, 8 insertions(+)

--
2.39.2
diff mbox series

Patch

diff --git a/include/linux/wmi.h b/include/linux/wmi.h
index 207544968268..8a643c39fcce 100644
--- a/include/linux/wmi.h
+++ b/include/linux/wmi.h
@@ -27,6 +27,14 @@  struct wmi_device {
 	bool setable;
 };

+/**
+ * to_wmi_device() - Helper macro to cast a device to a wmi_device
+ * @device: device struct
+ *
+ * Cast a struct device to a struct wmi_device.
+ */
+#define to_wmi_device(device)	container_of(device, struct wmi_device, dev)
+
 extern acpi_status wmidev_evaluate_method(struct wmi_device *wdev,
 					  u8 instance, u32 method_id,
 					  const struct acpi_buffer *in,