Message ID | 20230713064111.558652-1-pizhenwei@bytedance.com (mailing list archive) |
---|---|
Headers | show |
Series | Misc fixes for throttle | expand |
Hi Kevin, Hanna, Patch 1 -> patch 5 of this series are already reviewed by Alberto(these affects throttle framework only), the patch 6 affects qemu block layer, would you please review this(in the further step, merge this series if this is acceptable)? On 7/13/23 14:41, zhenwei pi wrote: > v2 -> v3: > - patch 1 -> patch 5 are already reviewed by Alberto > - append patch 6: throttle: use enum ThrottleType instead of bool is_write > > v1 -> v2: > - rename 'ThrottleTimerType' to 'ThrottleType' > - add assertion to throttle_schedule_timer > > v1: > - introduce enum ThrottleTimerType instead of timers[0], timer[1]... > - support read-only and write-only for throttle > - adapt related test codes > - cryptodev uses a write-only throttle timer > > Zhenwei Pi (6): > throttle: introduce enum ThrottleType > test-throttle: use enum ThrottleType > throttle: support read-only and write-only > test-throttle: test read only and write only > cryptodev: use NULL throttle timer cb for read direction > throttle: use enum ThrottleType instead of bool is_write > > backends/cryptodev.c | 12 +++--- > block/throttle-groups.c | 6 ++- > fsdev/qemu-fsdev-throttle.c | 8 ++-- > include/qemu/throttle.h | 15 +++++--- > tests/unit/test-throttle.c | 76 ++++++++++++++++++++++++++++++++++--- > util/throttle.c | 64 +++++++++++++++++++------------ > 6 files changed, 136 insertions(+), 45 deletions(-) >