mbox series

[v2,0/3] include: Rename some expanded headers using '.h.inc' suffix

Message ID 20240424173333.96148-1-philmd@linaro.org (mailing list archive)
Headers show
Series include: Rename some expanded headers using '.h.inc' suffix | expand

Message

Philippe Mathieu-Daudé April 24, 2024, 5:33 p.m. UTC
v2: one more

Per our Coding Style:

  If you do use template header files they should be named with
  the ``.c.inc`` or ``.h.inc`` suffix to make it clear they are
  being included for expansion.

Rename elf_ops.h, helper-head.h and host/load-extract/store-insert
headers.

Philippe Mathieu-Daudé (3):
  hw/elf_ops: Rename elf_ops.h -> elf_ops.h.inc
  accel/tcg: Rename load-extract/store-insert headers using .h.inc
    suffix
  accel/tcg: Rename helper-head.h -> helper-head.h.inc

 .../{load-extract-al16-al8.h => load-extract-al16-al8.h.inc}  | 0
 .../host/{store-insert-al16.h => store-insert-al16.h.inc}     | 0
 .../{load-extract-al16-al8.h => load-extract-al16-al8.h.inc}  | 0
 .../host/{store-insert-al16.h => store-insert-al16.h.inc}     | 0
 .../{load-extract-al16-al8.h => load-extract-al16-al8.h.inc}  | 0
 .../host/{store-insert-al16.h => store-insert-al16.h.inc}     | 0
 .../{load-extract-al16-al8.h => load-extract-al16-al8.h.inc}  | 0
 include/exec/helper-gen.h.inc                                 | 2 +-
 include/exec/{helper-head.h => helper-head.h.inc}             | 0
 include/exec/helper-proto.h.inc                               | 2 +-
 include/hw/{elf_ops.h => elf_ops.h.inc}                       | 0
 bsd-user/elfload.c                                            | 2 +-
 hw/core/loader.c                                              | 4 ++--
 linux-user/elfload.c                                          | 2 +-
 accel/tcg/ldst_atomicity.c.inc                                | 4 ++--
 include/exec/helper-info.c.inc                                | 2 +-
 16 files changed, 9 insertions(+), 9 deletions(-)
 rename host/include/aarch64/host/{load-extract-al16-al8.h => load-extract-al16-al8.h.inc} (100%)
 rename host/include/aarch64/host/{store-insert-al16.h => store-insert-al16.h.inc} (100%)
 rename host/include/generic/host/{load-extract-al16-al8.h => load-extract-al16-al8.h.inc} (100%)
 rename host/include/generic/host/{store-insert-al16.h => store-insert-al16.h.inc} (100%)
 rename host/include/loongarch64/host/{load-extract-al16-al8.h => load-extract-al16-al8.h.inc} (100%)
 rename host/include/loongarch64/host/{store-insert-al16.h => store-insert-al16.h.inc} (100%)
 rename host/include/x86_64/host/{load-extract-al16-al8.h => load-extract-al16-al8.h.inc} (100%)
 rename include/exec/{helper-head.h => helper-head.h.inc} (100%)
 rename include/hw/{elf_ops.h => elf_ops.h.inc} (100%)

Comments

Richard Henderson April 24, 2024, 10:11 p.m. UTC | #1
On 4/24/24 10:33, Philippe Mathieu-Daudé wrote:
> Philippe Mathieu-Daudé (3):
>    hw/elf_ops: Rename elf_ops.h -> elf_ops.h.inc
>    accel/tcg: Rename load-extract/store-insert headers using .h.inc
>      suffix
>    accel/tcg: Rename helper-head.h -> helper-head.h.inc

Acked-by: Richard Henderson <richard.henderson@linaro.org>

r~