mbox series

[v3,00/17] hw/sd/sdcard: Accumulation of cleanups and fixes

Message ID 20240627162232.80428-1-philmd@linaro.org (mailing list archive)
Headers show
Series hw/sd/sdcard: Accumulation of cleanups and fixes | expand

Message

Philippe Mathieu-Daudé June 27, 2024, 4:22 p.m. UTC
Since v2:
- Tested-by from Cédric recorded
- more patches added :S
Since v1:
- various patches merged, few more added

Various SD card cleanups and fixes accumulated over
the years. Various have been useful to help integrating
eMMC support (which will come later).

Full series for testing:
https://gitlab.com/philmd/qemu/-/tags/emmc-v4

Cédric Le Goater (1):
  hw/sd/sdcard: Introduce definitions for EXT_CSD register

Philippe Mathieu-Daudé (16):
  hw/sd/sdcard: Deprecate support for spec v1.10
  hw/sd/sdcard: Use spec v3.01 by default
  hw/sd/sdcard: Track last command used to help logging
  hw/sd/sdcard: Trace block offset in READ/WRITE data accesses
  hw/sd/sdcard: Trace requested address computed by sd_req_get_address()
  hw/sd/sdcard: Do not store vendor data on block drive (CMD56)
  hw/sd/sdcard: Send WRITE_PROT bits MSB first (CMD30)
  hw/sd/sdcard: Send NUM_WR_BLOCKS bits MSB first (ACMD22)
  hw/sd/sdcard: Use READY_FOR_DATA definition instead of magic value
  hw/sd/sdcard: Assign SDCardStates enum values
  hw/sd/sdcard: Simplify sd_inactive_state handling
  hw/sd/sdcard: Restrict SWITCH_FUNCTION to sd_transfer_state (CMD6)
  hw/sd/sdcard: Add direct reference to SDProto in SDState
  hw/sd/sdcard: Extract sd_blk_len() helper
  tests/qtest: Disable npcm7xx_sdhci tests using hardcoded RCA
  hw/sd/sdcard: Generate random RCA value

 docs/about/deprecated.rst        |   6 ++
 hw/sd/sdmmc-internal.h           |  97 +++++++++++++++++++++
 hw/sd/sd.c                       | 145 ++++++++++++++++++-------------
 tests/qtest/npcm7xx_sdhci-test.c |   7 ++
 hw/sd/trace-events               |   6 +-
 5 files changed, 199 insertions(+), 62 deletions(-)