Message ID | 1455883404-10976-1-git-send-email-peter.maydell@linaro.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Fr, 2016-02-19 at 12:03 +0000, Peter Maydell wrote: > The TUSB6010 is a USB controller (as the name suggests). Move it from > hw/timer (where it was accidentally filed in 2013 when we moved > everything out of hw/) to hw/usb. Added to usb queue. thanks, Gerd
diff --git a/hw/timer/Makefile.objs b/hw/timer/Makefile.objs index 133bd0d..5cfea6e 100644 --- a/hw/timer/Makefile.objs +++ b/hw/timer/Makefile.objs @@ -25,7 +25,6 @@ obj-$(CONFIG_OMAP) += omap_gptimer.o obj-$(CONFIG_OMAP) += omap_synctimer.o obj-$(CONFIG_PXA2XX) += pxa2xx_timer.o obj-$(CONFIG_SH4) += sh_timer.o -obj-$(CONFIG_TUSB6010) += tusb6010.o obj-$(CONFIG_DIGIC) += digic-timer.o obj-$(CONFIG_MC146818RTC) += mc146818rtc.o diff --git a/hw/usb/Makefile.objs b/hw/usb/Makefile.objs index 8f00fbd..2717027 100644 --- a/hw/usb/Makefile.objs +++ b/hw/usb/Makefile.objs @@ -10,6 +10,8 @@ common-obj-$(CONFIG_USB_EHCI_SYSBUS) += hcd-ehci-sysbus.o common-obj-$(CONFIG_USB_XHCI) += hcd-xhci.o common-obj-$(CONFIG_USB_MUSB) += hcd-musb.o +obj-$(CONFIG_TUSB6010) += tusb6010.o + # emulated usb devices common-obj-$(CONFIG_USB) += dev-hub.o common-obj-$(CONFIG_USB) += dev-hid.o
The TUSB6010 is a USB controller (as the name suggests). Move it from hw/timer (where it was accidentally filed in 2013 when we moved everything out of hw/) to hw/usb. Signed-off-by: Peter Maydell <peter.maydell@linaro.org> --- hw/timer/Makefile.objs | 1 - hw/usb/Makefile.objs | 2 ++ hw/{timer => usb}/tusb6010.c | 0 3 files changed, 2 insertions(+), 1 deletion(-) rename hw/{timer => usb}/tusb6010.c (100%) diff --git a/hw/timer/tusb6010.c b/hw/usb/tusb6010.c similarity index 100% rename from hw/timer/tusb6010.c rename to hw/usb/tusb6010.c