diff mbox series

qapi: Make visit_next_list()'s comment less confusing

Message ID 20190802122325.16520-1-armbru@redhat.com (mailing list archive)
State New, archived
Headers show
Series qapi: Make visit_next_list()'s comment less confusing | expand

Commit Message

Markus Armbruster Aug. 2, 2019, 12:23 p.m. UTC
visit_next_list() returns non-null on success, null on failure.  The
comment's phrasing "until NULL return or error occurs" is needlessly
confusing.  Scratch the "or error occurs" part.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 include/qapi/visitor.h | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Eric Blake Aug. 2, 2019, 1:06 p.m. UTC | #1
On 8/2/19 7:23 AM, Markus Armbruster wrote:
> visit_next_list() returns non-null on success, null on failure.  The
> comment's phrasing "until NULL return or error occurs" is needlessly
> confusing.  Scratch the "or error occurs" part.
> 
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>  include/qapi/visitor.h | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)

Reviewed-by: Eric Blake <eblake@redhat.com>

> 
> diff --git a/include/qapi/visitor.h b/include/qapi/visitor.h
> index 5b2ed3f202..c5b23851a1 100644
> --- a/include/qapi/visitor.h
> +++ b/include/qapi/visitor.h
> @@ -364,10 +364,10 @@ void visit_start_list(Visitor *v, const char *name, GenericList **list,
>   * @tail must not be NULL; on the first call, @tail is the value of
>   * *list after visit_start_list(), and on subsequent calls @tail must
>   * be the previously returned value.  Should be called in a loop until
> - * a NULL return or error occurs; for each non-NULL return, the caller
> - * then calls the appropriate visit_type_*() for the element type of
> - * the list, with that function's name parameter set to NULL and obj
> - * set to the address of @tail->value.
> + * a NULL return; for each non-NULL return, the caller then calls the
> + * appropriate visit_type_*() for the element type of the list, with
> + * that function's name parameter set to NULL and obj set to the
> + * address of @tail->value.
>   */
>  GenericList *visit_next_list(Visitor *v, GenericList *tail, size_t size);
>  
>
Markus Armbruster Aug. 12, 2019, 2:11 p.m. UTC | #2
Markus Armbruster <armbru@redhat.com> writes:

> visit_next_list() returns non-null on success, null on failure.  The
> comment's phrasing "until NULL return or error occurs" is needlessly
> confusing.  Scratch the "or error occurs" part.
>
> Signed-off-by: Markus Armbruster <armbru@redhat.com>

Queued for 4.2.
diff mbox series

Patch

diff --git a/include/qapi/visitor.h b/include/qapi/visitor.h
index 5b2ed3f202..c5b23851a1 100644
--- a/include/qapi/visitor.h
+++ b/include/qapi/visitor.h
@@ -364,10 +364,10 @@  void visit_start_list(Visitor *v, const char *name, GenericList **list,
  * @tail must not be NULL; on the first call, @tail is the value of
  * *list after visit_start_list(), and on subsequent calls @tail must
  * be the previously returned value.  Should be called in a loop until
- * a NULL return or error occurs; for each non-NULL return, the caller
- * then calls the appropriate visit_type_*() for the element type of
- * the list, with that function's name parameter set to NULL and obj
- * set to the address of @tail->value.
+ * a NULL return; for each non-NULL return, the caller then calls the
+ * appropriate visit_type_*() for the element type of the list, with
+ * that function's name parameter set to NULL and obj set to the
+ * address of @tail->value.
  */
 GenericList *visit_next_list(Visitor *v, GenericList *tail, size_t size);