diff mbox series

[PULL,02/17] hw/ppc/ppc4xx_pci: Replace magic value by the PCI_NUM_PINS definition

Message ID 20200919184451.2129349-3-laurent@vivier.eu (mailing list archive)
State New, archived
Headers show
Series [PULL,01/17] hw/gpio/max7310: Remove impossible check | expand

Commit Message

Laurent Vivier Sept. 19, 2020, 6:44 p.m. UTC
From: Philippe Mathieu-Daudé <f4bug@amsat.org>

Replace the magic '4' value by the PCI_NUM_PINS definition.

Suggested-by: Cédric Le Goater <clg@kaod.org>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Acked-by: David Gibson <david@gibson.dropbear.id.au>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Message-Id: <20200910072325.439344-3-f4bug@amsat.org>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>
---
 hw/ppc/ppc4xx_pci.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/hw/ppc/ppc4xx_pci.c b/hw/ppc/ppc4xx_pci.c
index c24bac96c32f..ca2553bf8b75 100644
--- a/hw/ppc/ppc4xx_pci.c
+++ b/hw/ppc/ppc4xx_pci.c
@@ -56,7 +56,7 @@  struct PPC4xxPCIState {
 
     struct PCIMasterMap pmm[PPC4xx_PCI_NR_PMMS];
     struct PCITargetMap ptm[PPC4xx_PCI_NR_PTMS];
-    qemu_irq irq[4];
+    qemu_irq irq[PCI_NUM_PINS];
 
     MemoryRegion container;
     MemoryRegion iomem;