diff mbox series

block/sheepdog: Replace magic val by NANOSECONDS_PER_SECOND definition

Message ID 20200921110145.520944-1-philmd@redhat.com (mailing list archive)
State New, archived
Headers show
Series block/sheepdog: Replace magic val by NANOSECONDS_PER_SECOND definition | expand

Commit Message

Philippe Mathieu-Daudé Sept. 21, 2020, 11:01 a.m. UTC
Use self-explicit NANOSECONDS_PER_SECOND definition instead
of magic value.

Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
---
 block/sheepdog.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alberto Garcia Sept. 21, 2020, 11:06 a.m. UTC | #1
On Mon 21 Sep 2020 01:01:45 PM CEST, Philippe Mathieu-Daudé wrote:
> Use self-explicit NANOSECONDS_PER_SECOND definition instead
> of magic value.
>
> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>

Reviewed-by: Alberto Garcia <berto@igalia.com>

Berto
Kevin Wolf Sept. 23, 2020, 3:18 p.m. UTC | #2
Am 21.09.2020 um 13:01 hat Philippe Mathieu-Daudé geschrieben:
> Use self-explicit NANOSECONDS_PER_SECOND definition instead
> of magic value.
> 
> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>

Thanks, applied to the block branch.

Kevin
diff mbox series

Patch

diff --git a/block/sheepdog.c b/block/sheepdog.c
index cbbebc1aaf2..cbc655a1a05 100644
--- a/block/sheepdog.c
+++ b/block/sheepdog.c
@@ -740,7 +740,7 @@  static coroutine_fn void reconnect_to_sdog(void *opaque)
         if (s->fd < 0) {
             trace_sheepdog_reconnect_to_sdog();
             error_report_err(local_err);
-            qemu_co_sleep_ns(QEMU_CLOCK_REALTIME, 1000000000ULL);
+            qemu_co_sleep_ns(QEMU_CLOCK_REALTIME, NANOSECONDS_PER_SECOND);
         }
     };