diff mbox series

[PULL,5/7] cs4231: Get rid of empty property array

Message ID 20201215134826.5504-6-kraxel@redhat.com (mailing list archive)
State New, archived
Headers show
Series [PULL,1/7] coreaudio: rename misnamed variable fake_as | expand

Commit Message

Gerd Hoffmann Dec. 15, 2020, 1:48 p.m. UTC
From: Eduardo Habkost <ehabkost@redhat.com>

An empty props array is unnecessary, we can just not call
device_class_set_props().

Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
Message-id: 20201211220529.2290218-2-ehabkost@redhat.com
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
---
 hw/audio/cs4231.c | 5 -----
 1 file changed, 5 deletions(-)
diff mbox series

Patch

diff --git a/hw/audio/cs4231.c b/hw/audio/cs4231.c
index 8e9554ce9bcd..209c05a0a0d5 100644
--- a/hw/audio/cs4231.c
+++ b/hw/audio/cs4231.c
@@ -160,17 +160,12 @@  static void cs4231_init(Object *obj)
     sysbus_init_irq(dev, &s->irq);
 }
 
-static Property cs4231_properties[] = {
-    {.name = NULL},
-};
-
 static void cs4231_class_init(ObjectClass *klass, void *data)
 {
     DeviceClass *dc = DEVICE_CLASS(klass);
 
     dc->reset = cs_reset;
     dc->vmsd = &vmstate_cs4231;
-    device_class_set_props(dc, cs4231_properties);
 }
 
 static const TypeInfo cs4231_info = {