diff mbox series

[02/14] hw/gpio/omap_gpio: Add local variable to avoid embedded cast

Message ID 20230109140306.23161-3-philmd@linaro.org (mailing list archive)
State New, archived
Headers show
Series hw/arm: QOM OBJECT_DECLARE_SIMPLE_TYPE cleanups | expand

Commit Message

Philippe Mathieu-Daudé Jan. 9, 2023, 2:02 p.m. UTC
Add a local 'struct omap_gpif_s *' variable to improve readability.
(This also eases next commit conversion).

Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
 hw/gpio/omap_gpio.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/hw/gpio/omap_gpio.c b/hw/gpio/omap_gpio.c
index bd0841d57f..12ec16d1b0 100644
--- a/hw/gpio/omap_gpio.c
+++ b/hw/gpio/omap_gpio.c
@@ -53,7 +53,8 @@  struct omap_gpif_s {
 /* General-Purpose I/O of OMAP1 */
 static void omap_gpio_set(void *opaque, int line, int level)
 {
-    struct omap_gpio_s *s = &((struct omap_gpif_s *) opaque)->omap1;
+    struct omap_gpif_s *p = opaque;
+    struct omap_gpio_s *s = &p->omap1;
     uint16_t prev = s->inputs;
 
     if (level)