Message ID | 20230201150815.409582-10-urezki@gmail.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 456cc5de1f0b9f5feea2221d7a0f06f20498b736 |
Headers | show |
Series | Rename k[v]free_rcu() single argument to k[v]free_rcu_mightsleep() | expand |
> The kfree_rcu()'s single argument name is deprecated therefore > rename it to kfree_rcu_mightsleep() variant. The goal is explicitly > underline that it is for sleepable contexts. > > Cc: Theodore Ts'o <tytso@mit.edu> > Cc: Lukas Czerner <lczerner@redhat.com> > Signed-off-by: Uladzislau Rezki (Sony) <urezki@gmail.com> > Could you please add you reviwed-by or Acked-by tags so we can bring our series with renaming for the next merge window? Thanks! -- Uladzislau Rezki
diff --git a/fs/ext4/super.c b/fs/ext4/super.c index 260c1b3e3ef2..87aa23d047c9 100644 --- a/fs/ext4/super.c +++ b/fs/ext4/super.c @@ -2500,7 +2500,7 @@ static void ext4_apply_quota_options(struct fs_context *fc, qname = rcu_replace_pointer(sbi->s_qf_names[i], qname, lockdep_is_held(&sb->s_umount)); if (qname) - kfree_rcu(qname); + kfree_rcu_mightsleep(qname); } }
The kfree_rcu()'s single argument name is deprecated therefore rename it to kfree_rcu_mightsleep() variant. The goal is explicitly underline that it is for sleepable contexts. Cc: Theodore Ts'o <tytso@mit.edu> Cc: Lukas Czerner <lczerner@redhat.com> Signed-off-by: Uladzislau Rezki (Sony) <urezki@gmail.com> --- fs/ext4/super.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)