Message ID | 20240802003426.4134196-1-paulmck@kernel.org (mailing list archive) |
---|---|
State | Accepted |
Commit | c3554bba31640269e5aa4536809a71e525a260b3 |
Headers | show |
Series | Add RCU Tasks diagnostics and documentation | expand |
Hi Paul, On Thu, Aug 01, 2024 at 05:34:21PM -0700, Paul E. McKenney wrote: > The current mapping of smp_processor_id() to a CPU processing Tasks-RCU > callbacks makes some assumptions about layout. This commit therefore > adds a WARN_ON() to check these assumptions. > > Signed-off-by: Paul E. McKenney <paulmck@kernel.org> > --- > kernel/rcu/tasks.h | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/kernel/rcu/tasks.h b/kernel/rcu/tasks.h > index b6fcf744af75d..d473846a572aa 100644 > --- a/kernel/rcu/tasks.h > +++ b/kernel/rcu/tasks.h > @@ -355,6 +355,7 @@ static void call_rcu_tasks_generic(struct rcu_head *rhp, rcu_callback_t func, > rcu_read_lock(); > ideal_cpu = smp_processor_id() >> READ_ONCE(rtp->percpu_enqueue_shift); > chosen_cpu = cpumask_next(ideal_cpu - 1, cpu_possible_mask); > + WARN_ON_ONCE(chosen_cpu >= nr_cpu_ids); I have changed this s/nr_cpu_ids/rcu_task_cpu_ids/ , as there is a another commit fd70e9f1d85f "rcu-tasks: Fix access non-existent percpu rtpcp variable in rcu_tasks_need_gpcb()" which is included in the tree here [1]. Please let me know if something looks incorrect. [1] https://git.kernel.org/pub/scm/linux/kernel/git/neeraj.upadhyay/linux-rcu.git/log/?h=next.14.08.24a - Neeraj > rtpcp = per_cpu_ptr(rtp->rtpcpu, chosen_cpu); > if (!raw_spin_trylock_rcu_node(rtpcp)) { // irqs already disabled. > raw_spin_lock_rcu_node(rtpcp); // irqs already disabled. > -- > 2.40.1 >
On Wed, Aug 14, 2024 at 05:46:54PM +0530, Neeraj Upadhyay wrote: > Hi Paul, > > On Thu, Aug 01, 2024 at 05:34:21PM -0700, Paul E. McKenney wrote: > > The current mapping of smp_processor_id() to a CPU processing Tasks-RCU > > callbacks makes some assumptions about layout. This commit therefore > > adds a WARN_ON() to check these assumptions. > > > > Signed-off-by: Paul E. McKenney <paulmck@kernel.org> > > --- > > kernel/rcu/tasks.h | 1 + > > 1 file changed, 1 insertion(+) > > > > diff --git a/kernel/rcu/tasks.h b/kernel/rcu/tasks.h > > index b6fcf744af75d..d473846a572aa 100644 > > --- a/kernel/rcu/tasks.h > > +++ b/kernel/rcu/tasks.h > > @@ -355,6 +355,7 @@ static void call_rcu_tasks_generic(struct rcu_head *rhp, rcu_callback_t func, > > rcu_read_lock(); > > ideal_cpu = smp_processor_id() >> READ_ONCE(rtp->percpu_enqueue_shift); > > chosen_cpu = cpumask_next(ideal_cpu - 1, cpu_possible_mask); > > + WARN_ON_ONCE(chosen_cpu >= nr_cpu_ids); > > I have changed this s/nr_cpu_ids/rcu_task_cpu_ids/ , as there is a > another commit fd70e9f1d85f "rcu-tasks: Fix access non-existent percpu > rtpcp variable in rcu_tasks_need_gpcb()" which is included in the tree > here [1]. Please let me know if something looks incorrect. > > [1] https://git.kernel.org/pub/scm/linux/kernel/git/neeraj.upadhyay/linux-rcu.git/log/?h=next.14.08.24a Good catch, looks good, and thank you! Thanx, Paul > - Neeraj > > > rtpcp = per_cpu_ptr(rtp->rtpcpu, chosen_cpu); > > if (!raw_spin_trylock_rcu_node(rtpcp)) { // irqs already disabled. > > raw_spin_lock_rcu_node(rtpcp); // irqs already disabled. > > -- > > 2.40.1 > >
diff --git a/kernel/rcu/tasks.h b/kernel/rcu/tasks.h index b6fcf744af75d..d473846a572aa 100644 --- a/kernel/rcu/tasks.h +++ b/kernel/rcu/tasks.h @@ -355,6 +355,7 @@ static void call_rcu_tasks_generic(struct rcu_head *rhp, rcu_callback_t func, rcu_read_lock(); ideal_cpu = smp_processor_id() >> READ_ONCE(rtp->percpu_enqueue_shift); chosen_cpu = cpumask_next(ideal_cpu - 1, cpu_possible_mask); + WARN_ON_ONCE(chosen_cpu >= nr_cpu_ids); rtpcp = per_cpu_ptr(rtp->rtpcpu, chosen_cpu); if (!raw_spin_trylock_rcu_node(rtpcp)) { // irqs already disabled. raw_spin_lock_rcu_node(rtpcp); // irqs already disabled.
The current mapping of smp_processor_id() to a CPU processing Tasks-RCU callbacks makes some assumptions about layout. This commit therefore adds a WARN_ON() to check these assumptions. Signed-off-by: Paul E. McKenney <paulmck@kernel.org> --- kernel/rcu/tasks.h | 1 + 1 file changed, 1 insertion(+)