diff mbox

[3/4] spi: spi-fsl-dspi: Fix continuous selection format

Message ID c1e51fc92dbcc9c31dcdcdfab3eed40d7745308a.1479384571.git.maitysanchayan@gmail.com (mailing list archive)
State New, archived
Headers show

Commit Message

Sanchayan Nov. 17, 2016, 12:16 p.m. UTC
Current DMA implementation was not handling the continuous selection
format viz. SPI chip select would be deasserted even between sequential
serial transfers. Use the cs_change variable and correctly set or
reset the CONT bit accordingly for case where peripherals require
the chip select to be asserted between sequential transfers.

Signed-off-by: Sanchayan Maity <maitysanchayan@gmail.com>
---
 drivers/spi/spi-fsl-dspi.c | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Stefan Agner Nov. 18, 2016, 1:07 a.m. UTC | #1
On 2016-11-17 04:16, Sanchayan Maity wrote:
> Current DMA implementation was not handling the continuous selection
> format viz. SPI chip select would be deasserted even between sequential
> serial transfers. Use the cs_change variable and correctly set or
> reset the CONT bit accordingly for case where peripherals require
> the chip select to be asserted between sequential transfers.
> 
> Signed-off-by: Sanchayan Maity <maitysanchayan@gmail.com>
> ---
>  drivers/spi/spi-fsl-dspi.c | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/spi/spi-fsl-dspi.c b/drivers/spi/spi-fsl-dspi.c
> index aee8c88..164e2e1 100644
> --- a/drivers/spi/spi-fsl-dspi.c
> +++ b/drivers/spi/spi-fsl-dspi.c
> @@ -258,9 +258,16 @@ static int dspi_next_xfer_dma_submit(struct fsl_dspi *dspi)
>  	}
>  
>  	val = tx_word ? *(u16 *) dspi->tx : *(u8 *) dspi->tx;
> -	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> -					SPI_PUSHR_PCS(dspi->cs) |
> -					SPI_PUSHR_CTAS(0);
> +	if (dspi->cs_change) {
> +		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> +						SPI_PUSHR_PCS(dspi->cs) |
> +						SPI_PUSHR_CTAS(0);
> +	} else {
> +		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> +						SPI_PUSHR_PCS(dspi->cs) |
> +						SPI_PUSHR_CTAS(0) |
> +						SPI_PUSHR_CONT;
> +	}

How about:


	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
					SPI_PUSHR_PCS(dspi->cs) |
					SPI_PUSHR_CTAS(0);

+	if (dspi->cs_change)
+		dspi->dma->tx_dma_buf[i] |= SPI_PUSHR_CONT;


Avoids code duplication...

--
Stefan



>  	dspi->tx += tx_word + 1;
>  
>  	dma->tx_desc = dmaengine_prep_slave_single(dma->chan_tx,
--
To unsubscribe from this list: send the line "unsubscribe linux-spi" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Sanchayan Nov. 18, 2016, 7:59 a.m. UTC | #2
Hello Stefan,

On 16-11-17 17:07:24, Stefan Agner wrote:
> On 2016-11-17 04:16, Sanchayan Maity wrote:
> > Current DMA implementation was not handling the continuous selection
> > format viz. SPI chip select would be deasserted even between sequential
> > serial transfers. Use the cs_change variable and correctly set or
> > reset the CONT bit accordingly for case where peripherals require
> > the chip select to be asserted between sequential transfers.
> > 
> > Signed-off-by: Sanchayan Maity <maitysanchayan@gmail.com>
> > ---
> >  drivers/spi/spi-fsl-dspi.c | 13 ++++++++++---
> >  1 file changed, 10 insertions(+), 3 deletions(-)
> > 
> > diff --git a/drivers/spi/spi-fsl-dspi.c b/drivers/spi/spi-fsl-dspi.c
> > index aee8c88..164e2e1 100644
> > --- a/drivers/spi/spi-fsl-dspi.c
> > +++ b/drivers/spi/spi-fsl-dspi.c
> > @@ -258,9 +258,16 @@ static int dspi_next_xfer_dma_submit(struct fsl_dspi *dspi)
> >  	}
> >  
> >  	val = tx_word ? *(u16 *) dspi->tx : *(u8 *) dspi->tx;
> > -	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> > -					SPI_PUSHR_PCS(dspi->cs) |
> > -					SPI_PUSHR_CTAS(0);
> > +	if (dspi->cs_change) {
> > +		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> > +						SPI_PUSHR_PCS(dspi->cs) |
> > +						SPI_PUSHR_CTAS(0);
> > +	} else {
> > +		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> > +						SPI_PUSHR_PCS(dspi->cs) |
> > +						SPI_PUSHR_CTAS(0) |
> > +						SPI_PUSHR_CONT;
> > +	}
> 
> How about:
> 
> 
> 	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> 					SPI_PUSHR_PCS(dspi->cs) |
> 					SPI_PUSHR_CTAS(0);
> 
> +	if (dspi->cs_change)
> +		dspi->dma->tx_dma_buf[i] |= SPI_PUSHR_CONT;
> 
> 
> Avoids code duplication...

Agreed. It's much better. Should be !dspi->cs_change though.

Will include it in next iteration.

Thanks & Regards,
Sanchayan.

> 
> --
> Stefan
> 
> 
> 
> >  	dspi->tx += tx_word + 1;
> >  
> >  	dma->tx_desc = dmaengine_prep_slave_single(dma->chan_tx,
--
To unsubscribe from this list: send the line "unsubscribe linux-spi" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/spi/spi-fsl-dspi.c b/drivers/spi/spi-fsl-dspi.c
index aee8c88..164e2e1 100644
--- a/drivers/spi/spi-fsl-dspi.c
+++ b/drivers/spi/spi-fsl-dspi.c
@@ -258,9 +258,16 @@  static int dspi_next_xfer_dma_submit(struct fsl_dspi *dspi)
 	}
 
 	val = tx_word ? *(u16 *) dspi->tx : *(u8 *) dspi->tx;
-	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
-					SPI_PUSHR_PCS(dspi->cs) |
-					SPI_PUSHR_CTAS(0);
+	if (dspi->cs_change) {
+		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
+						SPI_PUSHR_PCS(dspi->cs) |
+						SPI_PUSHR_CTAS(0);
+	} else {
+		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
+						SPI_PUSHR_PCS(dspi->cs) |
+						SPI_PUSHR_CTAS(0) |
+						SPI_PUSHR_CONT;
+	}
 	dspi->tx += tx_word + 1;
 
 	dma->tx_desc = dmaengine_prep_slave_single(dma->chan_tx,