Message ID | 20211015132643.1621913-3-hch@lst.de (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h | expand |
On Fri, Oct 15, 2021 at 03:26:15PM +0200, Christoph Hellwig wrote: > +static inline sector_t bdev_nr_bytes(struct block_device *bdev) > +{ > + return i_size_read(bdev->bd_inode); Uh. loff_t, surely?
On Fri, Oct 15, 2021 at 02:35:15PM +0100, Matthew Wilcox wrote: > On Fri, Oct 15, 2021 at 03:26:15PM +0200, Christoph Hellwig wrote: > > +static inline sector_t bdev_nr_bytes(struct block_device *bdev) > > +{ > > + return i_size_read(bdev->bd_inode); > > Uh. loff_t, surely? Yes, that wuld be the right type. Note that it makes a difference outside of documentation purposes.
Hi Christoph, > On 15 Oct 2021, at 14:26, Christoph Hellwig <hch@lst.de> wrote: > > Add a helpe to query the size of a block device in bytes. This > will be used to remove open coded access to ->bd_inode. Matthew already pointed out the return type for bdev_nr_bytes() but also your commit message has a typo: "Add a helpe" -> "Add a helper". Best regards, Anton > Signed-off-by: Christoph Hellwig <hch@lst.de> > --- > include/linux/genhd.h | 7 ++++++- > 1 file changed, 6 insertions(+), 1 deletion(-) > > diff --git a/include/linux/genhd.h b/include/linux/genhd.h > index 082a3e5fd8fa1..f67db3c5a04b3 100644 > --- a/include/linux/genhd.h > +++ b/include/linux/genhd.h > @@ -235,9 +235,14 @@ static inline sector_t get_start_sect(struct block_device *bdev) > return bdev->bd_start_sect; > } > > +static inline sector_t bdev_nr_bytes(struct block_device *bdev) > +{ > + return i_size_read(bdev->bd_inode); > +} > + > static inline sector_t bdev_nr_sectors(struct block_device *bdev) > { > - return i_size_read(bdev->bd_inode) >> 9; > + return bdev_nr_bytes(bdev) >> SECTOR_SHIFT; > } > > static inline sector_t get_capacity(struct gendisk *disk) > -- > 2.30.2 >
On Fri, Oct 15, 2021 at 02:37:41PM +0000, Anton Altaparmakov wrote: > Hi Christoph, > > > On 15 Oct 2021, at 14:26, Christoph Hellwig <hch@lst.de> wrote: > > > > Add a helpe to query the size of a block device in bytes. This > > will be used to remove open coded access to ->bd_inode. > > Matthew already pointed out the return type for bdev_nr_bytes() but also your commit message has a typo: "Add a helpe" -> "Add a helper". Right. With these fixed, I'm a fan. :) Reviewed-by: Kees Cook <keescook@chromium.org> -Kees
diff --git a/include/linux/genhd.h b/include/linux/genhd.h index 082a3e5fd8fa1..f67db3c5a04b3 100644 --- a/include/linux/genhd.h +++ b/include/linux/genhd.h @@ -235,9 +235,14 @@ static inline sector_t get_start_sect(struct block_device *bdev) return bdev->bd_start_sect; } +static inline sector_t bdev_nr_bytes(struct block_device *bdev) +{ + return i_size_read(bdev->bd_inode); +} + static inline sector_t bdev_nr_sectors(struct block_device *bdev) { - return i_size_read(bdev->bd_inode) >> 9; + return bdev_nr_bytes(bdev) >> SECTOR_SHIFT; } static inline sector_t get_capacity(struct gendisk *disk)
Add a helpe to query the size of a block device in bytes. This will be used to remove open coded access to ->bd_inode. Signed-off-by: Christoph Hellwig <hch@lst.de> --- include/linux/genhd.h | 7 ++++++- 1 file changed, 6 insertions(+), 1 deletion(-)