diff mbox

[V9fs-developer] 9p: safer definition of P9_NOTAG and P9_NOFID

Message ID 148170364325.11774.10800199735048760595.stgit@bahia (mailing list archive)
State Superseded, archived
Headers show

Commit Message

Greg Kurz Dec. 14, 2016, 8:20 a.m. UTC
Both defines should at least have enclosing parenthesis to be usable in
any syntactical situation. This is the case of U16_MAX and U32_MAX, so
let's use them.

This patch is just cleanup, it doesn't change any behaviour with the current
code.

Signed-off-by: Greg Kurz <groug@kaod.org>
---
 include/net/9p/9p.h |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
diff mbox

Patch

diff --git a/include/net/9p/9p.h b/include/net/9p/9p.h
index 27dfe85772b1..5c80d98126b3 100644
--- a/include/net/9p/9p.h
+++ b/include/net/9p/9p.h
@@ -332,8 +332,8 @@  enum p9_qid_t {
 };
 
 /* 9P Magic Numbers */
-#define P9_NOTAG	(u16)(~0)
-#define P9_NOFID	(u32)(~0)
+#define P9_NOTAG	U16_MAX
+#define P9_NOFID	U32_MAX
 #define P9_MAXWELEM	16
 
 /* ample room for Twrite/Rread header */