mbox series

[0/5] hw: Use PCI macros from 'hw/pci/pci.h'

Message ID 20201012124506.3406909-1-philmd@redhat.com (mailing list archive)
Headers show
Series hw: Use PCI macros from 'hw/pci/pci.h' | expand

Message

Philippe Mathieu-Daudé Oct. 12, 2020, 12:45 p.m. UTC
Trivial patches using the generic PCI macros from "hw/pci/pci.h".

Philippe Mathieu-Daudé (5):
  hw/pci-host/bonito: Make PCI_ADDR() macro more readable
  hw/pci-host: Use the PCI_BUILD_BDF() macro from 'hw/pci/pci.h'
  hw/pci-host/uninorth: Use the PCI_FUNC() macro from 'hw/pci/pci.h'
  hw: Use the PCI_SLOT() macro from 'hw/pci/pci.h'
  hw: Use the PCI_DEVFN() macro from 'hw/pci/pci.h'

 hw/arm/virt.c          | 3 ++-
 hw/hppa/dino.c         | 2 +-
 hw/i386/xen/xen-hvm.c  | 2 +-
 hw/isa/piix3.c         | 2 +-
 hw/mips/gt64xxx_pci.c  | 2 +-
 hw/pci-host/bonito.c   | 5 ++---
 hw/pci-host/pnv_phb4.c | 2 +-
 hw/pci-host/ppce500.c  | 2 +-
 hw/pci-host/uninorth.c | 8 +++-----
 hw/ppc/ppc4xx_pci.c    | 2 +-
 hw/sh4/sh_pci.c        | 2 +-
 11 files changed, 15 insertions(+), 17 deletions(-)

Comments

Philippe Mathieu-Daudé Jan. 3, 2021, 1:04 p.m. UTC | #1
On 10/12/20 2:45 PM, Philippe Mathieu-Daudé wrote:
> Trivial patches using the generic PCI macros from "hw/pci/pci.h".
> 
> Philippe Mathieu-Daudé (5):
>   hw/pci-host/bonito: Make PCI_ADDR() macro more readable
>   hw/pci-host: Use the PCI_BUILD_BDF() macro from 'hw/pci/pci.h'
>   hw/pci-host/uninorth: Use the PCI_FUNC() macro from 'hw/pci/pci.h'
>   hw: Use the PCI_SLOT() macro from 'hw/pci/pci.h'
>   hw: Use the PCI_DEVFN() macro from 'hw/pci/pci.h'

As this series are trivial and Acked, I'm going to queue
it via the mips-tree, as other reviewed patches depend
on it.

Thanks,

Phil.
Michael S. Tsirkin Jan. 4, 2021, 9:32 a.m. UTC | #2
On Sun, Jan 03, 2021 at 02:04:53PM +0100, Philippe Mathieu-Daudé wrote:
> On 10/12/20 2:45 PM, Philippe Mathieu-Daudé wrote:
> > Trivial patches using the generic PCI macros from "hw/pci/pci.h".
> > 
> > Philippe Mathieu-Daudé (5):
> >   hw/pci-host/bonito: Make PCI_ADDR() macro more readable
> >   hw/pci-host: Use the PCI_BUILD_BDF() macro from 'hw/pci/pci.h'
> >   hw/pci-host/uninorth: Use the PCI_FUNC() macro from 'hw/pci/pci.h'
> >   hw: Use the PCI_SLOT() macro from 'hw/pci/pci.h'
> >   hw: Use the PCI_DEVFN() macro from 'hw/pci/pci.h'
> 
> As this series are trivial and Acked, I'm going to queue
> it via the mips-tree, as other reviewed patches depend
> on it.
> 
> Thanks,
> 
> Phil.

Fine.
Acked-by: Michael S. Tsirkin <mst@redhat.com>