mbox series

[v2,0/5] xen/arm: mm: Bunch of clean-ups

Message ID 20220720184459.51582-1-julien@xen.org (mailing list archive)
Headers show
Series xen/arm: mm: Bunch of clean-ups | expand

Message

Julien Grall July 20, 2022, 6:44 p.m. UTC
From: Julien Grall <jgrall@amazon.com>

Hi all,

This series is a collection of patches to clean-up the MM subsystem
I have done in preparation for the next revision of "xen/arm: Don't
switch TTBR while the MMU is on" [1].

Cheers,

[1] https://lore.kernel.org/all/20220309112048.17377-1-julien@xen.org/

Julien Grall (5):
  xen/arm: Remove most of the *_VIRT_END defines
  xen/arm32: mm: Consolidate the domheap mappings initialization
  xen: Rename CONFIG_DOMAIN_PAGE to CONFIG_ARCH_MAP_DOMAIN_PAGE and...
  xen/arm: mm: Move domain_{,un}map_* helpers in a separate file
  xen/arm: mm: Reduce the area that xen_second covers

 xen/arch/arm/Kconfig                |   1 +
 xen/arch/arm/Makefile               |   1 +
 xen/arch/arm/domain_page.c          | 193 ++++++++++++++++++++++++
 xen/arch/arm/include/asm/arm32/mm.h |   8 +
 xen/arch/arm/include/asm/config.h   |  19 +--
 xen/arch/arm/include/asm/lpae.h     |  17 +++
 xen/arch/arm/livepatch.c            |   2 +-
 xen/arch/arm/mm.c                   | 221 ++++------------------------
 xen/arch/arm/setup.c                |  21 ++-
 xen/arch/x86/Kconfig                |   1 +
 xen/arch/x86/include/asm/config.h   |   1 -
 xen/common/Kconfig                  |   6 +
 xen/include/xen/domain_page.h       |   6 +-
 13 files changed, 283 insertions(+), 214 deletions(-)
 create mode 100644 xen/arch/arm/domain_page.c

Comments

Bertrand Marquis July 21, 2022, 8:59 a.m. UTC | #1
Hi Julien,

> On 20 Jul 2022, at 19:44, Julien Grall <julien@xen.org> wrote:
> 
> From: Julien Grall <jgrall@amazon.com>
> 
> Hi all,
> 
> This series is a collection of patches to clean-up the MM subsystem
> I have done in preparation for the next revision of "xen/arm: Don't
> switch TTBR while the MMU is on" [1].
> 
> Cheers,
> 
> [1] https://lore.kernel.org/all/20220309112048.17377-1-julien@xen.org/
> 


I tested the whole serie with (including starting a guest) on qemu x86, qemu arm32, qemu arm64 and fvp base.

So for the whole serie:
Tested-by: Bertrand Marquis <bertrand.marquis@arm.com>

Cheers
Bertrand

> Julien Grall (5):
>  xen/arm: Remove most of the *_VIRT_END defines
>  xen/arm32: mm: Consolidate the domheap mappings initialization
>  xen: Rename CONFIG_DOMAIN_PAGE to CONFIG_ARCH_MAP_DOMAIN_PAGE and...
>  xen/arm: mm: Move domain_{,un}map_* helpers in a separate file
>  xen/arm: mm: Reduce the area that xen_second covers
> 
> xen/arch/arm/Kconfig                |   1 +
> xen/arch/arm/Makefile               |   1 +
> xen/arch/arm/domain_page.c          | 193 ++++++++++++++++++++++++
> xen/arch/arm/include/asm/arm32/mm.h |   8 +
> xen/arch/arm/include/asm/config.h   |  19 +--
> xen/arch/arm/include/asm/lpae.h     |  17 +++
> xen/arch/arm/livepatch.c            |   2 +-
> xen/arch/arm/mm.c                   | 221 ++++------------------------
> xen/arch/arm/setup.c                |  21 ++-
> xen/arch/x86/Kconfig                |   1 +
> xen/arch/x86/include/asm/config.h   |   1 -
> xen/common/Kconfig                  |   6 +
> xen/include/xen/domain_page.h       |   6 +-
> 13 files changed, 283 insertions(+), 214 deletions(-)
> create mode 100644 xen/arch/arm/domain_page.c
> 
> -- 
> 2.32.0
> 
>
Julien Grall July 29, 2022, 10:04 p.m. UTC | #2
Hi,

On 20/07/2022 19:44, Julien Grall wrote:
> From: Julien Grall <jgrall@amazon.com>
> 
> Hi all,
> 
> This series is a collection of patches to clean-up the MM subsystem
> I have done in preparation for the next revision of "xen/arm: Don't
> switch TTBR while the MMU is on" [1].
> 
> Cheers,
> 
> [1] https://lore.kernel.org/all/20220309112048.17377-1-julien@xen.org/
> 
> Julien Grall (5):
>    xen/arm: Remove most of the *_VIRT_END defines
>    xen/arm32: mm: Consolidate the domheap mappings initialization
>    xen: Rename CONFIG_DOMAIN_PAGE to CONFIG_ARCH_MAP_DOMAIN_PAGE and...
>    xen/arm: mm: Move domain_{,un}map_* helpers in a separate file
>    xen/arm: mm: Reduce the area that xen_second covers

I have committed this series.

Cheers,