mbox series

[v6,0/3] x86/boot: Reduce assembly code

Message ID 20240926092109.475271-1-frediano.ziglio@cloud.com (mailing list archive)
Headers show
Series x86/boot: Reduce assembly code | expand

Message

Frediano Ziglio Sept. 26, 2024, 9:21 a.m. UTC
This series came from part of the work of removing duplications between
boot code and rewriting part of code from assembly to C.
First patch rework BIOS/PVH paths to reuse some code.
Second patch rewrites EFI code in pure C.

Changes since v1, more details in specific commits:
- style updates;
- comments and descriptions improvements;
- other improvements.

Changes since v2:
- rebased on master, resolved conflicts;
- add comment on trampoline section.

Changes since v3:
- changed new function name;
- declare efi_multiboot2 in a separate header;
- distinguish entry point from using magic number;
- other minor changes (see commens in commits).

Changes since v4:
- rebase on staging;
- set %fs and %gs as other segment registers;
- style and other changes.

Changes since v5:
- fixed a typo.

Frediano Ziglio (3):
  x86/boot: Refactor BIOS/PVH start
  x86/boot: Rewrite EFI/MBI2 code partly in C
  x86/boot: Improve MBI2 structure check

 xen/arch/x86/boot/head.S       | 246 +++++++++------------------------
 xen/arch/x86/efi/Makefile      |   1 +
 xen/arch/x86/efi/efi-boot.h    |   6 +-
 xen/arch/x86/efi/parse-mbi2.c  |  66 +++++++++
 xen/arch/x86/efi/stub.c        |   3 +-
 xen/arch/x86/include/asm/efi.h |  18 +++
 6 files changed, 155 insertions(+), 185 deletions(-)
 create mode 100644 xen/arch/x86/efi/parse-mbi2.c
 create mode 100644 xen/arch/x86/include/asm/efi.h

Comments

Jan Beulich Sept. 26, 2024, 10:43 a.m. UTC | #1
On 26.09.2024 11:21, Frediano Ziglio wrote:
> This series came from part of the work of removing duplications between
> boot code and rewriting part of code from assembly to C.
> First patch rework BIOS/PVH paths to reuse some code.
> Second patch rewrites EFI code in pure C.
> 
> Changes since v1, more details in specific commits:
> - style updates;
> - comments and descriptions improvements;
> - other improvements.
> 
> Changes since v2:
> - rebased on master, resolved conflicts;
> - add comment on trampoline section.
> 
> Changes since v3:
> - changed new function name;
> - declare efi_multiboot2 in a separate header;
> - distinguish entry point from using magic number;
> - other minor changes (see commens in commits).
> 
> Changes since v4:
> - rebase on staging;
> - set %fs and %gs as other segment registers;
> - style and other changes.
> 
> Changes since v5:
> - fixed a typo.

That's probably fine, yet may I ask that you slow down some with submissions
of new versions (not just here)? Multiple versions a day are odd, even more
so when the discussion on the earlier version hasn't fully settled yet. If
after several days (maybe a week) you find that the discussion doesn't move
forward anymore, then of course it's fine to go ahead with a new version
despite there perhaps having been some loose ends.

Jan