mbox series

[v2,0/5] Move {acpi_}device_init() and device_get_class() to common code

Message ID cover.1726579819.git.oleksii.kurochko@gmail.com (mailing list archive)
Headers show
Series Move {acpi_}device_init() and device_get_class() to common code | expand

Message

Oleksii Kurochko Sept. 17, 2024, 4:15 p.m. UTC
The {acpi_}device_init() and device_get_class() functions are identical across
Arm and RISC-V, and they are likely to remain the same for other architectures
like PPC.
Since there is no architecture-specific logic within these functions, they are
good candidates to be moved to the common codebase.

This patch series refactors the code by moving these functions to the common
directory, reducing code duplication and simplifying future maintenance.

---
Changes in v2:
 - Introduce macros for definition of ACPI and Device Tree sections.
 - Introduce CONFIG_DEVICE_INIT to make common/device.o compilable only for Arm,
   PPC and RISC-V.
---
Oleksii Kurochko (5):
  xen: define ACPI and DT device info sections macros
  xen/arm: use {DT,ACPI}_DEV_INFO for device info sections
  xen/ppc: add section for device information in linker script
  xen/riscv: add section for device information in linker script
  xen/common: move device initialization code to common code

 xen/arch/arm/device.c     | 71 +--------------------------------
 xen/arch/arm/xen.lds.S    | 14 +------
 xen/arch/ppc/xen.lds.S    |  3 ++
 xen/arch/riscv/xen.lds.S  |  3 ++
 xen/common/Kconfig        |  8 ++++
 xen/common/Makefile       |  1 +
 xen/common/device.c       | 82 +++++++++++++++++++++++++++++++++++++++
 xen/include/xen/xen.lds.h | 26 +++++++++++++
 8 files changed, 127 insertions(+), 81 deletions(-)
 create mode 100644 xen/common/device.c