diff mbox

libxl, xl: change p9 to p9s

Message ID 20170829111901.19874-1-wei.liu2@citrix.com (mailing list archive)
State New, archived
Headers show

Commit Message

Wei Liu Aug. 29, 2017, 11:19 a.m. UTC
To match our naming convention. Since we released p9 one release ago,
we need to define a macro inside libxl.h to indicate the change.

Signed-off-by: Wei Liu <wei.liu2@citrix.com>
---
Cc: Stefano Stabellini <sstabellini@kernel.org>
Cc: Ian Jackson <ian.jackson@eu.citrix.com>
Cc: Oleksandr Grytsov <oleksandr_grytsov@epam.com>
Cc: Jim Fehlig <jfehlig@suse.com>

Ian and I discussed IRL, the conclusion is that changing the field name should
be OK.
---
 tools/libxl/libxl.h         | 5 +++++
 tools/libxl/libxl_create.c  | 2 +-
 tools/libxl/libxl_types.idl | 2 +-
 tools/xl/xl_parse.c         | 4 ++--
 4 files changed, 9 insertions(+), 4 deletions(-)

Comments

Wei Liu Aug. 30, 2017, 11:24 a.m. UTC | #1
On Tue, Aug 29, 2017 at 12:19:01PM +0100, Wei Liu wrote:
> To match our naming convention. Since we released p9 one release ago,
> we need to define a macro inside libxl.h to indicate the change.
> 
> Signed-off-by: Wei Liu <wei.liu2@citrix.com>
> ---
> Cc: Stefano Stabellini <sstabellini@kernel.org>
> Cc: Ian Jackson <ian.jackson@eu.citrix.com>
> Cc: Oleksandr Grytsov <oleksandr_grytsov@epam.com>
> Cc: Jim Fehlig <jfehlig@suse.com>
> 
> Ian and I discussed IRL, the conclusion is that changing the field name should
> be OK.

If I hear no objection by Friday I will commit this patch.
Wei Liu Sept. 1, 2017, 5:01 p.m. UTC | #2
On Wed, Aug 30, 2017 at 12:24:58PM +0100, Wei Liu wrote:
> On Tue, Aug 29, 2017 at 12:19:01PM +0100, Wei Liu wrote:
> > To match our naming convention. Since we released p9 one release ago,
> > we need to define a macro inside libxl.h to indicate the change.
> > 
> > Signed-off-by: Wei Liu <wei.liu2@citrix.com>
> > ---
> > Cc: Stefano Stabellini <sstabellini@kernel.org>
> > Cc: Ian Jackson <ian.jackson@eu.citrix.com>
> > Cc: Oleksandr Grytsov <oleksandr_grytsov@epam.com>
> > Cc: Jim Fehlig <jfehlig@suse.com>
> > 
> > Ian and I discussed IRL, the conclusion is that changing the field name should
> > be OK.
> 
> If I hear no objection by Friday I will commit this patch.

Committed now.
diff mbox

Patch

diff --git a/tools/libxl/libxl.h b/tools/libxl/libxl.h
index 17045253ab..812b7ea95d 100644
--- a/tools/libxl/libxl.h
+++ b/tools/libxl/libxl.h
@@ -305,6 +305,11 @@ 
  */
 #define LIBXL_HAVE_BUILDINFO_HVM_ACPI_LAPTOP_SLATE 1
 
+/*
+ * LIBXL_HAVE_P9S indicates that the p9 field in IDL has been changed to p9s
+ */
+#define LIBXL_HAVE_P9S 1
+
 /*
  * libxl ABI compatibility
  *
diff --git a/tools/libxl/libxl_create.c b/tools/libxl/libxl_create.c
index 1d24209242..936a6e5012 100644
--- a/tools/libxl/libxl_create.c
+++ b/tools/libxl/libxl_create.c
@@ -1327,7 +1327,7 @@  static void domcreate_launch_dm(libxl__egc *egc, libxl__multidev *multidev,
     }
 
     for (i = 0; i < d_config->num_p9s; i++)
-        libxl__device_p9_add(gc, domid, &d_config->p9[i]);
+        libxl__device_p9_add(gc, domid, &d_config->p9s[i]);
 
     switch (d_config->c_info.type) {
     case LIBXL_DOMAIN_TYPE_HVM:
diff --git a/tools/libxl/libxl_types.idl b/tools/libxl/libxl_types.idl
index 6e80d36256..173d70acec 100644
--- a/tools/libxl/libxl_types.idl
+++ b/tools/libxl/libxl_types.idl
@@ -791,7 +791,7 @@  libxl_domain_config = Struct("domain_config", [
     ("vfbs", Array(libxl_device_vfb, "num_vfbs")),
     ("vkbs", Array(libxl_device_vkb, "num_vkbs")),
     ("vtpms", Array(libxl_device_vtpm, "num_vtpms")),
-    ("p9", Array(libxl_device_p9, "num_p9s")),
+    ("p9s", Array(libxl_device_p9, "num_p9s")),
     # a channel manifests as a console with a name,
     # see docs/misc/channels.txt
     ("channels", Array(libxl_device_channel, "num_channels")),
diff --git a/tools/xl/xl_parse.c b/tools/xl/xl_parse.c
index 5c2bf17222..02ddd2e90d 100644
--- a/tools/xl/xl_parse.c
+++ b/tools/xl/xl_parse.c
@@ -1401,9 +1401,9 @@  void parse_config_data(const char *config_source,
         char *p, *p2, *buf2;
 
         d_config->num_p9s = 0;
-        d_config->p9 = NULL;
+        d_config->p9s = NULL;
         while ((buf = xlu_cfg_get_listitem (p9devs, d_config->num_p9s)) != NULL) {
-            p9 = ARRAY_EXTEND_INIT(d_config->p9,
+            p9 = ARRAY_EXTEND_INIT(d_config->p9s,
                                    d_config->num_p9s,
                                    libxl_device_p9_init);
             libxl_device_p9_init(p9);