diff mbox series

scripts/add_maintainers.pl: add -o as an alternative to --patchdir

Message ID dc05a59dc0e186f9dcec8d0e877ee80af168b6a8.1650551981.git.ehem+xen@m5p.com (mailing list archive)
State New, archived
Headers show
Series scripts/add_maintainers.pl: add -o as an alternative to --patchdir | expand

Commit Message

Elliott Mitchell April 21, 2022, 2:35 p.m. UTC
This matches the output directory option used by `git format-patch`.  I
suspect I'm not the only one who finds matching `git format-patch` more
intuitive, than -d for directory.

Signed-off-by: Elliott Mitchell <ehem+xen@m5p.com>
---
 scripts/add_maintainers.pl | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Jürgen Groß April 22, 2022, 5:18 a.m. UTC | #1
On 21.04.22 16:35, Elliott Mitchell wrote:
> This matches the output directory option used by `git format-patch`.  I
> suspect I'm not the only one who finds matching `git format-patch` more
> intuitive, than -d for directory.

Thank you for doing that!

> Signed-off-by: Elliott Mitchell <ehem+xen@m5p.com>

Reviewed-by: Juergen Gross <jgross@suse.com>


Juergen
diff mbox series

Patch

diff --git a/scripts/add_maintainers.pl b/scripts/add_maintainers.pl
index 5a6d0f631b..380e8da22a 100755
--- a/scripts/add_maintainers.pl
+++ b/scripts/add_maintainers.pl
@@ -32,7 +32,7 @@  $get_maintainer =~ s/add_maintainers/get_maintainer/;
 my $usage = <<EOT;
 OPTIONS:
 --------
-USAGE: $tool [options] (--patchdir | -d) <patchdir>
+USAGE: $tool [options] (--patchdir | -d | -o) <patchdir>
 
   --reroll-count <n> | -v <n>
     Choose patch files for specific version. This results into the
@@ -223,7 +223,7 @@  my $patch_ext           = ".patch";
 my $maintainers         = "MAINTAINERS";
 
 if (!GetOptions(
-                'd|patchdir=s'     => \$patch_dir,
+                'd|o|patchdir=s'   => \$patch_dir,
                 'v|reroll-count=i' => \$rerollcount,
                 'p|patchcc=s'      => \$plocation,
                 'c|covercc=s'      => \$clocation,