From patchwork Tue Aug 13 09:03:03 2019 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Nikolay Borisov X-Patchwork-Id: 11091541 Return-Path: Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org [172.30.200.125]) by pdx-korg-patchwork-2.web.codeaurora.org (Postfix) with ESMTP id D542B112C for ; Tue, 13 Aug 2019 09:03:13 +0000 (UTC) Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id C791C284D4 for ; Tue, 13 Aug 2019 09:03:13 +0000 (UTC) Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486) id BC50B28617; Tue, 13 Aug 2019 09:03:13 +0000 (UTC) X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on pdx-wl-mail.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-7.9 required=2.0 tests=BAYES_00,MAILING_LIST_MULTI, RCVD_IN_DNSWL_HI autolearn=ham version=3.3.1 Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 7E304284D4 for ; Tue, 13 Aug 2019 09:03:13 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1727149AbfHMJDN (ORCPT ); Tue, 13 Aug 2019 05:03:13 -0400 Received: from mx2.suse.de ([195.135.220.15]:54916 "EHLO mx1.suse.de" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1726026AbfHMJDM (ORCPT ); Tue, 13 Aug 2019 05:03:12 -0400 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.220.254]) by mx1.suse.de (Postfix) with ESMTP id 1694FAF59; Tue, 13 Aug 2019 09:03:08 +0000 (UTC) From: Nikolay Borisov To: linux-xfs@vger.kernel.org Cc: darrick.wong@oracle.com, Nikolay Borisov Subject: [PATCH 0/3] Minor cleanups Date: Tue, 13 Aug 2019 12:03:03 +0300 Message-Id: <20190813090306.31278-1-nborisov@suse.com> X-Mailer: git-send-email 2.17.1 Sender: linux-xfs-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-xfs@vger.kernel.org X-Virus-Scanned: ClamAV using ClamSMTP While digging around xfs' buf code I spotted a couple of cleanup candidates which resulted in this patch. It should hopefully make the code easier to inspect by reducing the 'hops' to the actual implementation of buffer submission. Nikolay Borisov (3): xfs: Use __xfs_buf_submit everywhere xfs: Rename __xfs_buf_submit to xfs_buf_submit xfs: Opencode and remove DEFINE_SINGLE_BUF_MAP fs/xfs/xfs_buf.c | 16 +++++++++------- fs/xfs/xfs_buf.h | 16 ++++------------ fs/xfs/xfs_buf_item.c | 2 +- fs/xfs/xfs_log_recover.c | 2 +- fs/xfs/xfs_trans.h | 6 ++++-- 5 files changed, 19 insertions(+), 23 deletions(-)