diff mbox series

[v2,3/4] debian: Fix FTBFS

Message ID 20211114224339.20246-4-bage@debian.org (mailing list archive)
State Accepted, archived
Headers show
Series xfsprogs debian updates | expand

Commit Message

Bastian Germann Nov. 14, 2021, 10:43 p.m. UTC
From: Boian Bonev <bbonev@ipacct.com>

With newer autotools install-sh is regenerated by libtoolize.
Copy the package's version after autogen.

Link: https://bugs.debian.org/997656
Signed-off-by: Boian Bonev <bbonev@ipacct.com>
Signed-off-by: Bastian Germann <bage@debian.org>
---
 debian/rules | 1 +
 1 file changed, 1 insertion(+)

Comments

Darrick J. Wong Nov. 15, 2021, 4:54 p.m. UTC | #1
On Sun, Nov 14, 2021 at 11:43:38PM +0100, Bastian Germann wrote:
> From: Boian Bonev <bbonev@ipacct.com>
> 
> With newer autotools install-sh is regenerated by libtoolize.
> Copy the package's version after autogen.
> 
> Link: https://bugs.debian.org/997656
> Signed-off-by: Boian Bonev <bbonev@ipacct.com>
> Signed-off-by: Bastian Germann <bage@debian.org>

/me wonders what exactly about our install-sh is so unique -- I guess
it's DIST_ROOT (being picked up from DESTDIR?) and copying things to
different locations?

As a strict "just keep the keys out of the fire hose" measure this looks
ok to me though.
Reviewed-by: Darrick J. Wong <djwong@kernel.org>

--D

> ---
>  debian/rules | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/debian/rules b/debian/rules
> index e12814b3..615289b4 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -50,6 +50,7 @@ config: .census
>  	AUTOHEADER=/bin/true dh_autoreconf
>  	dh_update_autotools_config
>  	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
> +	cp -f include/install-sh .
>  	touch .census
>  
>  dibuild:
> -- 
> 2.33.1
> 
>
Boian Bonev Nov. 15, 2021, 6:05 p.m. UTC | #2
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Hi Darrick,

On Mon, 2021-11-15 at 08:54 -0800, Darrick J. Wong wrote:
> On Sun, Nov 14, 2021 at 11:43:38PM +0100, Bastian Germann wrote:
> > From: Boian Bonev <bbonev@ipacct.com>
> > 
> > With newer autotools install-sh is regenerated by libtoolize.
> > Copy the package's version after autogen.
> > 
> > Link: https://bugs.debian.org/997656
> > Signed-off-by: Boian Bonev <bbonev@ipacct.com>
> > Signed-off-by: Bastian Germann <bage@debian.org>
> 
> /me wonders what exactly about our install-sh is so unique -- I guess
> it's DIST_ROOT (being picked up from DESTDIR?) and copying things to
> different locations?

I also saw these are not supported in the libtoolize provided install-sh:

include/buildmacros:	../$(INSTALL) -m 755 -T so_dot_version $(LIBNAME).lai
$(PKG_ROOT_LIB_DIR); \
include/buildmacros:	../$(INSTALL) -T so_dot_current $(LIBNAME).lai
$(PKG_ROOT_LIB_DIR)
include/buildmacros:	../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai
$(PKG_LIB_DIR); \
include/buildmacros:	../$(INSTALL) -T so_base $(LIBNAME).lai
$(PKG_ROOT_LIB_DIR); \
include/buildmacros:	../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai
$(PKG_LIB_DIR)

Maybe there are more, I didn't dig too deep.


> As a strict "just keep the keys out of the fire hose" measure this looks
> ok to me though.
> Reviewed-by: Darrick J. Wong <djwong@kernel.org>

Thanks for your reviews :)

With best regards,
b.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEumC8IPN+WURNbSUAE2VyCRPS8i0FAmGSoYcACgkQE2VyCRPS
8i2pXxAAhhPUBZ7+vDcRx4VO98VeHe5jpadlW+RwJjrGIDZlb+RDGFD/DmJOZxQl
/pCxsFZL6MCqL6aJmG/mBfkD8Yzv17PKM7duV9/xf2Af60xyOfGDR9hP+/A5jsZL
kOOgyAfh+rUy0yguh4iD7c5ptegX4tb+xqYGNlUqcfVMu1SGWjkrsiNGvNKadPQq
ZQvTr7sfihXLy+GGqBBzhOD5WqXVThHntsj8krPfIb8U0m/FRTpTyzfoJr/QEBPX
TevaFH+cdS+ENHzLs3iVFBIVGKjelyYb52rMauvAqyaF2dZuSTr4V86jex5TsfJk
3RB0Yri299mqqnoe8gmcF84XNMCO4MjfV1aSHVke43UPpb8gTnaU/NC5XNxjZzY6
f6iTE7yRTIxu2QIrY1Odkqm4qQUM3cnZfybpzbr+QluM6GnH42md8XS30SJAQvqx
gGo4HifPu+iyVEOjoFYSdlEtw8mA0DNHSVGk7HtWN6mwhNAj90rfq5LJeZwWO08D
sK5aKzKDBibL/7Glv0LOyVMk92MrKT5KBQ1S4qZm7DjNthz5yPvmaXNaOe4UJ6nt
EVw8DOz0nWD9aqALZGmsIjQd8BH5iTIzsSCTiVWjrJDG9SrkXezs6TnGrW5yH1+J
ZIaMA8e3ElHsAf57I+ahPMTUAUXy0MPuA2Kq96R2U9mpUbASQJ0=
=TAAn
-----END PGP SIGNATURE-----
diff mbox series

Patch

diff --git a/debian/rules b/debian/rules
index e12814b3..615289b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,6 +50,7 @@  config: .census
 	AUTOHEADER=/bin/true dh_autoreconf
 	dh_update_autotools_config
 	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
+	cp -f include/install-sh .
 	touch .census
 
 dibuild: