diff mbox series

[1/2] debian: Generate .gitcensus instead of .census (Closes: #999743)

Message ID 20211119171241.102173-2-bage@debian.org (mailing list archive)
State Accepted, archived
Headers show
Series debian: Fix xfsprogs FT(C)BFS | expand

Commit Message

Bastian Germann Nov. 19, 2021, 5:12 p.m. UTC
Fix the Debian build outside a git tree (e.g., Debian archive builds) by
creating an empty .gitcensus instead of .census file on config.

Signed-off-by: Bastian Germann <bage@debian.org>
---
 debian/rules | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Bastian Germann Nov. 23, 2021, 8:01 p.m. UTC | #1
@Darrick: Thanks for caring about the 2nd patch. Is anyone up to review this patch?

Am 19.11.21 um 18:12 schrieb Bastian Germann:
> Fix the Debian build outside a git tree (e.g., Debian archive builds) by
> creating an empty .gitcensus instead of .census file on config.
> 
> Signed-off-by: Bastian Germann <bage@debian.org>
> ---
>   debian/rules | 8 ++++----
>   1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/debian/rules b/debian/rules
> index 615289b4..6d5b82a8 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -43,15 +43,15 @@ built: dibuild config
>   	$(MAKE) $(PMAKEFLAGS) default
>   	touch built
>   
> -config: .census
> -.census:
> +config: .gitcensus
> +.gitcensus:
>   	@echo "== dpkg-buildpackage: configure" 1>&2
>   	$(checkdir)
>   	AUTOHEADER=/bin/true dh_autoreconf
>   	dh_update_autotools_config
>   	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
>   	cp -f include/install-sh .
> -	touch .census
> +	touch .gitcensus
>   
>   dibuild:
>   	$(checkdir)
> @@ -72,7 +72,7 @@ dibuild:
>   clean:
>   	@echo "== dpkg-buildpackage: clean" 1>&2
>   	$(checkdir)
> -	-rm -f built .census mkfs/mkfs.xfs-$(bootpkg)
> +	-rm -f built .gitcensus mkfs/mkfs.xfs-$(bootpkg)
>   	$(MAKE) distclean
>   	-rm -rf $(dirme) $(dirdev) $(dirdi)
>   	-rm -f debian/*substvars debian/files* debian/*.debhelper
>
Darrick J. Wong Nov. 23, 2021, 8:08 p.m. UTC | #2
On Fri, Nov 19, 2021 at 06:12:40PM +0100, Bastian Germann wrote:
> Fix the Debian build outside a git tree (e.g., Debian archive builds) by
> creating an empty .gitcensus instead of .census file on config.
> 
> Signed-off-by: Bastian Germann <bage@debian.org>

Heh.  I used to have a patch that more or less did this, until I
switched to building development packages only from git.  Sorry I forgot
to come back to this one.

Reviewed-by: Darrick J. Wong <djwong@kernel.org>

--D

> ---
>  debian/rules | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/debian/rules b/debian/rules
> index 615289b4..6d5b82a8 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -43,15 +43,15 @@ built: dibuild config
>  	$(MAKE) $(PMAKEFLAGS) default
>  	touch built
>  
> -config: .census
> -.census:
> +config: .gitcensus
> +.gitcensus:
>  	@echo "== dpkg-buildpackage: configure" 1>&2
>  	$(checkdir)
>  	AUTOHEADER=/bin/true dh_autoreconf
>  	dh_update_autotools_config
>  	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
>  	cp -f include/install-sh .
> -	touch .census
> +	touch .gitcensus
>  
>  dibuild:
>  	$(checkdir)
> @@ -72,7 +72,7 @@ dibuild:
>  clean:
>  	@echo "== dpkg-buildpackage: clean" 1>&2
>  	$(checkdir)
> -	-rm -f built .census mkfs/mkfs.xfs-$(bootpkg)
> +	-rm -f built .gitcensus mkfs/mkfs.xfs-$(bootpkg)
>  	$(MAKE) distclean
>  	-rm -rf $(dirme) $(dirdev) $(dirdi)
>  	-rm -f debian/*substvars debian/files* debian/*.debhelper
> -- 
> 2.30.2
> 
>
diff mbox series

Patch

diff --git a/debian/rules b/debian/rules
index 615289b4..6d5b82a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,15 +43,15 @@  built: dibuild config
 	$(MAKE) $(PMAKEFLAGS) default
 	touch built
 
-config: .census
-.census:
+config: .gitcensus
+.gitcensus:
 	@echo "== dpkg-buildpackage: configure" 1>&2
 	$(checkdir)
 	AUTOHEADER=/bin/true dh_autoreconf
 	dh_update_autotools_config
 	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
 	cp -f include/install-sh .
-	touch .census
+	touch .gitcensus
 
 dibuild:
 	$(checkdir)
@@ -72,7 +72,7 @@  dibuild:
 clean:
 	@echo "== dpkg-buildpackage: clean" 1>&2
 	$(checkdir)
-	-rm -f built .census mkfs/mkfs.xfs-$(bootpkg)
+	-rm -f built .gitcensus mkfs/mkfs.xfs-$(bootpkg)
 	$(MAKE) distclean
 	-rm -rf $(dirme) $(dirdev) $(dirdi)
 	-rm -f debian/*substvars debian/files* debian/*.debhelper