diff mbox series

[v2,1/1] debian: Generate .gitcensus instead of .census (Closes: #999743)

Message ID 20211207122110.1448-2-bage@debian.org (mailing list archive)
State Accepted, archived
Headers show
Series debian: Resend .gitcensus change | expand

Commit Message

Bastian Germann Dec. 7, 2021, 12:21 p.m. UTC
Fix the Debian build outside a git tree (e.g., Debian archive builds) by
creating an empty .gitcensus instead of .census file on config.

Signed-off-by: Bastian Germann <bage@debian.org>
Reviewed-by: Darrick J. Wong <djwong@kernel.org>
---
 debian/rules | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Bastian Germann Feb. 10, 2022, 12:35 p.m. UTC | #1
Hey,

I want to remind you of this patch before releasing xfsprogs 5.15.0.

Thanks,
Bastian

Am 07.12.21 um 13:21 schrieb Bastian Germann:
> Fix the Debian build outside a git tree (e.g., Debian archive builds) by
> creating an empty .gitcensus instead of .census file on config.
> 
> Signed-off-by: Bastian Germann <bage@debian.org>
> Reviewed-by: Darrick J. Wong <djwong@kernel.org>
> ---
>   debian/rules | 8 ++++----
>   1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/debian/rules b/debian/rules
> index 615289b4..6d5b82a8 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -43,15 +43,15 @@ built: dibuild config
>   	$(MAKE) $(PMAKEFLAGS) default
>   	touch built
>   
> -config: .census
> -.census:
> +config: .gitcensus
> +.gitcensus:
>   	@echo "== dpkg-buildpackage: configure" 1>&2
>   	$(checkdir)
>   	AUTOHEADER=/bin/true dh_autoreconf
>   	dh_update_autotools_config
>   	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
>   	cp -f include/install-sh .
> -	touch .census
> +	touch .gitcensus
>   
>   dibuild:
>   	$(checkdir)
> @@ -72,7 +72,7 @@ dibuild:
>   clean:
>   	@echo "== dpkg-buildpackage: clean" 1>&2
>   	$(checkdir)
> -	-rm -f built .census mkfs/mkfs.xfs-$(bootpkg)
> +	-rm -f built .gitcensus mkfs/mkfs.xfs-$(bootpkg)
>   	$(MAKE) distclean
>   	-rm -rf $(dirme) $(dirdev) $(dirdi)
>   	-rm -f debian/*substvars debian/files* debian/*.debhelper
Bastian Germann April 17, 2022, 10 a.m. UTC | #2
Hi!

Am 07.12.21 um 13:21 schrieb Bastian Germann:
> Fix the Debian build outside a git tree (e.g., Debian archive builds) by
> creating an empty .gitcensus instead of .census file on config.
> 
> Signed-off-by: Bastian Germann <bage@debian.org>
> Reviewed-by: Darrick J. Wong <djwong@kernel.org>

2nd friendly ping on this.
For the last few Debian releases, I applied this.

> ---
>   debian/rules | 8 ++++----
>   1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/debian/rules b/debian/rules
> index 615289b4..6d5b82a8 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -43,15 +43,15 @@ built: dibuild config
>   	$(MAKE) $(PMAKEFLAGS) default
>   	touch built
>   
> -config: .census
> -.census:
> +config: .gitcensus
> +.gitcensus:
>   	@echo "== dpkg-buildpackage: configure" 1>&2
>   	$(checkdir)
>   	AUTOHEADER=/bin/true dh_autoreconf
>   	dh_update_autotools_config
>   	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
>   	cp -f include/install-sh .
> -	touch .census
> +	touch .gitcensus
>   
>   dibuild:
>   	$(checkdir)
> @@ -72,7 +72,7 @@ dibuild:
>   clean:
>   	@echo "== dpkg-buildpackage: clean" 1>&2
>   	$(checkdir)
> -	-rm -f built .census mkfs/mkfs.xfs-$(bootpkg)
> +	-rm -f built .gitcensus mkfs/mkfs.xfs-$(bootpkg)
>   	$(MAKE) distclean
>   	-rm -rf $(dirme) $(dirdev) $(dirdi)
>   	-rm -f debian/*substvars debian/files* debian/*.debhelper
Eric Sandeen May 2, 2022, 11:25 p.m. UTC | #3
On 4/17/22 5:00 AM, Bastian Germann wrote:
> Hi!
> 
> Am 07.12.21 um 13:21 schrieb Bastian Germann:
>> Fix the Debian build outside a git tree (e.g., Debian archive builds) by
>> creating an empty .gitcensus instead of .census file on config.
>>
>> Signed-off-by: Bastian Germann <bage@debian.org>
>> Reviewed-by: Darrick J. Wong <djwong@kernel.org>
> 
> 2nd friendly ping on this.
> For the last few Debian releases, I applied this.

Very sorry for the delay. Does this need magic in debian/changelog
to auto-close the bug?

I have the change itself staged for 5.16.0 now.

-Eric
Bastian Germann May 3, 2022, 7:51 a.m. UTC | #4
Am 03.05.22 um 01:25 schrieb Eric Sandeen:
> On 4/17/22 5:00 AM, Bastian Germann wrote:
>> Hi!
>>
>> Am 07.12.21 um 13:21 schrieb Bastian Germann:
>>> Fix the Debian build outside a git tree (e.g., Debian archive builds) by
>>> creating an empty .gitcensus instead of .census file on config.
>>>
>>> Signed-off-by: Bastian Germann <bage@debian.org>
>>> Reviewed-by: Darrick J. Wong <djwong@kernel.org>
>>
>> 2nd friendly ping on this.
>> For the last few Debian releases, I applied this.
> 
> Very sorry for the delay. Does this need magic in debian/changelog
> to auto-close the bug?

When the "Closes: #999743" is contained in the changelog, it triggers an auto-close.
But I can also close it manually.

Thanks!
diff mbox series

Patch

diff --git a/debian/rules b/debian/rules
index 615289b4..6d5b82a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,15 +43,15 @@  built: dibuild config
 	$(MAKE) $(PMAKEFLAGS) default
 	touch built
 
-config: .census
-.census:
+config: .gitcensus
+.gitcensus:
 	@echo "== dpkg-buildpackage: configure" 1>&2
 	$(checkdir)
 	AUTOHEADER=/bin/true dh_autoreconf
 	dh_update_autotools_config
 	$(options) $(MAKE) $(PMAKEFLAGS) include/platform_defs.h
 	cp -f include/install-sh .
-	touch .census
+	touch .gitcensus
 
 dibuild:
 	$(checkdir)
@@ -72,7 +72,7 @@  dibuild:
 clean:
 	@echo "== dpkg-buildpackage: clean" 1>&2
 	$(checkdir)
-	-rm -f built .census mkfs/mkfs.xfs-$(bootpkg)
+	-rm -f built .gitcensus mkfs/mkfs.xfs-$(bootpkg)
 	$(MAKE) distclean
 	-rm -rf $(dirme) $(dirdev) $(dirdi)
 	-rm -f debian/*substvars debian/files* debian/*.debhelper