diff mbox series

debian: Increase build verbosity, add terse support

Message ID 20240212230813.10122-1-bage@debian.org (mailing list archive)
State New
Headers show
Series debian: Increase build verbosity, add terse support | expand

Commit Message

Bastian Germann Feb. 12, 2024, 11:07 p.m. UTC
Section 4.9 of the Debian Policy reads:

"The package build should be as verbose as reasonably possible,
except where the terse tag is included in DEB_BUILD_OPTIONS".

Implement such behavior for xfsprogs by passing V=1 to make by default.

Link: https://www.debian.org/doc/debian-policy/ch-source.html#main-building-script-debian-rules
Link: https://bugs.debian.org/1063774
Reported-by: Emanuele Rocca <ema@debian.org>
Signed-off-by: Bastian Germann <bage@debian.org>
---
 debian/rules | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Darrick J. Wong Feb. 12, 2024, 11:29 p.m. UTC | #1
On Tue, Feb 13, 2024 at 12:07:55AM +0100, Bastian Germann wrote:
> Section 4.9 of the Debian Policy reads:
> 
> "The package build should be as verbose as reasonably possible,
> except where the terse tag is included in DEB_BUILD_OPTIONS".
> 
> Implement such behavior for xfsprogs by passing V=1 to make by default.
> 
> Link: https://www.debian.org/doc/debian-policy/ch-source.html#main-building-script-debian-rules
> Link: https://bugs.debian.org/1063774
> Reported-by: Emanuele Rocca <ema@debian.org>
> Signed-off-by: Bastian Germann <bage@debian.org>

Sounds good to me!
Reviewed-by: Darrick J. Wong <djwong@kernel.org>

--D

> ---
>  debian/rules | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/debian/rules b/debian/rules
> index 57baad62..7e4b83e2 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -7,6 +7,10 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
>      PMAKEFLAGS += -j$(NUMJOBS)
>  endif
>  
> +ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
> +    PMAKEFLAGS += V=1
> +endif
> +
>  package = xfsprogs
>  develop = xfslibs-dev
>  bootpkg = xfsprogs-udeb
> -- 
> 2.43.0
> 
>
diff mbox series

Patch

diff --git a/debian/rules b/debian/rules
index 57baad62..7e4b83e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,10 @@  ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
     PMAKEFLAGS += -j$(NUMJOBS)
 endif
 
+ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
+    PMAKEFLAGS += V=1
+endif
+
 package = xfsprogs
 develop = xfslibs-dev
 bootpkg = xfsprogs-udeb