diff mbox series

Bug#794158: marked as done (xfsprogs FTCBFS: fails to pass --host to configure)

Message ID handler.794158.D794158.163700072115895.ackdone@bugs.debian.org (mailing list archive)
State New, archived
Headers show
Series Bug#794158: marked as done (xfsprogs FTCBFS: fails to pass --host to configure) | expand

Commit Message

Debian Bug Tracking System Nov. 15, 2021, 6:27 p.m. UTC
Your message dated Mon, 15 Nov 2021 18:25:19 +0000
with message-id <E1mmgfP-0004r1-ND@fasolo.debian.org>
and subject line Bug#794158: fixed in xfsprogs 5.14.0-rc1-1
has caused the Debian Bug report #794158,
regarding xfsprogs FTCBFS: fails to pass --host to configure
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)
diff mbox series

Patch

diff -Nru xfsprogs-3.2.3/debian/changelog xfsprogs-3.2.3+nmu1/debian/changelog
--- xfsprogs-3.2.3/debian/changelog	2015-06-01 03:35:09.000000000 +0200
+++ xfsprogs-3.2.3+nmu1/debian/changelog	2015-07-30 23:32:50.000000000 +0200
@@ -1,3 +1,12 @@ 
+xfsprogs (3.2.3+nmu1) UNRELEASED; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix FTCBFS. (Closes: #-1)
+    + Pass --build and --host to configure.
+    + Compile gen_crc32table and crc32selftest using CC_FOR_BUILD.
+
+ -- Helmut Grohne <helmut@subdivi.de>  Thu, 30 Jul 2015 23:00:34 +0200
+
 xfsprogs (3.2.3) unstable; urgency=low
 
   * New upstream release
diff -Nru xfsprogs-3.2.3/debian/rules xfsprogs-3.2.3+nmu1/debian/rules
--- xfsprogs-3.2.3/debian/rules	2014-11-10 01:51:18.000000000 +0100
+++ xfsprogs-3.2.3+nmu1/debian/rules	2015-07-30 23:23:08.000000000 +0200
@@ -6,6 +6,10 @@ 
 develop = xfslibs-dev
 bootpkg = xfsprogs-udeb
 
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export CC_FOR_BUILD ?= cc
+
 version = $(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2)
 target ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 udebpkg = $(bootpkg)_$(version)_$(target).udeb
@@ -18,11 +22,13 @@ 
 pkgdi  = DIST_ROOT=`pwd`/$(dirdi); export DIST_ROOT;
 stdenv = @GZIP=-q; export GZIP;
 
+configure_options = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
+
 options = export DEBUG=-DNDEBUG DISTRIBUTION=debian \
 	  INSTALL_USER=root INSTALL_GROUP=root \
-	  LOCAL_CONFIGURE_OPTIONS="--enable-readline=yes --enable-blkid=yes" ;
+	  LOCAL_CONFIGURE_OPTIONS="$(configure_options) --enable-readline=yes --enable-blkid=yes" ;
 diopts  = $(options) \
-	  export OPTIMIZER=-Os LOCAL_CONFIGURE_OPTIONS="--enable-gettext=no" ;
+	  export OPTIMIZER=-Os LOCAL_CONFIGURE_OPTIONS="$(configure_options) --enable-gettext=no" ;
 checkdir = test -f debian/rules
 
 build: built
diff -Nru xfsprogs-3.2.3/libxfs/Makefile xfsprogs-3.2.3+nmu1/libxfs/Makefile
--- xfsprogs-3.2.3/libxfs/Makefile	2014-05-02 02:09:15.000000000 +0200
+++ xfsprogs-3.2.3+nmu1/libxfs/Makefile	2015-07-30 23:32:23.000000000 +0200
@@ -67,7 +67,7 @@ 
 
 crc32table.h: gen_crc32table.c
 	@echo "    [CC]     gen_crc32table"
-	$(Q) $(CC) $(CFLAGS) -o gen_crc32table $<
+	$(Q) $(CC_FOR_BUILD) $(CFLAGS) -o gen_crc32table $<
 	@echo "    [GENERATE] $@"
 	$(Q) ./gen_crc32table > crc32table.h
 
@@ -78,7 +78,7 @@ 
 # disk.
 crc32selftest: gen_crc32table.c crc32table.h crc32.c
 	@echo "    [TEST]    CRC32"
-	$(Q) $(CC) $(CFLAGS) -D CRC32_SELFTEST=1 crc32.c -o $@
+	$(Q) $(CC_FOR_BUILD) $(CFLAGS) -D CRC32_SELFTEST=1 crc32.c -o $@
 	$(Q) ./$@
 
 include $(BUILDRULES)