diff mbox

[3/4] ALSA: mixart: Fix kerneldoc comments

Message ID 1415637155-20918-4-git-send-email-tiwai@suse.de (mailing list archive)
State Accepted
Commit 3f60c87d129acbb232afbc7269c726d009a01869
Headers show

Commit Message

Takashi Iwai Nov. 10, 2014, 4:32 p.m. UTC
Signed-off-by: Takashi Iwai <tiwai@suse.de>
---
 sound/pci/mixart/mixart_hwdep.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Peter Meerwald-Stadler Nov. 10, 2014, 5 p.m. UTC | #1
> Signed-off-by: Takashi Iwai <tiwai@suse.de>
> ---
>  sound/pci/mixart/mixart_hwdep.c | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/sound/pci/mixart/mixart_hwdep.c b/sound/pci/mixart/mixart_hwdep.c
> index 581e1e74863c..9996a4dead0f 100644
> --- a/sound/pci/mixart/mixart_hwdep.c
> +++ b/sound/pci/mixart/mixart_hwdep.c
> @@ -37,10 +37,11 @@
>  /**
>   * wait for a value on a peudo register, exit with a timeout
>   *
> - * @param mgr pointer to miXart manager structure
> - * @param offset unsigned pseudo_register base + offset of value
> - * @param value value
> - * @param timeout timeout in centisenconds
> + * @mgr: pointer to miXart manager structure
> + * @offset: unsigned pseudo_register base + offset of value
> + * @is_egal: wait for the equal value
> + * @value: value
> + * @timeout: timeout in centisenconds
>   */
>  static int mixart_wait_nice_for_register_value(struct mixart_mgr *mgr,
>  					       u32 offset, int is_egal,

centiseconds

looks like is_egal should be named is_equal?
Takashi Iwai Nov. 10, 2014, 5:04 p.m. UTC | #2
At Mon, 10 Nov 2014 18:00:28 +0100 (CET),
Peter Meerwald wrote:
> 
> 
> > Signed-off-by: Takashi Iwai <tiwai@suse.de>
> > ---
> >  sound/pci/mixart/mixart_hwdep.c | 9 +++++----
> >  1 file changed, 5 insertions(+), 4 deletions(-)
> > 
> > diff --git a/sound/pci/mixart/mixart_hwdep.c b/sound/pci/mixart/mixart_hwdep.c
> > index 581e1e74863c..9996a4dead0f 100644
> > --- a/sound/pci/mixart/mixart_hwdep.c
> > +++ b/sound/pci/mixart/mixart_hwdep.c
> > @@ -37,10 +37,11 @@
> >  /**
> >   * wait for a value on a peudo register, exit with a timeout
> >   *
> > - * @param mgr pointer to miXart manager structure
> > - * @param offset unsigned pseudo_register base + offset of value
> > - * @param value value
> > - * @param timeout timeout in centisenconds
> > + * @mgr: pointer to miXart manager structure
> > + * @offset: unsigned pseudo_register base + offset of value
> > + * @is_egal: wait for the equal value
> > + * @value: value
> > + * @timeout: timeout in centisenconds
> >   */
> >  static int mixart_wait_nice_for_register_value(struct mixart_mgr *mgr,
> >  					       u32 offset, int is_egal,
> 
> centiseconds
> 
> looks like is_egal should be named is_equal?

Yes, but the important bit of this patch series is touching only
comments.  This guarantees not to break anything.

(And honestly speaking, I don't care.  It can be even a good chance
 for readers to learn French or German :)


Takashi
diff mbox

Patch

diff --git a/sound/pci/mixart/mixart_hwdep.c b/sound/pci/mixart/mixart_hwdep.c
index 581e1e74863c..9996a4dead0f 100644
--- a/sound/pci/mixart/mixart_hwdep.c
+++ b/sound/pci/mixart/mixart_hwdep.c
@@ -37,10 +37,11 @@ 
 /**
  * wait for a value on a peudo register, exit with a timeout
  *
- * @param mgr pointer to miXart manager structure
- * @param offset unsigned pseudo_register base + offset of value
- * @param value value
- * @param timeout timeout in centisenconds
+ * @mgr: pointer to miXart manager structure
+ * @offset: unsigned pseudo_register base + offset of value
+ * @is_egal: wait for the equal value
+ * @value: value
+ * @timeout: timeout in centisenconds
  */
 static int mixart_wait_nice_for_register_value(struct mixart_mgr *mgr,
 					       u32 offset, int is_egal,