diff mbox

[17/30] staging: wilc1000: fix line over 80 chars in wilc_wfi_cfg_tx_vendor_spec()

Message ID 1525682614-3824-18-git-send-email-ajay.kathat@microchip.com (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Ajay Singh May 7, 2018, 8:43 a.m. UTC
Fix line over 80 characters issues reported by checkpatch.pl script in
wilc_wfi_cfg_tx_vendor_spec() by using temporary variable. Simplified
'if else' condition with 'if'.

Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
---
 drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Comments

Claudiu Beznea May 9, 2018, 1:42 p.m. UTC | #1
On 07.05.2018 11:43, Ajay Singh wrote:
> Fix line over 80 characters issues reported by checkpatch.pl script in
> wilc_wfi_cfg_tx_vendor_spec() by using temporary variable. Simplified
> 'if else' condition with 'if'.
> 
> Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
> ---
>  drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
> index 4f35178..8dea414 100644
> --- a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
> +++ b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
> @@ -1573,14 +1573,14 @@ static void wilc_wfi_cfg_tx_vendor_spec(struct p2p_mgmt_data *mgmt_tx,
>  	for (i = P2P_PUB_ACTION_SUBTYPE + 2; i < len; i++) {
>  		if (buf[i] == P2PELEM_ATTR_ID &&
>  		    !memcmp(p2p_oui, &buf[i + 2], 4)) {
> +			bool oper_ch = false;
> +			u8 *tx_buff = &mgmt_tx->buff[i + 6];
> +
>  			if (subtype == P2P_INV_REQ || subtype == P2P_INV_RSP)
> -				wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
> -							     len - (i + 6),
> -							     true, iftype);
> -			else
> -				wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
> -							     len - (i + 6),
> -							     false, iftype);
> +				oper_ch = true;
> +
> +			wilc_wfi_cfg_parse_tx_action(tx_buff, len - (i + 6),
> +						     oper_ch, iftype);

What about:
			wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
						     len - (i + 6),
						     (subtype == P2P_INV_REQ ||
						      subtype == P2P_INV_RSP),
						     iftype);


instead all the temporary variables?

>  
>  			break;
>  		}
>
Ajay Singh May 9, 2018, 6:44 p.m. UTC | #2
On Wed, 9 May 2018 16:42:45 +0300
Claudiu Beznea <Claudiu.Beznea@microchip.com> wrote:

> On 07.05.2018 11:43, Ajay Singh wrote:
> > Fix line over 80 characters issues reported by checkpatch.pl script
> > in wilc_wfi_cfg_tx_vendor_spec() by using temporary variable.
> > Simplified 'if else' condition with 'if'.
> > 
> > Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
> > ---
> >  drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14
> > +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
> > b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c index
> > 4f35178..8dea414 100644 ---
> > a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c +++
> > b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c @@ -1573,14
> > +1573,14 @@ static void wilc_wfi_cfg_tx_vendor_spec(struct
> > p2p_mgmt_data *mgmt_tx, for (i = P2P_PUB_ACTION_SUBTYPE + 2; i <
> > len; i++) { if (buf[i] == P2PELEM_ATTR_ID && !memcmp(p2p_oui,
> > &buf[i + 2], 4)) {
> > +			bool oper_ch = false;
> > +			u8 *tx_buff = &mgmt_tx->buff[i + 6];
> > +
> >  			if (subtype == P2P_INV_REQ || subtype ==
> > P2P_INV_RSP)
> > -
> > wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
> > -							     len -
> > (i + 6),
> > -							     true,
> > iftype);
> > -			else
> > -
> > wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
> > -							     len -
> > (i + 6),
> > -
> > false, iftype);
> > +				oper_ch = true;
> > +
> > +			wilc_wfi_cfg_parse_tx_action(tx_buff, len
> > - (i + 6),
> > +						     oper_ch,
> > iftype);  
> 
> What about:
> 			wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i
> + 6], len - (i + 6),
> 						     (subtype ==
> P2P_INV_REQ || subtype == P2P_INV_RSP),
> 						     iftype);
> 
> 
> instead all the temporary variables?

In my opinion adding one bool variable making the code more readable
then using adding extra logic with parameters for function call.

> 
> >  
> >  			break;
> >  		}
> >
diff mbox

Patch

diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
index 4f35178..8dea414 100644
--- a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
+++ b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
@@ -1573,14 +1573,14 @@  static void wilc_wfi_cfg_tx_vendor_spec(struct p2p_mgmt_data *mgmt_tx,
 	for (i = P2P_PUB_ACTION_SUBTYPE + 2; i < len; i++) {
 		if (buf[i] == P2PELEM_ATTR_ID &&
 		    !memcmp(p2p_oui, &buf[i + 2], 4)) {
+			bool oper_ch = false;
+			u8 *tx_buff = &mgmt_tx->buff[i + 6];
+
 			if (subtype == P2P_INV_REQ || subtype == P2P_INV_RSP)
-				wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
-							     len - (i + 6),
-							     true, iftype);
-			else
-				wilc_wfi_cfg_parse_tx_action(&mgmt_tx->buff[i + 6],
-							     len - (i + 6),
-							     false, iftype);
+				oper_ch = true;
+
+			wilc_wfi_cfg_parse_tx_action(tx_buff, len - (i + 6),
+						     oper_ch, iftype);
 
 			break;
 		}