diff mbox series

AMD/IOMMU: don't open-code for_each_amd_iommu()

Message ID 5CA6FD300200007800224C43@prv1-mh.provo.novell.com (mailing list archive)
State New, archived
Headers show
Series AMD/IOMMU: don't open-code for_each_amd_iommu() | expand

Commit Message

Jan Beulich April 5, 2019, 7:01 a.m. UTC
Signed-off-by: Jan Beulich <jbeulich@suse.com>

Comments

Jan Beulich May 2, 2019, 2:51 p.m. UTC | #1
>>> On 05.04.19 at 09:01, <JBeulich@suse.com> wrote:
> Signed-off-by: Jan Beulich <jbeulich@suse.com>
> 
> --- a/xen/drivers/passthrough/amd/iommu_intr.c
> +++ b/xen/drivers/passthrough/amd/iommu_intr.c
> @@ -503,7 +503,7 @@ static struct amd_iommu *_find_iommu_for
>  {
>      struct amd_iommu *iommu;
>  
> -    list_for_each_entry ( iommu, &amd_iommu_head, list )
> +    for_each_amd_iommu ( iommu )
>          if ( iommu->seg == seg && iommu->bdf == bdf )
>              return NULL;
>
Jan Beulich May 14, 2019, 7:07 a.m. UTC | #2
>>> On 02.05.19 at 16:51, <JBeulich@suse.com> wrote:
>>>> On 05.04.19 at 09:01, <JBeulich@suse.com> wrote:
>> Signed-off-by: Jan Beulich <jbeulich@suse.com>
>> 
>> --- a/xen/drivers/passthrough/amd/iommu_intr.c
>> +++ b/xen/drivers/passthrough/amd/iommu_intr.c
>> @@ -503,7 +503,7 @@ static struct amd_iommu *_find_iommu_for
>>  {
>>      struct amd_iommu *iommu;
>>  
>> -    list_for_each_entry ( iommu, &amd_iommu_head, list )
>> +    for_each_amd_iommu ( iommu )
>>          if ( iommu->seg == seg && iommu->bdf == bdf )
>>              return NULL;
>>  

I'm sorry for being blunt, but a trivial change like this shouldn't
require well over a month and multiple pings to finally get an ack.
I'll give this a day or two more, and then commit without ack
unless I hear objections.

Jan
Andrew Cooper May 14, 2019, 10:25 a.m. UTC | #3
On 14/05/2019 08:07, Jan Beulich wrote:
>>>> On 02.05.19 at 16:51, <JBeulich@suse.com> wrote:
>>>>> On 05.04.19 at 09:01, <JBeulich@suse.com> wrote:
>>> Signed-off-by: Jan Beulich <jbeulich@suse.com>
>>>
>>> --- a/xen/drivers/passthrough/amd/iommu_intr.c
>>> +++ b/xen/drivers/passthrough/amd/iommu_intr.c
>>> @@ -503,7 +503,7 @@ static struct amd_iommu *_find_iommu_for
>>>  {
>>>      struct amd_iommu *iommu;
>>>  
>>> -    list_for_each_entry ( iommu, &amd_iommu_head, list )
>>> +    for_each_amd_iommu ( iommu )
>>>          if ( iommu->seg == seg && iommu->bdf == bdf )
>>>              return NULL;
>>>  
> I'm sorry for being blunt, but a trivial change like this shouldn't
> require well over a month and multiple pings to finally get an ack.
> I'll give this a day or two more, and then commit without ack
> unless I hear objections.

FWIW, Ack.  This is too trivial to be worth arguing over.

~Andrew
Roger Pau Monné May 14, 2019, 10:26 a.m. UTC | #4
On Fri, Apr 05, 2019 at 01:01:04AM -0600, Jan Beulich wrote:
> Signed-off-by: Jan Beulich <jbeulich@suse.com>

Not sure if it's of much help, but:

Reviewed-by: Roger Pau Monné <roger.pau@citrix.com>

The change it's trivial and obviously correct to me.

Roger.
diff mbox series

Patch

--- a/xen/drivers/passthrough/amd/iommu_intr.c
+++ b/xen/drivers/passthrough/amd/iommu_intr.c
@@ -503,7 +503,7 @@  static struct amd_iommu *_find_iommu_for
 {
     struct amd_iommu *iommu;
 
-    list_for_each_entry ( iommu, &amd_iommu_head, list )
+    for_each_amd_iommu ( iommu )
         if ( iommu->seg == seg && iommu->bdf == bdf )
             return NULL;