Message ID | 20190519201627.17188-1-kamalheib1@gmail.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | [for-next] RDMA/core: Rename ib_device_check_mandatory | expand |
On Sun, May 19, 2019 at 11:16:27PM +0300, Kamal Heib wrote: > The return value from ib_device_check_mandatory() is always 0 - change > it to be void and rename the function to emphasize the use of it, which > is setting the kverbs_provider flag. Actually check_mandatory is the real usage of that function and kverbs_provider is extra granularity. So yes to "void", no to function name change. Thanks
diff --git a/drivers/infiniband/core/device.c b/drivers/infiniband/core/device.c index 78dc07c6ac4b..7702d03c1967 100644 --- a/drivers/infiniband/core/device.c +++ b/drivers/infiniband/core/device.c @@ -270,7 +270,7 @@ struct ib_port_data_rcu { struct ib_port_data pdata[]; }; -static int ib_device_check_mandatory(struct ib_device *device) +static void ib_set_kverbs_provider(struct ib_device *device) { #define IB_MANDATORY_FUNC(x) { offsetof(struct ib_device_ops, x), #x } static const struct { @@ -305,8 +305,6 @@ static int ib_device_check_mandatory(struct ib_device *device) break; } } - - return 0; } /* @@ -1175,10 +1173,7 @@ static int setup_device(struct ib_device *device) int ret; setup_dma_device(device); - - ret = ib_device_check_mandatory(device); - if (ret) - return ret; + ib_set_kverbs_provider(device); ret = setup_port_data(device); if (ret) {
The return value from ib_device_check_mandatory() is always 0 - change it to be void and rename the function to emphasize the use of it, which is setting the kverbs_provider flag. Signed-off-by: Kamal Heib <kamalheib1@gmail.com> --- drivers/infiniband/core/device.c | 9 ++------- 1 file changed, 2 insertions(+), 7 deletions(-)