diff mbox series

rtc: zynqmp: One function call less in xlnx_rtc_alarm_irq_enable()

Message ID 6f1db217-cb0a-9f6c-0e2e-5d932103f6ef@web.de (mailing list archive)
State New, archived
Headers show
Series rtc: zynqmp: One function call less in xlnx_rtc_alarm_irq_enable() | expand

Commit Message

Markus Elfring July 5, 2019, 8:45 p.m. UTC
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Fri, 5 Jul 2019 22:37:58 +0200

Avoid an extra function call by using a ternary operator instead of
a conditional statement for a setting selection.

This issue was detected by using the Coccinelle software.

Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
 drivers/rtc/rtc-zynqmp.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

--
2.22.0

Comments

Alexandre Belloni July 5, 2019, 10:36 p.m. UTC | #1
On 05/07/2019 22:45:39+0200, Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Fri, 5 Jul 2019 22:37:58 +0200
> 
> Avoid an extra function call by using a ternary operator instead of
> a conditional statement for a setting selection.
> 

Please elaborate on why this is a good thing.

> This issue was detected by using the Coccinelle software.
> 

Unless you use an upstream coccinelle script or you share the one you
are using, this is not a useful information.

> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
>  drivers/rtc/rtc-zynqmp.c | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/rtc/rtc-zynqmp.c b/drivers/rtc/rtc-zynqmp.c
> index 00639594de0c..4631019a54e2 100644
> --- a/drivers/rtc/rtc-zynqmp.c
> +++ b/drivers/rtc/rtc-zynqmp.c
> @@ -124,11 +124,8 @@ static int xlnx_rtc_alarm_irq_enable(struct device *dev, u32 enabled)
>  {
>  	struct xlnx_rtc_dev *xrtcdev = dev_get_drvdata(dev);
> 
> -	if (enabled)
> -		writel(RTC_INT_ALRM, xrtcdev->reg_base + RTC_INT_EN);
> -	else
> -		writel(RTC_INT_ALRM, xrtcdev->reg_base + RTC_INT_DIS);
> -
> +	writel(RTC_INT_ALRM,
> +	       xrtcdev->reg_base + (enabled ? RTC_INT_EN : RTC_INT_DIS));

This makes the code less readable.

>  	return 0;
>  }
> 
> --
> 2.22.0
>
Markus Elfring July 6, 2019, 5:07 a.m. UTC | #2
> Unless you use an upstream coccinelle script or you share the one you
> are using, this is not a useful information.

How do you think about to extend a software development discussion
on a topic like “Pretty-printing of code for ternary operators?”?
https://systeme.lip6.fr/pipermail/cocci/2019-July/006079.html
https://lore.kernel.org/cocci/3d2a9d9a-790c-a0f0-f980-b560504babb9@web.de/

Regards,
Markus
diff mbox series

Patch

diff --git a/drivers/rtc/rtc-zynqmp.c b/drivers/rtc/rtc-zynqmp.c
index 00639594de0c..4631019a54e2 100644
--- a/drivers/rtc/rtc-zynqmp.c
+++ b/drivers/rtc/rtc-zynqmp.c
@@ -124,11 +124,8 @@  static int xlnx_rtc_alarm_irq_enable(struct device *dev, u32 enabled)
 {
 	struct xlnx_rtc_dev *xrtcdev = dev_get_drvdata(dev);

-	if (enabled)
-		writel(RTC_INT_ALRM, xrtcdev->reg_base + RTC_INT_EN);
-	else
-		writel(RTC_INT_ALRM, xrtcdev->reg_base + RTC_INT_DIS);
-
+	writel(RTC_INT_ALRM,
+	       xrtcdev->reg_base + (enabled ? RTC_INT_EN : RTC_INT_DIS));
 	return 0;
 }