Message ID | 20190821040727.19650-1-jhubbard@nvidia.com (mailing list archive) |
---|---|
Headers | show |
Series | mm/gup: introduce vaddr_pin_pages_remote(), FOLL_PIN | expand |
On Tue, Aug 20, 2019 at 09:07:24PM -0700, John Hubbard wrote: > Hi Ira, > > This is for your tree. I'm dropping the RFC because this aspect is > starting to firm up pretty well. > > I've moved FOLL_PIN inside the vaddr_pin_*() routines, and moved > FOLL_LONGTERM outside, based on our recent discussions. This is > documented pretty well within the patches. > > Note that there are a lot of references in comments and commit > logs, to vaddr_pin_pages(). We'll want to catch all of those if > we rename that. I am pushing pretty hard to rename it to > vaddr_pin_user_pages(). > > v1 of this may be found here: > https://lore.kernel.org/r/20190812015044.26176-1-jhubbard@nvidia.com I am really sorry about this... I think it is fine to pull these in... There are some nits which are wrong but I think with the XDP complication and Daves' objection I think the vaddr_pin information is going to need reworking. So the documentation there is probably wrong. But until we know what it is going to be we should just take this. Do you have a branch with this on it? The patches don't seem to apply. Looks like they got corrupted somewhere... :-/ Thanks, Ira > > John Hubbard (3): > For Ira: tiny formatting tweak to kerneldoc > mm/gup: introduce FOLL_PIN flag for get_user_pages() > mm/gup: introduce vaddr_pin_pages_remote(), and invoke it > > drivers/infiniband/core/umem.c | 1 + > include/linux/mm.h | 61 ++++++++++++++++++++++++++++++---- > mm/gup.c | 40 ++++++++++++++++++++-- > mm/process_vm_access.c | 23 +++++++------ > 4 files changed, 106 insertions(+), 19 deletions(-) > > -- > 2.22.1 > >
On 8/22/19 5:24 PM, Ira Weiny wrote: > On Tue, Aug 20, 2019 at 09:07:24PM -0700, John Hubbard wrote: >> Hi Ira, >> >> This is for your tree. I'm dropping the RFC because this aspect is >> starting to firm up pretty well. >> >> I've moved FOLL_PIN inside the vaddr_pin_*() routines, and moved >> FOLL_LONGTERM outside, based on our recent discussions. This is >> documented pretty well within the patches. >> >> Note that there are a lot of references in comments and commit >> logs, to vaddr_pin_pages(). We'll want to catch all of those if >> we rename that. I am pushing pretty hard to rename it to >> vaddr_pin_user_pages(). >> >> v1 of this may be found here: >> https://lore.kernel.org/r/20190812015044.26176-1-jhubbard@nvidia.com > > I am really sorry about this... > > I think it is fine to pull these in... There are some nits which are wrong but > I think with the XDP complication and Daves' objection I think the vaddr_pin > information is going to need reworking. So the documentation there is probably > wrong. But until we know what it is going to be we should just take this. > Sure, I was thinking the same thing: FOLL_PIN is clearing up, but vaddr_pin_pages() is still under heavy discussion. > Do you have a branch with this on it? > Yes, it's on: git@github.com:johnhubbard/linux.git , branch: vaddr_FOLL_PIN_next > The patches don't seem to apply. Looks like they got corrupted somewhere... > Lately I'm trying out .nvidia.com outgoing servers for git-send-email, so I'm still nervous about potential email-based patch problems. I suspect, though, that it's really just a "must be on exactly the right commit in order to apply" situation. Please let me know, so I can make any corrections necessary on this end. thanks,