diff mbox series

[v2,1/2] thermal: armada: fix register offsets for AXP

Message ID BN8PR10MB3379A954079A4ECF574E80DE8C5D0@BN8PR10MB3379.namprd10.prod.outlook.com (mailing list archive)
State Changes Requested
Delegated to: Zhang Rui
Headers show
Series [v2,1/2] thermal: armada: fix register offsets for AXP | expand

Commit Message

Zachary Hays Dec. 5, 2019, 2:19 p.m. UTC
As shown in its device tree, Armada XP has the control1 register at
0x184d0, not 0x182d0.

Signed-off-by: Zachary Hays <zhays@lexmark.com>
---
v2: update commit title and add "Signed-off-by"
---
 drivers/thermal/armada_thermal.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.7.4

Comments

Daniel Lezcano Dec. 9, 2019, 3:42 p.m. UTC | #1
Hi Zak,

what patch to pick up? V2 or V2?

What email is the correct one?

	Zachary Hays <zhays@lexmark.com>
or
	Zak Hays <zak.hays@lexmark.com>

Also waiting for Miquel to ack the patch.

Thanks

  -- Daniel


On 05/12/2019 15:19, Zak Hays wrote:
> As shown in its device tree, Armada XP has the control1 register at
> 0x184d0, not 0x182d0.
> 
> Signed-off-by: Zachary Hays <zhays@lexmark.com>
> ---
> v2: update commit title and add "Signed-off-by"
> ---
>  drivers/thermal/armada_thermal.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/thermal/armada_thermal.c b/drivers/thermal/armada_thermal.c
> index 709a22f455e9..88363812033c 100644
> --- a/drivers/thermal/armada_thermal.c
> +++ b/drivers/thermal/armada_thermal.c
> @@ -578,7 +578,7 @@ static const struct armada_thermal_data armadaxp_data = {
>         .coef_m = 10000000ULL,
>         .coef_div = 13825,
>         .syscon_status_off = 0xb0,
> -       .syscon_control1_off = 0xd0,
> +       .syscon_control1_off = 0x2d0,
>  };
> 
>  static const struct armada_thermal_data armada370_data = {
> --
> 2.7.4
>
Zachary Hays Dec. 9, 2019, 4:31 p.m. UTC | #2
Hi Daniel,

>Hi Zak,
>
>what patch to pick up? V2 or V2?
I'm not sure I entirely understand your question. There are two patches:

Zachary Hays  thermal: armada: fix register offsets for AXP
Zachary Hays  thermal: armada: clear reset in armadaxp_init

Version 2 of each patch updates the commit message to add a "Signed-off-by"
and cleans up the commit message per Miquèl's earlier comments. Otherwise the
patches are the same as they were in version 1. The patch below is version 2 of that first patch.

Does that answer your question?
>
>What email is the correct one?
>
>        Zachary Hays <zhays@lexmark.com>
>or
>        Zak Hays <zak.hays@lexmark.com>
>
Both addresses route to the same place but "Zachary Hays <zhays@lexmark.com>" is preferable. Sorry for the confusion.

>Also waiting for Miquel to ack the patch.
>
>Thanks
>
> -- Daniel
>
>
>On 05/12/2019 15:19, Zak Hays wrote:
>> As shown in its device tree, Armada XP has the control1 register at
>> 0x184d0, not 0x182d0.
>>
>> Signed-off-by: Zachary Hays <zhays@lexmark.com>
>> ---
>> v2: update commit title and add "Signed-off-by"
>> ---
>>  drivers/thermal/armada_thermal.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/thermal/armada_thermal.c b/drivers/thermal/armada_thermal.c
>> index 709a22f455e9..88363812033c 100644
>> --- a/drivers/thermal/armada_thermal.c
>> +++ b/drivers/thermal/armada_thermal.c
>> @@ -578,7 +578,7 @@ static const struct armada_thermal_data armadaxp_data = {
>>         .coef_m = 10000000ULL,
>>         .coef_div = 13825,
>>         .syscon_status_off = 0xb0,
>> -       .syscon_control1_off = 0xd0,
>> +       .syscon_control1_off = 0x2d0,
>>  };
>>
>>  static const struct armada_thermal_data armada370_data = {
>> --
>> 2.7.4
>>
Daniel Lezcano Dec. 9, 2019, 4:39 p.m. UTC | #3
On 09/12/2019 17:31, Zak Hays wrote:
> Hi Daniel,
> 
>> Hi Zak,
>>
>> what patch to pick up? V2 or V2?
> I'm not sure I entirely understand your question. There are two patches:
> 
> Zachary Hays  thermal: armada: fix register offsets for AXP
> Zachary Hays  thermal: armada: clear reset in armadaxp_init

I'm seeing multiple posting of the V2 and reply to V2 with I guess a
changelog added.

It is very difficult to deal with patches when it is unclear, duplicate
series with different changelog.

In the future, post a resend version explaining what was missing, so it
is easier to understand what is happening. Or send a V3.

> Version 2 of each patch updates the commit message to add a "Signed-off-by"
> and cleans up the commit message per Miquèl's earlier comments. Otherwise the
> patches are the same as they were in version 1. The patch below is version 2 of that first patch.
> 
> Does that answer your question?
>>
>> What email is the correct one?
>>
>>        Zachary Hays <zhays@lexmark.com>
>> or
>>        Zak Hays <zak.hays@lexmark.com>
>>
> Both addresses route to the same place but "Zachary Hays <zhays@lexmark.com>" is preferable. Sorry for the confusion.
> 
>> Also waiting for Miquel to ack the patch.
>>
>> Thanks
>>
>> -- Daniel
>>
>>
>> On 05/12/2019 15:19, Zak Hays wrote:
>>> As shown in its device tree, Armada XP has the control1 register at
>>> 0x184d0, not 0x182d0.
>>>
>>> Signed-off-by: Zachary Hays <zhays@lexmark.com>
>>> ---
>>> v2: update commit title and add "Signed-off-by"
>>> ---
>>>  drivers/thermal/armada_thermal.c | 2 +-
>>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/thermal/armada_thermal.c b/drivers/thermal/armada_thermal.c
>>> index 709a22f455e9..88363812033c 100644
>>> --- a/drivers/thermal/armada_thermal.c
>>> +++ b/drivers/thermal/armada_thermal.c
>>> @@ -578,7 +578,7 @@ static const struct armada_thermal_data armadaxp_data = {
>>>         .coef_m = 10000000ULL,
>>>         .coef_div = 13825,
>>>         .syscon_status_off = 0xb0,
>>> -       .syscon_control1_off = 0xd0,
>>> +       .syscon_control1_off = 0x2d0,
>>>  };
>>>
>>>  static const struct armada_thermal_data armada370_data = {
>>> --
>>> 2.7.4
>> >
Zachary Hays Dec. 9, 2019, 4:58 p.m. UTC | #4
>On 09/12/2019 17:31, Zak Hays wrote:
>> Hi Daniel,
>>
>>> Hi Zak,
>>>
>>> what patch to pick up? V2 or V2?
>> I'm not sure I entirely understand your question. There are two patches:
>>
>> Zachary Hays  thermal: armada: fix register offsets for AXP
>> Zachary Hays  thermal: armada: clear reset in armadaxp_init
>
>I'm seeing multiple posting of the V2 and reply to V2 with I guess a
>changelog added.
>
>It is very difficult to deal with patches when it is unclear, duplicate
>series with different changelog.
>
>In the future, post a resend version explaining what was missing, so it
>is easier to understand what is happening. Or send a V3.

Ah. I understand now. I've been fighting email issues trying to get these patches sent and
inadvertently sent out multiple versions of the same patches. The most recent patches
are correct. Sorry for that spam. Shouldn't happen again.

Would you like me to resend as V3 for clarity or would you prefer to continue with the
V2 patches?

>
>> Version 2 of each patch updates the commit message to add a "Signed-off-by"
>> and cleans up the commit message per Miquèl's earlier comments. Otherwise the
>> patches are the same as they were in version 1. The patch below is version 2 of that first patch.
>>
>> Does that answer your question?
>>>
>>> What email is the correct one?
>>>
>>>        Zachary Hays <zhays@lexmark.com>
>>> or
>>>        Zak Hays <zak.hays@lexmark.com>
>>>
>> Both addresses route to the same place but "Zachary Hays <zhays@lexmark.com>" is preferable. Sorry for the confusion.
>>
>>> Also waiting for Miquel to ack the patch.
>>>
>>> Thanks
>>>
>>> -- Daniel
>>>
>>>
>>> On 05/12/2019 15:19, Zak Hays wrote:
>>>> As shown in its device tree, Armada XP has the control1 register at
>>>> 0x184d0, not 0x182d0.
>>>>
>>>> Signed-off-by: Zachary Hays <zhays@lexmark.com>
>>>> ---
>>>> v2: update commit title and add "Signed-off-by"
>>>> ---
>>>>  drivers/thermal/armada_thermal.c | 2 +-
>>>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>>>
>>>> diff --git a/drivers/thermal/armada_thermal.c b/drivers/thermal/armada_thermal.c
>>>> index 709a22f455e9..88363812033c 100644
>>>> --- a/drivers/thermal/armada_thermal.c
>>>> +++ b/drivers/thermal/armada_thermal.c
>>>> @@ -578,7 +578,7 @@ static const struct armada_thermal_data armadaxp_data = {
>>>>         .coef_m = 10000000ULL,
>>>>         .coef_div = 13825,
>>>>         .syscon_status_off = 0xb0,
>>>> -       .syscon_control1_off = 0xd0,
>>>> +       .syscon_control1_off = 0x2d0,
>>>>  };
>>>>
>>>>  static const struct armada_thermal_data armada370_data = {
>>>> --
>>>> 2.7.4
>> >>
Daniel Lezcano Dec. 9, 2019, 5:11 p.m. UTC | #5
On 09/12/2019 17:58, Zak Hays wrote:
>> On 09/12/2019 17:31, Zak Hays wrote:
>>> Hi Daniel,
>>>
>>>> Hi Zak,
>>>>
>>>> what patch to pick up? V2 or V2?
>>> I'm not sure I entirely understand your question. There are two patches:
>>>
>>> Zachary Hays  thermal: armada: fix register offsets for AXP
>>> Zachary Hays  thermal: armada: clear reset in armadaxp_init
>>
>> I'm seeing multiple posting of the V2 and reply to V2 with I guess a
>> changelog added.
>>
>> It is very difficult to deal with patches when it is unclear, duplicate
>> series with different changelog.
>>
>> In the future, post a resend version explaining what was missing, so it
>> is easier to understand what is happening. Or send a V3.
> 
> Ah. I understand now. I've been fighting email issues trying to get these patches sent and
> inadvertently sent out multiple versions of the same patches. The most recent patches
> are correct. Sorry for that spam. Shouldn't happen again.
> 
> Would you like me to resend as V3 for clarity or would you prefer to continue with the
> V2 patches?

A V3 please, so I can pick them up without ambiguity from patchwork.

Thanks!
diff mbox series

Patch

diff --git a/drivers/thermal/armada_thermal.c b/drivers/thermal/armada_thermal.c
index 709a22f455e9..88363812033c 100644
--- a/drivers/thermal/armada_thermal.c
+++ b/drivers/thermal/armada_thermal.c
@@ -578,7 +578,7 @@  static const struct armada_thermal_data armadaxp_data = {
        .coef_m = 10000000ULL,
        .coef_div = 13825,
        .syscon_status_off = 0xb0,
-       .syscon_control1_off = 0xd0,
+       .syscon_control1_off = 0x2d0,
 };

 static const struct armada_thermal_data armada370_data = {